1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Switching the Humax from wireless to cable

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by linuxtowers, Dec 3, 2011.

  1. linuxtowers

    linuxtowers Member

    I'm having problems with the Humax hogging the wireless connection when FTPing a file from the humax to a PC, none of my wireless devices can access the Internet during a FTP download.

    Also if I change the Transmission app setting using the web to unlimited download / upload speed, then I can't access the Transmission from the web interface, get a server connection error, if limit the speed to 300, its fine.

    I using a BT hub 3 over BT Infinity 39mps download / 8mps upload, which is dam fast.

    When I use my Samsung Galaxy S2 Andriod phone to access the Internet over wireless the Speedtest.net app states that the phones wireless speed is >26mps download and full 8mps upload, so there seems not to be a bandwidth problem with the phone.

    Samba transfers seem to be fine, does stop other wireless devices accessing the hub.

    I just found that I can daisy chain hubs, so I was thinking of connecting my new hub to the BT hub to give me more cable Ethernet connections to free up a spare cable connection.

    So if I was to remove the wireless dongle from the Humax, and connect the Humax directly to my BT hub, would fix my wireless bandwidth problem?

    I'm using the RS, WebIf, samba and Transmission packages, will I need to uninstall and setup all these working services again or will it just work after a reboot if the Ethernet cable is fitted?

    Also I assume I need to remove the wireless helper package, and note down the new IP address that the router will issue because the Humax MAC address will be different for the cable connection?

    I'm a bit scared to change anything at the moment because the RS and webif is working so good, just got a silly bandwidth issue with the Humax taking over the wireless access...
     
  2. Sam Widges

    Sam Widges Active Member

    Because of the way that wireless works, there is only a set amount of bandwidth (network capacity) that has to be shared between all wireless hosts. It's even worse if the PC is wireless as well because then all the traffic has to go from the source to the hub and then from the hub to the destination.

    Using a wired connection will make things a lot better.
     
  3. Black Hole

    Black Hole Felinos Guru

    I keep as little wireless as possible, with a bit of lee-way for laziness. My philosophy is: if it's in a fixed place, provide a wire - although that can mean HomePlug.

    Even on HomePlug there can be bandwidth contention: it's like another wireless network but along the mains cables. With a Cat5 network there is no contention - for one thing you have a 100Mbps channel each way, and for another most "hubs" these days are actually switches, so the traffic from point A to point B doesn't affect the traffic from point C to point D even if it goes through the same switch - as long as it does not share a common wire anywhere.
     
  4. linuxtowers

    linuxtowers Member

    Thanks for your help.

    My PC is on cable and is connected to the BT hub via the 1 Gbs output.

    Just can't get my head around the wirless bandwidth problem, I understand the Humax limited its speed due it only having a slow CPU (and needs to hangle HD recording in the background), but how is the humax effecting other devies on the same wireless network i.e. my phone & wireless laptops ?

    If I run a Andriod App called Fing, it shows my phone and laptop connected to the BT hub at 65Mbs wirelessly, and the humax at 35Mbs, there should be massive bandwidth on the wireless connection, maybe the Humax is forcing the network to a lower speed ?

    What I would like to know if I convert the Humax from a wireless connection to a cable connection will all the Customised Firmware still work, or would I have to reinstall everything again from scratch ???
     
  5. Black Hole

    Black Hole Felinos Guru

    No reason it shouldn't just work.

    As an aside, your PC may be connected to the Gigabit Ethernet port of your router, but are you sure it is actually using it?
     
  6. linuxtowers

    linuxtowers Member

    Thanks Black Hole, I will get it a try later.

    The BT hub says it connected at 1Gbs and the PC 'Local Area Connection' status is connected at 1Gbs using IPv4, I can transfer very large files over wireless to my phone or to a laptop (wired or wireless) at very high speeds, no problem.

    My problem is on the wireless side, even if the Desktop PC (connected via cable) is switched off, my phone or a Laptops (connected via wireless) will not connect to the Internet or the Webif, if the Humax is downloading files over FTP.

    If I power up the Desktop PC (wired) and start a FTP session with the Humax (wireless) to download files to the PC from the Humax, none of my wireless devices can use the wireless connection, humax seems to take over the whole wireless network, as soon as the FTP has transferred the files, the wireless network is fine; Same goes for Transmission, if I set the speed to unlimited then I get the same problem, limit the change the speed to 200bps and its fine.

    It's driving me mad, because I am stopping everyone from using the Internet over wireless (Internet can be accessed (wired) at anytime no problem from my Desktop PC).

    Did think that it was due to the wireless devices been different types, i.e. my phone can do full 802.11n (150 Mbs) on 2.4 GHz or 5 GHz bands, where the Humax wireless dongle probably is only 802.11b and 802.11g and uses 2.4 GHz only.

    I worked on wireless Embedded Linux drivers and I know how complex wireless can be, maybe I should run Wireshark on my network, trouble is I need to special wireless dongle and I'm not sure who I lent it to...

    The Humax only transfer files are very low speeds to protect the HD recording functions, but why should it effect everything else on the network if it is sending packets slowly.
     
  7. Sam Widges

    Sam Widges Active Member

    When you send a wireless packet then no other devices can communicate until that packet has been sent - only one device on a wireless network can send at a time. If your network can support, say, 50 packets per second and the Humax uses 45 of those packets, then the other devices (phone, laptops and the hub) are scrabbling for the other 5, except it's made worse because they then have to compete with each other and they may not get the chance of sending anything at all.

    Some devices will affect the overall speed of the network - Wireless N, for instance, won't run at full speed unless all the devices on the wireless network are Wireless N (if I remember correctly)

    Changing from wired to wireless will have no effect on the use of customised firmware.
     
  8. linuxtowers

    linuxtowers Member

    Sam Widges,

    Thanks for your reply.
    If what you say is true then it explains the speed loss, I didn't think Ethernet was blocking, I thought other packages could get in between each transaction, once a packet has been transmitted on the network and ACKed.

    You are right about fast Wireless N devices will have to be switched down to the lowest speed on the wireless network at the connect stage.
    As Black Hole said, most wired hubs are really switches, so can divert packages traffic in a more efficient way, but maybe this isn't true for wireless.

    I thought wireless Ethernet was just another layer on top of the network stack, and packets can arrive on the TCP network in any order.

    Anyway, I will try moving over to wired and see if this improves my wireless speed.
     
  9. Black Hole

    Black Hole Felinos Guru

    Talking out of my back side here, but maybe the wifi dongle on the Humax doesn't play nicely and drop the line between packets? You clearly know much more about these things than me.
     
  10. linuxtowers

    linuxtowers Member

    Could be right Black Hole, something is locking up the network and its the humax I think.
     
  11. linuxtowers

    linuxtowers Member

    I removed the Humax wireless USB adapter and plugged a Ethernet cable, and placed the Humax into standby waited for the HDD click, and powered up again, everything is working fine up to now.

    Check RS, and it is showing the wired MAC address, great stuff !

    Ran my Fing app, and it showed me the new wired IP address (static IP) the BT router has assigned, so check the Webif using the new IP and its fine !

    Transmission is working fine as well.

    Samba is fine with new address from Windows and Android i.e. \\ipaddress\Media

    Thanks guys! Seems to be working, no problems swapping over, must be using host names instead of IP addresses.

    For the record the Humax wireless USB adapter says its a 150N, so should be very fast, using the 802.11 N (150 Mbs) standard, maybe this is only under windows ?

    This has got me thinking, would it be easy to write a simple script (Jim /bash) to copy downloaded files from the internal drive to the external USB drive using Telnet, than using Samba or FTP.

    I try using the move option within the Humax menu to save on network bandwidth, but it only moves files with extensions it supports, which is poor and leaves some of the files behind.

    I tired the following Telnet commands which works:

    ls /mnt/hd2/'My Video'/torrent (Target files area)
    ls /media/usb-drive1/Vids (Destination external USB drive location)

    But why can't I copy the files to the external drive ?

    Example: cp /mnt/hd2/'My Video'/torrent/*.* /media/usb-drive1/Vids/*.*

    I get a "cp: omitting directory " error ?
     
  12. xyz321

    xyz321 Well-Known Member

    The shell expands the '*'s before executing the cp command. Say you had a.ts, b.ts in the "torrent" directory and c.ts and d.ts in the "Vids" directory. This would be expanded to the following (omitting the directories for clarity).
    Code:
    cp a.ts b.ts c.tc d.ts
    which would try to copy the files a.ts, b.ts & c.ts into d.ts. Usually this will fail bcause cp would expect to see a directory as the last argument when copying multiple files. Try replacing cp with echo in your command above to see how it all gets expanded.

    What you really need is:
    Code:
    cp /mnt/hd2/"My Video"/torrent/* /media/usb-drive1/Vids/
    Note that the dot is not really significant in the unix world, it is just another character which may or may not be present in the file name.

    You may still get an omitting directory warning. This will be because there is a sub-directory within your source directory which will not have been copied. To copy this as well use the '-r' recursive option.
     
  13. linuxtowers

    linuxtowers Member

    Thanks xyz123, I fully understand now, thought it may be down to some linux symbolic link resolve issue. Good tip about using 'echo' command.

    Could you possibly tell me where the transmission config file lives in the file system ?

    I would like to change the defaults for the download path (to the external hdd if fitted) and the max uploads rate to 50k, and the download rate to unlimited.

    Tried changing them using the web interface, but doesn't seem to save the values. After the RS
    has done it shut down and wakeup there settings go back to default values...
     
  14. xyz321

    xyz321 Well-Known Member

    /mod/etc/transmission/settings.json

    Note though that there is a minor bug in the package configuration in that this file has not been declared as a config file. This means that a future version update may overwrite this file.
     
  15. linuxtowers

    linuxtowers Member

    Thanks again xyz123,

    I noticed the settings.json file had today's time/date on it, so not sure which process is touching the file.

    Could be seeing things, but did see the Daemon swap the "alt-speed-down": 400 "alt-speed-up": 30 around in the settings.json, could be me...

    Don't understand why the transmission web interface doesn't "save" the changes in the settings.json, only seems to change the parameter settings in memory, after the HDR sleeps it goes back to the defaults of Turtle mode (which is good if your connection is over wireless).

    https://trac.transmissionbt.com/wiki/EditConfigFiles
    "The above sites states it's not always possible to set all configurations from the GUI, especially on the Daemon or the Web Interface."

    For a test, I have changed the settings.json file to turn off Turtle mode and limited the upload speed to 30, and set download speed to max (for wired connections).

    When in Turtle mode limit the upload to 30 and download to 400 (wireless max).

    "alt-speed-down": 400
    "alt-speed-enabled": false
    "alt-speed-up": 30
    "speed-limit-up": 30
    "speed-limit-up-enabled": true

    The next stage if the settings file doesn't get overwritten, is to change the default complete path to the external USB drive, not sure what will happen if the drive is disconnected.

    "download-dir": "/media/usb-drive1/Vids"

    Maybe I could detect in the start-up script for transmission-daemon if the external drive is present
    https://trac.transmissionbt.com/wiki/ConfigFiles#Locations

    My Android phone can open the "Preferences" dialogue in it's web browser, but not the Total Download / Upload Rate sub menu, so I have to power up the PC which was a pain.

    But now I can easy toggle the Temporary Speed Limits (Turtle) icon on/off, when I want my broadband bandwidth back.
     
  16. linuxtowers

    linuxtowers Member

    Forgot to add, I had problems with the copy command using Telnet, when I exited the connection the copy stopped, so the solution was to make the process a backgroud job by using "&" option, hope this helps someone...

    cp /mnt/hd2/"My Video"/torrent/* /media/usb-drive1/Vids/ -r &
     
  17. Black Hole

    Black Hole Felinos Guru

    Yes, thanks, we've been tutored in the "&" suffix but worth repeating to drive it home!
     
  18. linuxtowers

    linuxtowers Member

    I thought I would mention it, for someone that's new to Linux, because if your moving very large files it can take days, you don't what to leave your PC or Smart phone connected for that length of time.

    Is there a exclusion flag with the cp command to exclude a folder name, i.e. exclude copying the 'incomplete' sub directory ?

    Would I have to use the 'find' command, example find /path -maxdepth 0 -type d ! -name "*exclude*" -exec cp -r "{}" /destination \;

    I'm no Bash expert, it's GCC make files and low level Embedded comms device drivers I'm good at...:oops:

    My next stage is to create a executable script to do the copy, and find the best place in the file system to place it, be good to be able call it from the webif button.

    Maybe better to just save the files on the external USB drive in the first place and don't worry about errors if the drive is not connected, just takes 40 seconds to wake up the external drive.

    Thanks for every ones help.
     
  19. Black Hole

    Black Hole Felinos Guru

    I'm not sure of the details, but one place you can fire up an arbitrary script from is the diagnostics page.
     
  20. linuxtowers

    linuxtowers Member

    Good idea, I will have a play when I get time, Thanks.