1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Telnet Prompt

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Black Hole, Nov 22, 2011.

  1. Black Hole

    Black Hole Ron Glum

    It's only a minor irritation, but running the Windows7 Telnet client when I connect to either HDR-FOX or HD-FOX the Humax# prompt is always doubled (two lines). I'm used to old-fashioned serial line terminals doing a local echo of your typed line and then getting a repeat back from the remote end (if you don't turn it off), but this is the string being originated from the remote end twice.

    Does it do that for everyone, and if not how do I stop it?

    All I can think of is an incompatibility between Windows and Linux - maybe CR-LF is being interpreted as two end-of-lines?
     
  2. af123

    af123 Administrator Staff Member

    You're right, the remote end is interpreting it as two separate newlines, most likely because the telnet client is sending a telnet newline escape sequence as well as a CR/LF.

    Windows telnet isn't the greatest client out there but you could try the two different crlf options that it has:

    Code:
    Welcome to Microsoft Telnet Client
    
    Escape Character is 'CTRL+]'
    
    Microsoft Telnet> set crlf
    New line mode - Causes return key to send CR & LF
    Microsoft Telnet> open humax
    
    If that doesn't work, try
    Code:
    unset crlf
    PuTTY works very well - you just need to make sure you untick the box under Connection->Telnet->Return key sends Telnet New Line instead of ^M or you'll get the same problem.
     
    Black Hole likes this.
  3. Black Hole

    Black Hole Ron Glum

    "unset crlf" did the trick.