Unable to access web interface after CF install

Fred z

New Member
Hi guys, looking for some help with problems I have with the custom firmware post installation.

I am running a HDR FOX T2 and have just upgraded to firmware version 1.03.12 and then applied custom firmware 1.03.12 mod 3.0 following the install guides on the forum.

When I connect to the web interface to press the button and complete the download of the system, the system goes through downloading the opk's (packages) and the reports back at the end that there are no further downloads etc required and that's it! - it does nothing after this point I.e does not tell me to reboot, doesn't say anything about package configuration or anything.

At this point if I hit refresh on the browser it tells me all packages are current and to reboot the system in the appropriate manor. When the system restarts the web interface does not respond. I can connect to telnet issue diag instructions ( general / disk check) which all pass and I have even logged onto the CLI and done a forced webif package re-install with the same outcome - its almost as if there is some persitant corruption with the underlying web server or webif package that rerunning the firmware update, custom firmware or system flush file does not clear!?!!?

Can anyone help?
 

Ezra Pound

Well-Known Member
You can check the install status of lightpd (the web server) and swapper from telnet with opkg info lighttpd / opkg info swapper e.g. :-
Code:
humax# opkg info lighttpd
Package: lighttpd
Version: 1.4.35-2
Depends: swapper
Provides:
Status: install ok installed
Section: web
Architecture: mipsel
Maintainer: af123@hummypkg.org.uk
MD5Sum: 5ce685f654c827b1a39a61679ed6163d
Size: 233092
Filename: lighttpd_1.4.35-2_mipsel.opk
Conffiles:
/mod/etc/lighttpd/extra.conf 7bfa62271212309f1568ac2a03a2532e
Description: Lightweight web server
Installed-Time: 1400090771


humax# opkg info swapper
Package: swapper
Version: 1.0.1
Provides:
Status: install ok installed
Section: admin
Architecture: mipsel
Maintainer: af123
MD5Sum: 6605da32ee95fd7113733d20c9b269e5
Size: 868
Filename: swapper_1.0.1_mipsel.opk
Description: Sets up swap space.
Installed-Time: 1400090772
 
OP
F

Fred z

New Member
hi ezra,

thanks for the fast response - checked and output appears to be correct as per your post

humax# opkg info lighttpd
Package: lighttpd
Version: 1.4.35-2
Depends: swapper
Provides:
Status: install ok installed
Section: web
Architecture: mipsel
Maintainer: af123 hummypkg.org.uk
MD5Sum: 5ce685f654c827b1a39a61679ed6163d
Size: 233092
Filename: lighttpd_1.4.35-2_mipsel.opk
Conffiles:
/mod/etc/lighttpd/extra.conf 7bfa62271212309f1568ac2a03a2532e
Description: Lightweight web server
Installed-Time: 1411251048

humax# opkg info swapper
Package: swapper
Version: 1.0.1
Provides:
Status: install ok installed
Section: admin
Architecture: mipsel
Maintainer: af123
MD5Sum: 6605da32ee95fd7113733d20c9b269e5
Size: 868
Filename: swapper_1.0.1_mipsel.opk
Description: Sets up swap space.
Installed-Time: 1411251048

(modified the email address due to posting restrictions!)

thoughts?
 
OP
F

Fred z

New Member
interestingly lighttpd does not show but mongoose does - i went through a number of threads on the forum yesterday and realised that mongoose had been depreciated - but couldnt figure out if lighttpd should be called as a service or not?!?!

output:

humax# service

Name Installed Autostart Running
---- --------- --------- -------
mediatomb No No No
dropbear No No No
transmission No No No
samba No No No
nfs No No No
cifs No No No
mongoose Yes No No
betaftpd No No No
 

Ezra Pound

Well-Known Member
I was going to make the same suggestion as raydon, but for some reason lighttpd is not included in the 'service' list, so your list is the same as my working Humax. Lighttpt replaced mongoose, which in the earlier versions of the CFW would have shown 'Yes - Yes - Yes' but was 'turned off' in this version

I would run the command line below this is similar to the force re-install web-if that you have already run but it does a bit of tidying up first
Code:
humax# diag fix-webif
 
Last edited:
OP
F

Fred z

New Member
i guess the service for lighttpd should have been created as part of the install process - can it be recreated or is it best to try another reinstall?

I have already 're flashed' the device several times with the same outcome so im wondering if there is a way of completely clearing it down (without losing the recordings)?
 

Ezra Pound

Well-Known Member
Did you see #6? lighttpd is never displayed in the service list even when it is running correctly. Did you try this?
Code:
humax# diag fix-webif
 
OP
F

Fred z

New Member
ezra - apologies i missed the diag fix-webif command

modified output below (removed h t t p for spam rule) with errors!

humax# diag fix-webif
Running: fix-webif
Removing package webif from root...
Not deleting modified conffile /mod/webif/html/favicon.ico.
Collected errors:
* file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico: No such file or directory.
Downloading *************/hdrfoxt2/base/Packages.gz.
Inflating ************/hdrfoxt2/base/Packages.gz.
Updated list of available packages in /mod/var/opkg/base.
Installing webif (1.0.16-4) to root...
Downloading *************/hdrfoxt2/base/webif_1.0.16-4_mipsel.opk.
Configuring webif.
SMART: (PASSED)
realloc: 0
spinretry: 0
pending: 0
offline: 0
 

raydon

Well-Known Member
Apologies for the bum information given earlier regarding the service command. I realised afterwards that I had added lighttpd to the service list myself, as the service-control package was not updated when mongoose was deprecated. It's easy enough to add it yourself if you have the means to edit the file "/mod/etc/modservices". Just add the line:
"lighttpd:/mod/sbin/lighttpd:01lighttpd:/mod/sbin/lighttpd"
However, if you do this be aware that you can then stop (and disable auto-start) the lighttpd server via the web interface itself, effectively pulling the rug out from beneath yourself.
Anyway, regardless of this you can still check the status of lighttpd using the "ps" or "pgrep" commands.
"/bin/ps | grep lighttpd" should list three worker threads for lighhttpd if it's running. Output looks like this:
HDRFOXT2# /bin/ps | grep lighttpd
767 root 3312 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf
772 root 3588 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf
773 root 3588 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf

Similarly using "pgrep lighttpd" should list the same three processes like this:
HDRFOXT2# pgrep lighttpd
767
772
773

If it's not running then entering "/mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf" should start it, or at least generate an error message.
There are also two lighttpd log files which may provide additional information. Try:
"cat /tmp/webif.log" or "cat /tmp/webif-error.log" to list them.
 
OP
F

Fred z

New Member
hi raydon - no worries about the service command :)

output of my ps statements - looks good in comparison to yours albar the process id statements being different;

humax# ps | grep lighttpd
614 root 3244 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf
615 root 3264 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf
616 root 3264 S N /mod/sbin/lighttpd -f /mod/etc/lighttpd/server.conf
933 root 1344 S N grep lighttpd

humax# pgrep lighttpd
614
615
616​

Log File Output;

humax# cat webif.log
2014-09-22 17:50:17: (log.c.164) server started
humax# cat webif-error.log
humax#​

Interesting that the server has started and has no errors?!?!

Double checking that nothing wacky has gone into iptables:
humax# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
humax#​

could it be the lighttpd server conf? (really dont know/ guessing?!?!!?)
 
OP
F

Fred z

New Member
Output (without trying to connect http):
humax# netstat -tln
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN​

Output (when trying to connect http)
humax# netstat -tln
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:9955 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:9001 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:50001 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:23 0.0.0.0:* LISTEN​
 

prpr

Well-Known Member
Looks normal to me. Can you Telnet to port 80 on the Humax from whatever device you are trying to browse from?

What exactly does "the web interface does not respond" mean anyway? What do you see?
 
OP
F

Fred z

New Member
telnet works fine on port 23 (as you would expect) no response on port 80 so you cant even send a get/ put.

What exactly does "the web interface does not respond" mean anyway? What, exactly, do you see?

Simple answer - nothing - Browser just sits at 'connecting' and does not respond. I have tried on 3 different devices with '4' different browsers same response; additionally I have put the browser into diag mode and performed a packet capture - you can see the connection request being sent but 'absolutely no response' from the the web server at the other end i.e. just sits waiting for a response..​
 
OP
F

Fred z

New Member
minor update I have also tried telnet from the humax box (localhost) to itself (localhost) on port 80 - no response

I can telnet from the humax bot to other external systems

Im beginning to think that there is a config problem with lighttpd
 

raydon

Well-Known Member
Try accessing lighttpd from the box itself using wget from telnet. This will confirm whether the server is listening on port 80. Enter the following two commands which should retrieve the servers index.html to the /tmp directory. Obviously you will need to substitute your HDR's own IP address, or 127.0.0.1 for this to work.

cd /tmp
wget http://192.168.0.6


HDRFOXT2# cd /tmp
HDRFOXT2# wget http://192.168.0.6
Connecting to 192.168.0.6 (192.168.0.6:80)
index.html 100% |*******************************| 7995 0:00:00 ETA
HDRFOXT2#
 
OP
F

Fred z

New Member
output using loopback;

humax# wget http://127.0.0.1
Connecting to 127.0.0.1 (127.0.0.1:80)
index.html 100% |*******************************| 9537 0:00:00 ETA
output using real address;

humax# wget http://192.168.0.1
Connecting to 192.168.0.1 (192.168.0.1:80)
index.html 100% |*******************************| 9537 0:00:00 ETA
Output of wget from a pc;

$ wget http://192.168.0.1
--2014-09-23 19:40:08-- http://192.168.0.1/
Connecting to 192.168.0.1:80... connected.
HTTP request sent, awaiting response... ^Z
so lighttpd is working locally but not external
 
OP
F

Fred z

New Member
So before going down the road of a pcap I assume that lighttpd has a server config module which sets the listen to address space - wondering if this could be throwing a spanner into works?

Can anyone post a working config for comparison?
 
Top