Undelete eratic behaviour

#1
Please note that on my HDR Fox T2 the package "undelete 1.3" has been installed, behaved in the following unexpected ways, and subsequently has been removed using the button in Package management, and yet the unexpected behaviour continues.

Unexpected Behaviour:
I delete 2 shows from My Video/NCIS contains 5 shows, Three shows should remain. I go to [Deleted Items] where I find NCIS which now contains ALL 5 shows! Checking the My Video directory NCIS has vanished!
To get round this I select [Deleted Items]/NCIS and delete the 2 shows I wanted to delete and then move the NCIS directory back to My Video.

After removal of the Undelete package:
The undelete function continues to work as before. If I delete the [Deleted Items] directory it is recreated next time I delete a file!
 

af123

Administrator
Staff member
#3
Unexpected Behaviour:
I delete 2 shows from My Video/NCIS contains 5 shows, Three shows should remain. I go to [Deleted Items] where I find NCIS which now contains ALL 5 shows! Checking the My Video directory NCIS has vanished!
That certainly isn't expected behaviour and nobody else has reported any issues - undelete only intercepts the deletions that are initiated by the Humax software, it doesn't start any by itself.

Can you talk us through how you are deleting multiple shows at once? You should just select the shows you want to delete (red button) then leave the cursor over one of the ones you don't want and press OPT+ followed by Delete. If you're selecting the two episodes then going back up and using OPT+ on the NCIS folder, then it will delete the whole thing.
 

Brian

Administrator
Staff member
#4
Can you talk us through how you are deleting multiple shows at once? You should just select the shows you want to delete (green button I think) then leave the cursor over one of the ones you don't want and press OPT+ followed by Delete. If you're selecting the two episodes then going back up and using OPT+ on the NCIS folder, then it will delete the whole thing.
Just to avoid any confusion, Red button is used to select individual programmes for deletion. Green button selects All programmes within the current folder for deletion.
 

Drutt

Active Member
#6
Could it be series-autofiler moving the folder and other episodes to where it thinks you now want it stored (ie the deleted items folder). Do you have series-autofiler installed as well?
 

af123

Administrator
Staff member
#7
Could it be series-autofiler moving the folder and other episodes to where it thinks you now want it stored (ie the deleted items folder). Do you have series-autofiler installed as well?
Good point - I don't think seriesfiler ever got updated to play nicely with undelete.
 
OP
OP
michael.h
#8
The following applies whether I use the remote or webif to delete one or more shows but not all in the directory.


1. Go to directory and select shows to be deleted using remote RED button or webif check boxes, NOT all in the directory.
2. While still in the directory with cursor on one of the show ticked for deletion I use OPT+ on remote or in webif and check boxes
have been used select the Delete button otherwise use the OPT+ button to delete an individual show.
3. Return to the My Video level, check that the show directory is still there, if not
4. Change to the [Deleted Items] directory then the particular show directory which has been moved from the My Video level.
5. I now delete the shows which I wanted to delete, no problem here.
6. Use remote to move the shows directory out of [Deleted Items] back the My Video level.



I would point out that this problem is erratic! Does not happen every time!
I am fully aware of the difference between the Red and Green buttons on the rremote.
I do have series-autofiler installed.
This problem occurs on both my HDR Fox T2s and on that of a friend.
It is my friend who removed undelete 1.3 and he has rebooted. I Have not removed undelete from either of my Hummies.

Thanks for your help
Michael
 

af123

Administrator
Staff member
#9
series-autofiler is causing this. It finds the folder under [Deleted Items] and assumes you want to file the new recordings there as well. It needs an update to ignore folders starting with a [ character. autofiler runs periodically so it won't always move them straight away which is why it appears erratic.

For now, do not use undelete in conjunction with series-autofiler.
 
Top