Unencrypt is not unencrypting

Ezra Pound

Well-Known Member
Ezra, I didn't realise it was that simple!! I do normally put my Humax in standby at night, so that explains it then.
I will keep it out of standby tonight and see what it does.

I have added a note to the WiKi HERE , Originally the process ran every 30 Mins. but there were some complaints about picture break-up
EDIT
I will keep it out of standby tonight and see what it does

If this works O.K. you can set auto On / Off with MENU >> Settings >> Preferencies >> TIME >> Power On timer and set both On and off times

It is also possible, (as stated above ) to alter the cron job to replace the 1-6 with * but that is less safe
 
OP
Two Steps

Two Steps

New Member
Just thought I would let you know that unencrypt would seem to be working over night as predicted.

There are quite a few files on the Humax to get through, so they haven't all been done yet, but what it has done so far is encouraging.

Thanks again to everyone who assisted me.
 

Black Hole

May contain traces of nut
When I started running unencrypt I altered the schedule to start every five minutes all day so as to chew through the backlog a lot more quickly (if a file takes longer than 5 mins to process, and some do, the next 5 min slot gets ignored). It didn't have any ill effects - the cautious every-half-hour-through-the-night was because of early problems, now resolved I believe.

Now the backlog is clear, unencrypt hardly ever has to do anything, so there is no harm in lettting it check for new work every five mins - that way I get my decrypted file ASAP (and it is available to play as a network share).

My crontab line reads:

Code:
1,6,11,16,21,26,31,36,41,46,51,56 * * * * /mod/sbin/unencrypt "/mnt/hd2"
 

richardar

New Member
As a non tecchie and a new user of the CF package on my HDR Fox T2 how do I edit the cron line as above? I'm in Diagnostics/File Editor/Open but cron doesn't appear in the file list .

I've had Unencrypt running for a week and it has obviously worked on all the media files except one - the Olympic Closing Ceremony, which it doesn't want to know! Any ideas?

Another question - up to this morning, when I had to reboot my PC, Humax has always appeared under NETWORK in Explorer enabling me to access the files on the Humax HDD. After the PC reboot it's disappeared and I can't get it back. Samba is installed.
 

richardar

New Member
Sorry, forget the last point - when I removed the USB drive from the Humax onto which I was adding a file, the Humax reappeared under NETWORK on the PC .
 

Ezra Pound

Well-Known Member
richardar : I'm in Diagnostics/File Editor/Open but cron doesn't appear in the file list
You need to navigate to the folder where cron lives (in red below):-
cron.jpg

You could always use the Web-if 'Decrypt' for the single Olympics file
 

richardar

New Member
Ezra Thanks for your prompt reply. I've edited the appropriate cron line. With the Olympic file, I've tried the Opt+/Decrypt route but the Decrypt command is greyed out although Enc is still shown:. What's causing this?

Olympics 2012_ Closing Ceremony_20120812_2056.ts (15.22 GiB)
172_1_00_HD.png
749_1_26_Video_Encryption.png
dlna.png
 

richardar

New Member
Auto Unprotect was one of the first packages I installed. I removed and reloaded it last night (Humax on all the time) but it's made no difference to the symbols on the Olympic file this morning . Decrypt is still greyed out.
 

Ezra Pound

Well-Known Member
My first thought was, this is a big file and may-be that's why the Humax is having difficulty handling it, however I have much the same file on my humax where the ENC flag is removed. If you have re-loaded Auto unprotect you may need to power cycle your Humax for it to take effect. Am I correct in thinking that all your other Hi-Def files have had their ENC flag removed, as shown below?

olympic.jpg

BTW
I could not see the icons in your post, as they have links to your LAN e.g. "http://192.168.1.4/cgi-bin/browse.jim#"
 

richardar

New Member
The Olympic Opening Ceremony was a bigger file and the ENC flag has been removed from it just as it has from all the other HD files. By power cycle the Humax do you mean switch it off at the back, wait a few minutes and switch it back on? If so, I did this twice this morning. The ENC flag is still there.
 

Ezra Pound

Well-Known Member
Yes, it's the old 'IT Crowd' slogan. I guess there must be something about this particular file, there used to be a 'one-off' remove ENC function in the Web-If but it has been removed, the only other suggestionI have, is to use a program called FOXY (you only need stage 1) to remove the ENC flag, it uses FTP to edit the hmt file on a P.C.
EDIT
Before trying Foxy (It's a bit long winded), I would try xyz321's suggestion in #39, which I had forgetten about
 

richardar

New Member
Interesting. Although the file had the ENC symbol when I transferred it to the PC via FileZilla it opened normally in VLC - which I understood it shouldn't if it had really been encrypted. I then ran the .hmt file through Foxy (which I had used before I discovered the CF package), thansferred the file back to the Humax and, lo and behold, the only symbol there now is OPT+. So problem solved. Thanks for the help.
 
Top