1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unusual Failure Mode

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Black Hole, Oct 29, 2017.

  1. Black Hole

    Black Hole Felinos Guru

    My HDR4 front panel appears to have crashed. It shows "BBC ONE West" on the VFD, and I went into the WebIF virtual remote to switch it to RED BUTTON (my standard idle). The WebIF remote appeared to work, and the WebIF status shows Red Button, but the VFD still shows BBC ONE West and the HDMI output remains BBC ONE West. There is no response to the physical handset.

    Is there anything anyone would like me to look at before I try recovering by power cycling?
     
  2. prpr

    prpr Well-Known Member

    I've had that before. I gave up and power cycled it without being able to learn anything.
     
  3. Border

    Border Member

    did the clock go back?
     
  4. Black Hole

    Black Hole Felinos Guru

    How do I tell? I didn't look at it between the clock change and noticing the failure.

    The coincidence between the failure and the clock change is worthy of note - prpr did yours occur with the same coincidence?
     
  5. prpr

    prpr Well-Known Member

    No. It's happened a few times. I don't recall it ever being DST related.
     
  6. Black Hole

    Black Hole Felinos Guru

    af123: I don't understand how the WebIF can be confused about what service is currently tuned (still is). This seems to imply the processing system isn't sending commands to the tuner hardware - but this is not the same as the front panel crashing.

    Can this be explained by the settop process crashing but not the whole system, so the CF stuff can carry on unaffected (except by getting no response from anything outside the file system)? If this were the case, why would simulated IR injections appear to work??
     
  7. prpr

    prpr Well-Known Member

    Presumably: the real IR and the WebIf IR fire commands via humaxtv which writes the selected channel to the database (which is how the WebIf thinks the channel is different to what it really is). It then either fails to fire the command to the tuner or the tuner ignores the command for whatever reason. Thus the front panel never gets updated.
     
  8. Black Hole

    Black Hole Felinos Guru

    This is odd.

    HDR1 hasn't been recording, although everything else appears normal. When I looked at Guide >> Schedule, it was still expecting things dated 30/10. After a reboot the schedule updated itself so that all the entries are in the future.

    When I looked at HDR3, I couldn't see anything recorded on 29th (Sunday, after the clock change), although there were recordings made on 30th. I can't be certain, but I think I rebooted it later on Sunday.

    Along with the report about HDR4, which rebooted to the service I changed to (but wasn't acted on), this all points towards the clock change as screwing things up until the systems are rebooted. Anyone else?
     
  9. alanofcleeves

    alanofcleeves New Member

    I have two HDRs, upstairs running 3.10 and downstairs on 3.13. Both wake up at 04:20 'Disable OTA' (do I still need this?). In the morning after clock change 'upstairs' had crashed; blue ring on the facia but not responding to remote or Webif. The blue ring was odd as it hadn't been left on overnight and no recording had been scheduled. No harm done but power off was needed to restart.

    Probably not relevant but I noticed that the 'Visual' recording schedule displayed by Webif was messed up in the week before the clocks changed (one day repeated in the list). The regular listing 'Recording List' was unaffected.
     
  10. prpr

    prpr Well-Known Member

    I've just had another failure on HDR-1 where it responds to Ping, but not to any other service i.e. FTP, Telnet, Samba, SNMP, http etc. although the sockets are connected - just no data flows.
    Having looked at the screen, it had a frozen picture and no sound, and needed to be power cycled.
    This sort of thing is quite annoying as it evades my simplistic monitoring.
     
  11. MikeSh

    MikeSh Well-Known Member

    Our two worked through the time change without missing a beat. However, I do all the scheduling with the Humax gui not WebIf or RS, and I don't have any of the exotic packages like detectads or decryption running. I do have tunefix and its update though.
     
  12. Border

    Border Member

    My Hdr (on Sunday day after clocks went back)) was unresponsive and I noticed the front panel was one hour ahead. (maybe it froze around 23 hours previously). I flicked the switch at the back. when it restarted the red ring flicked momentarily once or twice. I noticed that one scheduled recording was present (haven't checked for others) but failed and lasted 0sec. I erased it but I think the time of the erased recording was the same as the reboot time as opposed to the scheduled record time. As I have deleted it I can't say for certain.
     
  13. Border

    Border Member

    I use padding for recordings as my box receives 2 different signals. Is HDR4 tuned to one or two ? Is HDR4 padding or using accurate recording?
     
  14. Black Hole

    Black Hole Felinos Guru

    HDR4 is AR on one region (HDR3 is my twin setup).
     
  15. Border

    Border Member

    Found one recording that was scheduled for 29th Sunday. After the reboot the red ring flashed as if recording twice (?maybe more). As I said there was one failed recording that I noticed. I deleted that one and I noticed it's start time was around the (GMT) time of the reboot. I had a look at the auto log for that day. Found another recording at that time. On webif information shows 0bytes and :

    Start Time Sun Oct 29 23:29:57 2017 GMT (Scheduled: Thu Jan 1 00:00:00 1970 GMT)
    End Time Sun Oct 29 23:29:57 2017 GMT (Scheduled: Thu Jan 1 00:00:00 1970 GMT)

    23:29 was the reboot time and as far as I remember the front panel showed 00:29. (Edit and was unresponsive to remote but I didn't wait to see if time updated). Didn't happen on the other HDR.
     
    Last edited: Oct 31, 2017
  16. Black Hole

    Black Hole Felinos Guru

    HDR1 may be a red herring. My daily Weather for the Week Ahead recordings continued fine, and the Sunday recordings of Strictly and Countryfile.

    Voyager didn't record again last night, even though the schedule showed it and now shows it set for today. No "failed to record" or anything as far as I can see, but if the AR flags were wrong it should have a "failed to track" flag. I'm mystified.
     
  17. MontysEvilTwin

    MontysEvilTwin Well-Known Member

    Do you use detectads? If so look in '/mod/tmp'. On occasion I have had missing recordings, but what has happened is that the original was deleted but the processed copy failed to be moved and renamed. If this is the case, the original file will be in '[Deleted Items]' if you have undelete installed.
     
  18. Black Hole

    Black Hole Felinos Guru

    No detectads on that machine.
     
  19. Black Hole

    Black Hole Felinos Guru

    Well, Voyager is currently recording. :rolleyes: