1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update Nightmare

Discussion in 'HD-FOX T2 Freeview Receiver' started by AdamA, Nov 19, 2011.

  1. AdamA

    AdamA New Member

    Hello all just got a HD-FOX T2 for my birthday and i decided to update the firmware on it.

    So i downloaded the update from the Humax download center, unziped and copied the .hdf file over to my 1gb Kingston flash drive formatted in FAT 32 and it is the only file on the drive.

    Put my box into stand by unplugged from the mains and inserted drive into USB port, held stand by button down and plugged box back into mains.

    Update screen appeared and it all completed successfully, unplugged USB drive and pressed stand by button.

    Waited got the humax splash screen with programming bar filling at bottom of screen, this then completed and the screen turned black.

    The box the went into stand by and 00:00 appered on the screen on front of the box, then then just counts up so 00:01, 00:02 and so on.

    I cant turn the box on and when i reset it the same happens.

    I have left it unplugged for 30 mins and no difference, i have tried loading the following firmwares:

    HD_FOX_T2_1.02.20

    HD-FOX T2_1.02.18

    HD_FOX_T2_1.01.12

    But no difference, i am at a total loss at what to do now.

    Any help would be greatly appreciated.

    Thanks Adam
     
  2. AdamA

    AdamA New Member

    Anyone?
     
  3. 4291

    4291 Well-Known Member

    Are you sure you have the update for the HD-Fox T2.
    It has the same number as the HDR version. Apart from that I cannot help.
     
  4. AdamA

    AdamA New Member

    Yes i have treble checked i have the correct firmware, Can loading the wrong firmware break the unit?

    Also i have noticed then when the update is being installed, under the heading System Information the software version reads:

    -.--.--

    Is this normal?
     
  5. 4291

    4291 Well-Known Member

    I know from experience that fiddling around the back to get at the USB slot can dislodge the other connections. Have you pulled the aerial lead out? Long shot I know but worth a try.
     
  6. AdamA

    AdamA New Member

    I have check all the connections even tried it without them to see if it made any difference.

    Is there any where else i can download the firmware so i can make sure what i am downloading is not corrupt.
     
  7. Black Hole

    Black Hole Felinos Guru

    Yes.

    Your description sounds like you are doing everything correctly. You do not actually need to go through a power cycle, putting the box into stand-by and then a long press on the stand-by button is sufficient to start the firmware update.

    The symptoms you describe sound very like what happens with no aerial plugged in - except you should see a message on the screen "poor reception" (words to that effect anyway). After a few minutes the message disappears to black and a screen-saver clock comes up (I'm talking about the TV screen here).

    Something which happens to me occasionally is I get a boot failure - it starts up and gives me the splash screen, but then bombs back to stand-by. I usually have to go through a cold start to cure that.
     
  8. Black Hole

    Black Hole Felinos Guru

    Does the menu button not do anything in your failed state?
     
  9. AdamA

    AdamA New Member

    I am getting no video at all, the clock is the digital display on the front of the Humax.

    It counts up every minuet the box is on.

    I cant do anything with the free view box, i cant even turn it on!

    All i can do is power cycle it with the USB stick in and try to load firmware.

    It says the firmware has loaded successfully but it just goes into stand by and the clock counts up.
     
  10. Black Hole

    Black Hole Felinos Guru

    Is there any chance the .hdf file is fragmented on the USB stick? Clutching at straws.
     
  11. AdamA

    AdamA New Member

    What do you mean by fragmented? It is the only file on the drive. I have also tried three other flash drives but they all do the same.
     
  12. Black Hole

    Black Hole Felinos Guru

    Probably not then. Take it back.
     
  13. AdamA

    AdamA New Member

    I wish i had never bothered updating it in the first place as it was working perfectly before.
     
  14. af123

    af123 Administrator Staff Member

    Technically yes, but the box should refuse to load anything but the right firmware.

    One thing that might be relevant is that it isn't possible to downgrade from 1.02.20 to an earlier version using the files that Humax publish; doing so results in exactly the symptoms you're seeing. I would try putting 1.02.20 on once more if you aren't already at that stage, otherwise it looks like a call to Humax support is on the cards, sorry.
     
  15. Black Hole

    Black Hole Felinos Guru

    I didn't know that. Is that true of the HDR-FOX too? Has this been mentioned before and I missed it? If it leads to identical symptoms this is suggestive.

    I think we have always assumed that if Humax crippled something we would have the option to back-track.
     
  16. af123

    af123 Administrator Staff Member

    It only applies to the HD. With the 1.2.x firmwares, Humax restructured the way the flash is partitioned (to match the HDR) and in that process the 2nd phase bootloader location moved (from 0x1900000 to 0x1c00000) and so the 1.02.x firmwares include a copy of the bootloader which is installed into Flash in the new location. Older firmware update files don't include the bootloader so when you revert you end up without a working bootloader as 0x1900000 has been overwritten with part of the kernel from 1.2.x.
     
  17. af123

    af123 Administrator Staff Member

    If re-applying the 1.02.20 firmware doesn't work, I could give you a 1.01.12 firmware update which should restore the bootloader. It may be that your first stage loader hasn't been properly told about the new location of the second stage one.
     
    AdamA likes this.
  18. af123

    af123 Administrator Staff Member

    Yes, but I can't find the posts at the moment!
     
    AdamA likes this.
  19. AdamA

    AdamA New Member

    Just tried loading HD_FOX_T2_1.01.12 and it completes successfully, once rebooted the humax logo appears with the loader version in the bottom left corner (Ver L7.26)

    On the digital display on the box the green light is on and the snake is going round.

    It hangs here and after about 5 mins it flickers the word boot in the digital display and goes back to the snake.

    So its trying to boot up but is stuck and wont go any further.

    Pressing the reset button reboots the box and then it hangs again.
     
  20. af123

    af123 Administrator Staff Member

    That makes sense, you won't be able to go back to 1.01.12 - try 1.02.20 again and see if it works this time.