USB GPT drives - current status ?

jack616

Member
Just wondering if GPT progress has been made fro the USB ports ?
I found a couple of threads (2017) which suggest issues with USB (I think it was BH who reported)

I've just bought a 5TB WD portable and am trying to decide how to partition it.
I have a 3TB msdos parted NTFS that works fine as 2 partitions.

For the record if anyone is interested in capacities etc I have a 7 port USB hub
with 6x 2TB drives plus the above mentioned 3TB giving 8 partitions active
All NTFS with no issues other than very slow initial mounting.
Playback from one partion while copying from another simulatiously works
fine. (I use the front USB port )
The humax spins them backup when they go to sleep quite quickly but
a reboot means I have to cold start the hub because the Humax doesnt seem
to rescan them.

Pretty impressive really.
 

trog

Member
Why? Sounds like a case of digital hoarding. I binned about 10 large boxes of 4 hour VHS tapes a couple of years ago after finally admitting to myself that I would never watch any of them again and even if I did want to I could find them online.
 

Trev

The Dumb One
I think the point is irrelevant (to the OP, but not us), he just wants to be able to do it for reasons best known to himself.
But, on the face of it, trog's post above does seem to apply. :frantic:
 
OP
J

jack616

Member
I guess I should have started a second thread...
I'm assuming GPT on USB is still a no go then. I'll just format for 3 msdos partitions. It will be
interesting to see if I can add it to the hub or maybe plug it into the back socket in addition to
the existing stuff.

FWIW one of my 2TB drives I do use for TV/Movie offloading - as for the rest - Trev's response covers it.
By impressive I was refering to what I could use an old freeview PVR to do. Thanks to the CF
of course. actual recording TV on them is very flakey.
My second live box only has a 4 port hub. Thats the one I actually use for for the TV.
(I use that hub so I'm not drawing power from the humax - I doubt there's any need but I had a cheap
hub not used so plugged it in)
 
OP
J

jack616

Member
Since I said something stupid I better fix it... you can't use all of a 5TB drive with mbr (msdos)
I had hoped I could hide a partition and do it that way but of course that wont work.
(and since i wrote my own OS with mbr startup I should have realised that!)
It will have to be a 5TB GPT 'hoarding ;) drive'
 
OP
J

jack616

Member
df
I did mess about a bit before posting - I think the link you gave is the one I mentioned before.
I'm using CF 3.13 - formatting as 2 GPT partitions +NTFS the drive isn't seen at all on either machine
I'm just seeing what happens through my hub as I type this - Well the hub lets it see the first
partition but only names it gpt-drive1 - it can't see any files on the drive - on the other hub/box
I get the same result - just an empty named drive gpt-drive1 so GPT doesn't work with 5TB WD
drives formatted NTFS at least. (Maybe ext4 could work but I've got data on the drive now so can't check)
It could be an ntfs-3g issue maybe? I dont know - I'm content for now anyway.

af123 - the last linux kernel I recompiled was slackware 1.0 (or maybe it was 1.1) ... not really my
thing anymore... other time consuming projects in motion.
 

/df

Active Member
When a device is detected as /dev/sdxmn, the CF runs the script /etc/mdev/run-and-gun to handle it. This might involve initialising the full CF environment, if the detected storage device has a /mod filesystem, installing packages from USB, or mounting the device for cases where the Humax STB code does't do so, such as USB-connected drives partitioned as GPT.

The run-and-gun actions are logged in /tmp/rag.log. What does it say?
 
OP
J

jack616

Member
thanks for re-prompting me /df

I've experimented a little and have some sort of success. After cold booting:
Using the cheap hub the box doesn't pop the USB device loading window up but the drive is active
Pressing the blue storage button just displays the HDD selection - it isnt showing any USB devices are installed
Unplugging the drive however pops up the USB removed message.
Rag file below -

If I use the more expensive hub both partitions are recognised and the GPT-P1 (empty) is left
in the drives list as well. It too does not pop up the USB loading window.
In this case though the box can see the files on both partitions.
This box is in full use so I can't mess with it more than that at the moment.

The rag file for the drive that can't see anything is below if that helps explain it.


--------- Info for Modinit PID 1741 ---------
1741: Date: Fri Dec 20 22:28:51 UTC 2019
1741: MDEV: sdb1
1741: ACTION: add
1741: Model: HDR
1741: Device: /dev/sdb1
1741: Disk: sdb


--------- Info for Modinit PID 1749 ---------
1749: Date: Fri Dec 20 22:28:51 UTC 2019
1749: MDEV: sdb2
1749: ACTION: add
1749: Model: HDR
1749: Device: /dev/sdb2
1749: Disk: sdb

1741:20/12/2019 22:28:51: Waiting for disk to become ready...
1749:20/12/2019 22:28:51: sdb2 is candidate for mod [/mnt/hd2]
1741:20/12/2019 22:28:51: disk ready after 0 seconds
1741:20/12/2019 22:28:51: /dev/sdb1 is NOT formatted as ext2/3
1741:20/12/2019 22:28:51: /dev/sdb1 is NOT removable.
1741:20/12/2019 22:28:51: /dev/sdb1 is connected via USB.
1749:20/12/2019 22:28:51: Waiting for disk to become ready...
1741:20/12/2019 22:28:51: /dev/sdb1 partition type gpt
1749:20/12/2019 22:28:51: disk ready after 0 seconds
1741:20/12/2019 22:28:52: Waiting for the disk to mount...
1749:20/12/2019 22:28:52: /dev/sdb2 is NOT formatted as ext2/3
1749:20/12/2019 22:28:52: /dev/sdb2 is NOT removable.
1749:20/12/2019 22:28:52: /dev/sdb2 is connected via USB.
1749:20/12/2019 22:28:52: /dev/sdb2 partition type gpt
1749:20/12/2019 22:28:52: Waiting for the disk to mount...
1741:20/12/2019 22:28:53: still waiting...
1749:20/12/2019 22:28:53: still waiting...
1741:20/12/2019 22:28:54: still waiting...
1749:20/12/2019 22:28:54: still waiting...
1741:20/12/2019 22:28:55: still waiting...
1749:20/12/2019 22:28:55: still waiting...
1741:20/12/2019 22:28:56: still waiting...
1749:20/12/2019 22:28:56: still waiting...
1741:20/12/2019 22:28:57: still waiting...
1749:20/12/2019 22:28:57: still waiting...
1741:20/12/2019 22:28:58: still waiting...
1749:20/12/2019 22:28:58: still waiting...
1741:20/12/2019 22:28:59: still waiting...
1749:20/12/2019 22:28:59: still waiting...
1741:20/12/2019 22:29:00: still waiting...
1749:20/12/2019 22:29:00: still waiting...
1741:20/12/2019 22:29:01: still waiting...
1749:20/12/2019 22:29:01: still waiting...
1741:20/12/2019 22:29:02: still waiting...
1749:20/12/2019 22:29:03: still waiting...
1741:20/12/2019 22:29:04: mounting GPT drive on /media/gpt-drive1
mount: mounting /dev/sdb1 on /media/gpt-drive1 failed: Invalid argument
1741:20/12/2019 22:29:04: mount FAILED after 11 seconds.
1749:20/12/2019 22:29:04: mounting GPT drive on /media/gpt-drive2
1741:20/12/2019 22:29:04: >>> /mod/etc/mdev/ntfs-3g add /dev/sdb1
1741:20/12/2019 22:29:04: /media/gpt-drive1 /tmp/tmp.U2fGWU
1749:20/12/2019 22:29:04: mounted after 11 seconds.
1741:20/12/2019 22:29:04: ntfs-3g: Device /dev/sdb1 was not premounted on /media/gpt-drive1
1749:20/12/2019 22:29:04: >>> /mod/etc/mdev/ntfs-3g add /dev/sdb2
1749:20/12/2019 22:29:04: /media/gpt-drive2 /tmp/tmp.Fb1dZO
1741:20/12/2019 22:29:05: ntfs-3g: Mounting /dev/sdb1 on "/media/P1-5TB"
1749:20/12/2019 22:29:05: ntfs-3g: Attempting to remount /dev/sdb2 currently on /media/gpt-drive2...
1749:20/12/2019 22:29:05: ntfs-3g: Unmounted /media/gpt-drive2
1749:20/12/2019 22:29:05: ntfs-3g: Mounting /dev/sdb2 on "/media/P2-5TB"
1749:20/12/2019 22:29:13: <<< /mod/etc/mdev/ntfs-3g
1749:20/12/2019 22:29:13: -- New mount point: [/media/P2-5TB]
1749:20/12/2019 22:29:13: Considering package scan on /media/P2-5TB
1749:20/12/2019 22:29:13: sdb: Non-removable disk, skipping package scan.
1741:20/12/2019 22:29:15: <<< /mod/etc/mdev/ntfs-3g
1741:20/12/2019 22:29:15: -- New mount point: [/media/P1-5TB]
1741:20/12/2019 22:29:15: Considering package scan on /media/P1-5TB
1741:20/12/2019 22:29:15: sdb: Non-removable disk, skipping package scan.

END
 

xyz321

Well-Known Member
The rag.log output looks normal with the partitions mounted as 'P1-5TB' and 'P2-5TB'. The USB button may not appear if you only have GPT formatted drives connected. To workaround this the ntfs-3g package has the virtual-disk2 package as a dependency. This should create a dummy/fake USB drive which should ensure that the USB button always appears.

Is virtual-disk2 installed?
 

/df

Active Member
Also, if the front panel USB socket (hidden behind the small cover on the far bottom right) is free, what happens if the 5TB USB disk is plugged into it directly with no hub?
 
OP
J

jack616

Member
It seems what I reported last night only works randomly anyway for some reason.
With no hub and the drive plugged in (either socket) then nothing is recognised as described above
(I always use the front port - I did try the back last night but no difference)
I dont know about virtual-disk2 - I'll check it out.
 
OP
J

jack616

Member
OK - that was a quick fix !
Installed virtual-disk2 and plugged it directly into the box and all seems to work fine.

thanks xyz321 and /dl
So far that seems pretty conclusive.
 
OP
J

jack616

Member
hmm - maybe I spoke too soon...

It all works for msdos and GPT but will not mount more than 6 physical drives now.
(It did before)
It will recogise 8 partitions on 6 drives but no matter what mix of partitions
it only ever recognises the 7th drive (after a very long time) as read-only
or stops the 6th drive from mounting read/write also.

Is there perhaps a physical drive limit in this version of ntfs-3g?
(I have checked the hub thoroughly - that is fine) - I even changed the UID on one
drive in (unlikely) case of duplication. Still no go.
 
Top