USB stick issue


New Member
I've been copying programmes off my HDT-2000T using a USB stick via the front USB port for about a year without any problems, until now. The last few times I've tried, it no longer shows my USB stick in the drive list. It now shows "drive1" and "drive2".

Ive never seen any deviced called "drive..." before!
Not only is the name different, but there are two devices, not one.

Humax USB problem 1b.jpg

Anyone know what's gone wrong?
Last edited:
And strangely enough, when I remove the USB stick, it shows two devices, this time the description is accurate "USB DISK 3.0".

It shows these devices even though the USB stick is removed.

Humax USB problem 2b.jpg
I can can get drive1/drive2/drive3 ... on my HDR-2000T after using a USB drive unless I use the eject option on the hidden menu. For me a cold reboot sorts out the reporting of extra devices. Try placing the HDR-2000T into standby when it is not recording or due to start recording for the next 40 minutes, and then turn it off at the plug for a minute.

Also have you since tried the USB stick in a PC to check that it is still working OK?

Edit: First posted before any sauce. Updated after some sauce!
Last edited: