1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Usually fails to connect WiFi if static IP used

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by stdavid, Mar 9, 2012.

  1. stdavid

    stdavid New Member

    Hi,

    Great work being done here!

    I bought the HDR about a month ago, set it all up with no problems. Latest official firmware and the official WiFi dongle, set up using static IP. Worked great. I decided to put the customised firmware on it, to have great things like remote scheduling. This went very smoothly.

    After installing the full web-if and the wireless helper package however, I noticed that the HDR wasn't automatically connecting to the WiFi on startup. Going into the settings page, and clicking Apply would get it to connect after about 4 or 5 attempts, about 90% of the time.

    After adding the WiFi network for the nth time, I decided to let DHCP do its thing, and to my surprise, it connected first time. I decided to leave it as it was, and for the last two weeks or so, the HDR auto connects to WiFi on startup more or less all the time. I still get the odd "Network disconnected", but a quick reboot usually fixes this.

    I'm happy to leave it on DHCP, as I don't have that many devices, so the box tends to stay on the same IP, but thought I should bring this to your attention and to see if anyone else has experienced something similar?

    I can't remember the version numbers off the top of my head, but web-if shows no updates available.

    Thanks.
     
  2. Black Hole

    Black Hole Felonius Gru

    Thanks for the report. It is strange that the custom software seems to be involved, but possible af123 can suggest a reason.

    As far as static/DHCP is concerned, I have found configuring the IP address manually is fraught with problems. If the router is generally handing out IP addresses to other devices, it can easily happen to hand out the one you have manually configured the Humax for (if the Humax is off the network at the time). On the other hand we need a static address so we can access conveniently by FTP or the custom software web interface. So what to do?

    My solution is to allow the Humax to connect by DHCP, and then at the router configuration options allocate that address permanently to the Humax (identified by its MAC). That way, IP addresses will be handed out as devices come and go by DHCP, but the Humax address will be reserved and only handed out to the Humax (every time it makes a DHCP request).
     
  3. makem

    makem Member

    I have 7 pieces of equipment (including the Humax), all allocated static reserved IP's by the router and filtered by MAC address. Each item is configured with it's corrosponding static IP, matching that reserved in the router. The router does nothing for those items. Other equipment brought by friends/relatives is allocated an IP via the router DHCP.

    I am pleased to say I have never had any trouble.

    Do you reserve and allocate those reserved IP's to your static IP equipment?
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    It is quite common for routers to have aDHCP range, So for example IP's 2 to 128 are always in a DHCP pool and 129 to 254 are Manually configurable, This stops any confusion over allocation of IP's
     
  5. fenlander

    fenlander Active Member

    You can normally define on the router the range of addresses to be allocated by DHCP, allowing you to manually allocate fixed addresses outside that range. My router starts allocating addresses at 192.168.0.11; my Hummy is set to 192.168.0.5 and my media PC to 192.168.0.3. Laptops etc. get their addresses from the DHCP server so that they can connect correctly to 'foreign' networks.
     
  6. Black Hole

    Black Hole Felonius Gru

    Handling it all at the router (and setting everything else to DHCP) avoids configuring IP addresses etc in multiple places, fewer chances of error.
     
  7. fenlander

    fenlander Active Member

    But I like to have CONTROL of how my devices connect. It's a tiny bit like using padding for recordings instead of letting the machine make the decisions...:)
     
  8. Black Hole

    Black Hole Felonius Gru

    I only described what I decided to do... make of it what you will. :cool:
     
  9. Wallace

    Wallace Slightly Pickled

    Well, I actually agree with BH on this one!

    That's exactly what I do. Fixed address' for all my AV/PC equipment, everything else gets DHCP. Works for me.
     
  10. fenlander

    fenlander Active Member

    I was just pointing out an alternative method for getting static addresses. Everything I have connected via ethernet is fixed; all wireless is DHCP.
     
  11. RedEarth

    RedEarth Member

    I don't know for definite if all routers work this way, but you can usually reserve a specific IP address for a specific device (matched by MAC address) so that whenever the device does a DHCP request (e.g. when you switch it on), the router will always give it the same address. You don't need to set a static IP address on the device, just set it to DHCP and let the router manage everything. Static IP addresses are only really needed if you have no means of allocating addresses by DHCP (e.g. a very basic peer-peer IP network), but I would imagine that all routers these days would have a DHCP server built-in.
     
  12. stdavid

    stdavid New Member

    Thanks for all the input. It's definately not an IP conflict.

    Router on 192.168.0.1.
    Wireless AP 192.168.0.2
    PC 192.168.1.10
    Chumby 192.168.1.20
    Humax 192.168.1.30
    DHCP pool 192.168.1.100-255

    I like using static addresses as I can then VPN into my home network from my phone, and connect to things.

    It's not a real problem as the humax is always being assigned the same IP as apart from the wife's laptop, it's the only thing that requests and IP.
     
  13. Ezra Pound

    Ezra Pound Well-Known Member

    Usually everything is on the same sub-net, e.g. the same group of 255 IP addresses whereas your router and Wireless AP are on '0' and everything else is on '1' could that be your problem?
     
  14. stdavid

    stdavid New Member

    Thanks for the suggestion Ezra Pound. I'll change the subnet mask from 255.255.0.0 to 255.255.255.0 and move the addresses around to see if it makes any difference.