1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Video format with subtitles

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Zico Barton, Jun 13, 2011.

  1. Zico Barton

    Zico Barton Member

    Does anyone know if my HDR-T2 can show subtitles when ripped from DVD?

    I've ripped a couple of DVDs using handbrake saving them as m4v to play on my Humax.
    There is an option in Handrake to include the subtitles, with burned into the video or as a user selectable option.
    Using the second method and playing through VLC on my PC it works fine, I select Subtitles then select the subtitles I want to use.
    However when I play it on the Humax the video is fine but when I press the subtitles button it says there are none.
    Burning the subtitles into the video works, but I want to be able to select if they appear or not.

    Thanks
     
  2. fenlander

    fenlander Active Member

    I know the HDR-T2 works fine with subtitles in a separate .srt file. I haven't actually used it, but you might find SubRip worth a try - it rips the subtitles from the DVD to a text file (srt).
     
  3. JSCollins

    JSCollins New Member

    This bothered me for ages, finally I realised that the .srt subtitles need to be
    (a) the exact same file name as the video file, replacing the .mp4 or .avi etc. extension with .srt, of course (this I already knew), and
    (b) the .srt file needs to be saved as a text file specifically with ANSI encoding (you can use Win Notepad for this). Apparently this is because the other encoding options use licensed fonts and therefore Humax would have to pay royalties, so bars these formats.
     
  4. Black Hole

    Black Hole Trick Cyclist

    That would be a straight plain ASCII text file then.
     
  5. Ezra Pound

    Ezra Pound Well-Known Member

    Very useful info., I have added it to the WiKi HERE - Thanks
     
  6. Steve1953

    Steve1953 New Member

    The ANSI encoding works without the CF by the way.
    Just been watching the film Woman in Gold which has a lot of German speaking scenes. The only way you an follow it is to turn on subtitles for those scenes. This forum is the only place I found the solution.
    thanks to JSCollins