1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WD Elements 2TB hard drive with custom firmware?

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Jacob, Dec 27, 2011.

  1. Jacob

    Jacob New Member

    Hi im new to the forums,
    I got my Humax HD-Fox T2 for christmas along with a 2TB Western Digital Elements external hard drive so i could turn it into a pvr.

    I have tried and failed trying to set it up,
    the box would not partition the drive and gets stuck when doing so,
    I then used G-parted to format it to ext3 which also didn't work with the box, which wanted to format it for me.
    I have formatted a 1TB hard drive (with the humax box) and then coppied all the files over to the 2TB hard drive (including hidden folder) and that also didn't work.

    I then decided to install the custom firmware to see if i could get it working, i have formatted the 2TB hard drive to NTFS and have installed the following package:

    ntfs-3g 2011.4.12-3 Read/write NTFS disk access. Out of the box the Humax can read NTFS formatted drives but this package upgrades that support to full read/write access.
    I have then plugged in the hard drive but it will not let me use it still, and tries formatting it.

    I'm completely stuck, i have seen many people asking how to do this and then some people have been successful but no guide has been given.

    Any suggestions on how i can get it working with my drive?
     
  2. af123

    af123 Administrator Staff Member

    When you copied the files across from the 1TB drive to the 2TB, did you give the 2TB drive/partition the same name?
    I don't know if it's the answer but the Humax does store the name of the disk in the database.
     
  3. Jacob

    Jacob New Member

    i believe so, it was named the default 'USB-1' i think, im going to retry that when i get chance though :)
     
  4. Black Hole

    Black Hole Ron Glum

    Yes, there has been one report of success using this route - perhaps the author will drop by to offer some pointers. Otherwise you are on relatively uncharted ground. We don't know the limitations of the disk driver or the consequences of cheating it into using a drive greater than 1TB.

    Your NTFS attempt would not get off the ground - the standard firmware is unable to write to an NTFS drive, and the custom software needs to be installed somewhere before it can add full NTFS support (adding NTFS to the custom boot code has been mooted). You could run a USB stick on a USB splitter, but things start getting complicated very quickly. However, I doubt the box would cooperate and record to an NTFS drive even with the drivers in place.
     
  5. Climber

    Climber Member

    I've previously installed a 2TB drive with no problems.
    It was a while ago, but I seem to remember formatting it to primary ext3 using Gparted.

    With the Humax box on standby - connected the (formatted) drive - switch Humax on.
    The crucial bit that you may be missing is - I still had to go into the setting to format the drive. The process (format) does not take too long.
    This seems to finalise the drive.
    It then worked perfectly well and I've had no issues since installation.
     
    Black Hole likes this.
  6. Black Hole

    Black Hole Ron Glum

    Excellent, thanks for contributing.
     
  7. Jacob

    Jacob New Member

    Thanks for the reply, just trying this method now.
    I have gone into settings and to format but it seems to be just staying on the 'Processing...' message.
    I'm going to leave it for a while to see if anything happens though.
    Do you know roughly how long it took for you?
     
  8. af123

    af123 Administrator Staff Member

    There is a file in the HD flash called ext_hdd_info - the UUID of the new disk needs to be put there before it will be used for recording etc.

    The blkid command can give you the UUID, e.g.:

    Code:
    humaxhd# /mod/sbin/blkid
    /dev/sda1: LABEL="Rugged" UUID="aaa4ee89-6b30-449e-8526-c0d7f6d7625d" TYPE="ext3"
    humaxhd# cat /var/lib/humaxtv/ext_hdd_info 
    aaa4ee89-6b30-449e-8526-c0d7f6d7625d
    
    If you're running the customised firmware, then the easiest way to fix this, once you have formatted the disk elsewhere, is to install the e2fsprogs package then run the assignhd diagnostic:

    Code:
    humaxhd# opkg install e2fsprogs
    Installing e2fsprogs (1.41.14) to root...
    Downloading http://hummypkg.org.uk/hdrfoxt2/base/e2fsprogs_1.41.14_mipsel.opk.
    Configuring e2fsprogs.
    humaxhd# diag assignhd
    Running: assignhd
    Disk UUID = [aaa4ee89-6b30-449e-8526-c0d7f6d7625d]
    Assigned disk, reboot now.
    humaxhd# reboot
    
    This is how you do it via telnet, you can of course achieve the same thing through the web interface - just install the e2fsprogs package then go to Diagnostics (link from bottom of main screen) and enter assignhd into the diagnostic box and run it. Then restart the box via the remote control.
     
    xyz321 likes this.
  9. Climber

    Climber Member

    I don't think it took much longer than 20 mins.
    For a trial, rather than having to use my 2TB disk, I tried it using a 500kb disk.
    In Gparted - deleted - formatted primary ext3
    Connected to humax HD - Switched on box - went into utils and formatted - it took less than ten minutes to work.
    Of course it's more than likely a different proposition with the larger sized disk.

    I hope you get success, as I know how frustrating it probably is.
     
  10. Shaggy

    Shaggy Member

    I bought my HDR earlier this year from Aerial Shack (Bournemouth) who fitted 2TB drives at the time, although they've since stopped. I think three separate partitions had to be created duplicating the partitions on the original. Two partitions should be created the same size as on the original disk, teh one used for recordings can be created to fill the rest of the space on the disk. I upgraded to the modified firmware a couple of months ago, and have been running with absolutely no problems ever since.
     
  11. af123

    af123 Administrator Staff Member

    That's true for the HDR, but the OP has the HD model.
     
  12. Jacob

    Jacob New Member

    thanks for this, i am finding it hard to understand though, being a noob and all ^^

    Do i need to do this whole step with the new hard drive plugged in on its own?
     
  13. af123

    af123 Administrator Staff Member

    The following sequence should work:
    • Format the disk using G-Parted;
    • Copy files across from old disk (including hidden .tsr directory);
    • Plug the disk into the Humax HD (running custom firmware);
    • Gain access to the Humax command line via telnet;
    • Type 'opkg install e2fsprogs' (without the quotes);
    • Type 'diag assignhd'
    • Type 'reboot'
    and, with any luck, the Humax will reboot and recognise the disk for recording.

    If you don't want to use the command line then substitute the last three steps for:
    • Install the e2fsprogs package via the web interface;
    • Go to the Diagnostics screen in the web interface (link from home page);
    • Enter assignhd into the diagnostic field on that page and click Run Diagnostic;
    • Put the Humax into standby using the remote control;
    • Start up the Humax using the remote control.
    HTH.
     
  14. Jacob

    Jacob New Member

    So far i have done the following steps:
    • Format the disk using G-Parted; I did this using the ext3 file system and formatted it as a primary partition - is this correct?
    • Copy files across from old disk (including hidden .tsr directory);
    • Plug the disk into the Humax HD (running custom firmware);
    • Gain access to the Humax command line via telnet;
    i then enter opkg install e2fsprogs on telnet and i get the following error:
    Code:
    humax# opkg install e2fsprogs
    Unknown package 'e2fsprogs'.
    Collected errors:
    * make_directory: Cannot create directory `/mod/': File exists.
    * make_directory: Cannot create directory `/mod': File exists.
    * make_directory: Cannot create directory `/mod': File exists.
    * make_directory: Cannot create directory `/mod': File exists.
    * opkg_install_cmd: Cannot install package e2fsprogs.
    * opkg_finalize_intercepts: Failed to open dir : No such file or directory.
    * rm_r: Failed to open dir : No such file or directory.
    * rm_r: Failed to open dir : No such file or directory.
    humax#
    if i try and enter the command 'diag assignhd' i get the error:
    Code:
    humax# diag assignhd
    Running: assignhd
    Install the e2fsprogs package first.
    humax#
    Also when i try and connect to the web interface using my browser it cannot connect/find the page.

    The hard drive is being detected on the humax box but i cannot access any files through the video menu etc, on the settings --> system --> data storage menu it shows the hard drive as having a total size of 1863.0GB but the available size is 0.0GB and the used size is 0.0GB.

    I have tried rebooting but cannot work it out.

    Any ideas?
     
  15. xyz321

    xyz321 Well-Known Member

    You seem to be copying files from an 'old' disk to a 'new' disk - is that right? Did it work with the 'old' disk? Are they both connected at the same time using a hub? If not are you rebooting after connecting the 'new' disk (with the files from the old disk already copied onto it)?

    Can you post the output of the following commands here?

    Code:
    cat /tmp/rag.log
    cat /tmp/modinit.log
     
  16. Jacob

    Jacob New Member

    Yes i previously had the 'old' 1TB hard drive working, that was the drive used for recording. I want to use the 'new' 2TB so i formatted it in Gparted to ext3 and i put them both into my laptop and copied all the files over including the hidden folders.

    Everything worked with the old disk.

    They are connected on their own without a usb hub to the usb port on the back of the humax box and i am rebooting the box after plugging the new drive in.

    here are the command results:
    Code:
    humax# cat /tmp/rag.log
    
    --------- Info for PID 260 ---------
    260: MDEV:      sda1
    260: ACTION:    add
    260: Model:      HD
    260: Device:    /dev/sda1
    260: Modinit: /media/drive1
    260: Waiting for disk to mount...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    260:  still waiting...
    humax# 
    Code:
    humax# cat /tmp/modinit.log
    cat: can't open '/tmp/modinit.log': No such file or directory
    humax#
    
     
  17. xyz321

    xyz321 Well-Known Member

    It's obviously failing to mount the drive. Are you still seeing the message asking to format the drive? If so I think it would be best to try @Climber's suggestion
    So in this case you would format it using gparted (which you have already done), then using the Humax GUI go into Menu, System, Data Storage, Format Storage. Now the drive should be recognised by the box. If that is so, then you should be able to copy all the data from the old disk (again). The mod. should then be available so that you can install e2fsprogs etc.
     
  18. Jacob

    Jacob New Member

    I have tried that multiple times and the screen just stays on 'Processing...', i have left it for over 1 hour on that screen and it does not progress.

    I am going to try again now though
     
  19. Black Hole

    Black Hole Ron Glum

    Perhaps the Humax just doesn't "like" this particular breed of disk. Is anyone else running one successfully?
     
  20. xyz321

    xyz321 Well-Known Member

    Exactly how big is the drive? There may be a problem if it is any more than 2TB.