1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Web I/F crashes

Discussion in 'FOXSAT-HDR Customised Firmware' started by Trev, Jun 23, 2012.

  1. Trev

    Trev The Dumb One

    I'm using the modified S/W on my Foxsat and sometimes when I am 'doing stuff' (unspecified) from my computer, the web interface stops working with a 404 error and a restart of the Hummy fixes it. Now I have read somewhere that somthing needs restarting by using some sort of command line thingy, but as I'm a bit vague on the subject (as you can tell), I don't even know what to search for and I don't fancy wading through dozens of pages on that other site trying to find out when I'm sure that someone here, or maybe from there, will have a short sharp smappy fix for me. I am a bit of a dunce as far as FTP, commands and all that sort of stuff, so it's no good telling me thatI can restart it by simply semding it a command or something, as I have no idea how to do that.
    Any help deeply appreciated as it's a pain in the butt when it crashes and HWMBO is watching something ;=)
     
  2. af123

    af123 Administrator Staff Member

    You need to gain access to the command line using telnet (See http://wiki.hummy.tv/wiki/Telnet for some basic instructions) and just type:

    Code:
    service start mongoose
    
    when you get to the prompt.

    I don't think anyone knows why it crashes fairly regularly on the Foxsat (it never seems to with the Freeview customised firmware and it's almost the same code).
     
  3. Trev

    Trev The Dumb One

    Jeez. That was PDQ af123. Thanks for that. I knew that I could get a real expert to help me out. I suppose this meercat, sorry, mongoose program is installed along with the modified S/W as I can't see it listed in the 'Installed packages' list?
    Thanks for the help. :=)
     
  4. af123

    af123 Administrator Staff Member

    Yes, it's baked into the modified firmware as far as I remember.​
     
  5. Trev

    Trev The Dumb One

    Have tried Putty and when I set it up as per instructions, Zone Alarm pinged up so I allowed it but the black window opens and then shuts down completely after about a second. Switched off ZA, run as Administrator etc. still no joy. Windows telnet Errors with 'Could not connect to host'.

    Doh. It helps ever so slightly if you install the Telnet add-on to the Hummy.

    Presumably you should get the 'Failed to start mongoose' error if it is already running?
     
  6. af123

    af123 Administrator Staff Member

    Ah yes, telnet is optional on the Foxsat.

    Yes, you should just get failed to start if it's already running.
     
  7. Trev

    Trev The Dumb One

    Sorted then gov'nor. I await my next Web I/F crash with bated breath.
    Thanks