1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Webif: Browse Media File error

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by GeeCee, Feb 5, 2012.

  1. GeeCee

    GeeCee New Member

    have been using the custom firmware/webif for a few months now (brilliant work BTW!)
    Following the initial install (v15) I received error messages whenever I used the dedup utility from webif. This was a minor thing that I could live with.

    Recently, however, I now receive the following error message whenever I 'Browse Media Files'. This happens all the time. The first 10 of my recorded file list is shown and then the error below.
    Also if I click on any of my recorded files, I also get this error.

    Runtime Error: /mod/var/mongoose/lib/ts.class:169: no such table: tblresource in procedure 'entry' called at file "browse.jim", line 286 in procedure '.00000000000000000002>' called at file "browse.jim", line 184 in procedure 'ts dlnaloc' called at file "/mod/lib/jim/oo.tcl", line 46 at file "/mod/lib/jim/oo.tcl", line 62 at file "/mod/var/mongoose/lib/ts.class", line 169

    I've upgraded to the latest mod version (v17) but still have this issue
    I saw a thread which seemed related (posted by Tobyjuggler) - I've run df diagnostics but do not get the busybox perm issue so I'm not sure if it's related. Results of the df are at the bottom of this post.

    Thanks in advance for any help here....


    >>> Beginning diagnostic df Running: df Filesystem Size Used Available Use% Mounted on /dev/sda2 447.6G 165.4G 259.5G 39% /mnt/hd2 Filesystem Size Used Available Use% Mounted on /dev/sda2 447.6G 165.4G 259.5G 39% /mnt/hd2 Welcome to Jim version 0.73 . . . 447.6G 165.4G 39 . * /mod/bin/busybox/busybox -rwxr-xr-x 1 root root 545224 Jan 23 21:27 /mod/bin/busybox/busybox Removing package busybox from root... Installing busybox (1.19.3-3) to root... Downloading http://hummypkg.org.uk/hdrfoxt2/base/busybox_1.19.3-3_mipsel.opk. Configuring busybox. * /mod/bin/busybox/busybox -rwxr-xr-x 1 root root 545224 Jan 23 21:27 /mod/bin/busybox/busybox * /mod/bin/busybox/busybox -rwxr-xr-x 1 root root 545224 Jan 23 21:27 /mod/bin/busybox/busybox >>> Ending diagnostic df
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    af123 setup a re-load of busybox 1.19.3-3 in the df diagnostic script in order to cure a problem where the access permissions for busybox appeared to be wrong, It looks like your busybox was successfully re-loaded, However it probably wasn't your problem anyway. In your case it looks like your 11th broused file is causing the problem, you could prove this by moving 'file 11' to it's own 'sub directory' and trying again
     
  3. af123

    af123 Administrator Staff Member

    I'll have a look at it when I finish playing in the snow (6 hours so far, don't kids ever get tired?)
    It doesn't look like the same issue as Tobyjuggler was having.
     
  4. GeeCee

    GeeCee New Member

    Following Erza Pound's suggestion, I moved the file to a sub directory but the error still occurs but for a different file. What seems to happen is that the interface has no problems displaying directories/folders but when it comes to displaying any recorded file then I get the issue. Also, if I click on any of the folders then it shows the first file and then the error too.

    On a more productive note, I managed to build a pretty impressive snowman for the kids.
     
  5. af123

    af123 Administrator Staff Member

    Try upgrading to webif 0.9.1
    Your Humax Media Server database seems corrupt in some way and the web interface didn't catch the error cleanly.
     
  6. GeeCee

    GeeCee New Member

    That's done the trick - many thanks for the help.

    On a related note, I still get this error when I run the de-duplicate function from the interface (process folder). I use it to rename files with their episode number. Not sure if you know what is going on here. It's not a showstopper as the workaround is to continue deduplicating the folder until all the files have been renamed (Instead of doing it once for all files in the folder I have to do it x times for x files in the folder).

    Runtime Error: /mod/var/mongoose/lib/ts.class:208: no such table: tblMedia in procedure 'ts' called at file "dedup.jim", line 80 at file "/mod/var/mongoose/lib/ts.class", line 208
     
  7. af123

    af123 Administrator Staff Member

    That's the same root cause - your media server database is broken. Is media sharing turned on in the standard Humax settings?

    I would do the following to fix it:

    Disable the media server in the Humax menus (Settings->System->Internet Setting->Content Share = Off)
    Restart the Humax - make sure it is a full restart, i.e. the disk powers off.
    Use the web interface browser to find the /mnt/hd2/dms_cds.db file and remove it.
    (or telnet in and type 'rm /mnt/hd2/dms_cds.db' without the quotes)
    Enable the media server again.
    The file will re-appear and hopefully dedup will begin working properly.
     
  8. GeeCee

    GeeCee New Member

    Media sharing wasn't turned on but after enabling it seems to have solved the issue

    Appreciate all your help on this