webif crashes / issues

RickT

New Member
Hi,

I've been having a problem for a while but, although it's been inconvenient I've done nothing about it as I was hoping a future upgrade might sort it out, but so far they haven't, so I thought I'd investigate.

Issue 1:
When I select the system diagnostics I don't get a graph, it hangs with a rotating icon saying loading but then nothing happens.

Issue 2:
If I upgrade a package via the webif, the webif crashes, requiring a reboot to get it working again (although I assume there is a way to restart it via telnet).

I thought the graphs issue might be related to this (butchered link to get it posted) : /forum/threads/sysmon-system-monitoring.1534/ but given I am running the latest versions, I don't think it is.

I've looked through the logs and I can't see anything for the crash (although not sure what to look for), but for Issue 2, I can see this in the webif_error.log :
Code:
humax# cat var/log/webif-error.log
/mod/webif/plugin/sysmon/data/temp.jim:12: Error: file is encrypted or is not a database
at file "/mod/webif/plugin/sysmon/data/temp.jim", line 12
/mod/webif/plugin/sysmon/data/cpu.jim:10: Error: file is encrypted or is not a database
at file "/mod/webif/plugin/sysmon/data/cpu.jim", line 10
/mod/webif/plugin/sysmon/data/net.jim:10: Error: file is encrypted or is not a database
at file "/mod/webif/plugin/sysmon/data/net.jim", line 10
/mod/webif/plugin/sysmon/data/smart.jim:10: Error: file is encrypted or is not a database
at file "/mod/webif/plugin/sysmon/data/smart.jim", line 10
I've tried re-installing the custom software (although it seems to complete very quickly, almost as if it isn't actually upgrading anything) and I've reinstalled the webif package - no change.

I've also run a disk check in Maintenance Mode - no issues found.

I have also tried the following:
Code:
humax# ls -l /mod/monitor/monitor.db
-rw-r--r--  1 root  root  34816 Apr 28 04:44 /mod/monitor/monitor.db
humax# mv /mod/monitor/monitor.db /mod/monitor/monitor-old.db
but now I get the following errors since there is no database file (I was hoping something would recreate it after a reboot)
Code:
humax# cat var/log/webif-error.log
/mod/webif/plugin/sysmon/data/temp.jim:12: Error: no such table: temp
at file "/mod/webif/plugin/sysmon/data/temp.jim", line 12
/mod/webif/plugin/sysmon/data/temp.jim:12: Error: no such table: temp
at file "/mod/webif/plugin/sysmon/data/temp.jim", line 12
/mod/webif/plugin/sysmon/data/cpu.jim:10: Error: no such table: vmstat
at file "/mod/webif/plugin/sysmon/data/cpu.jim", line 10
/mod/webif/plugin/sysmon/data/net.jim:10: Error: no such table: net
at file "/mod/webif/plugin/sysmon/data/net.jim", line 10
/mod/webif/plugin/sysmon/data/smart.jim:10: Error: no such table: smart
at file "/mod/webif/plugin/sysmon/data/smart.jim", line 10
System details:
Code:
Web interface version: 1.3.2-8
Custom firmware version: 3.10 (build 2734)
Humax Version: 1.03.12 (kernel HDR_CFW_3.10)
Loader Version: a7.33
Ideas for either issue please?

Thanks in advance.
 
Last edited:
OP
R

RickT

New Member
Thanks Black Hole.

I did a Reset CFW from the diagnostics screen, rebooted ... and then realised I'd forgotten to take a note of the various packages I had installed and their settings! Ooops.

Anyway, I had the basic webif being presented to me, but I did a software upgrade again from a USB stick, to make sure that was ok, then installed the full webif, and have spent the last hour or so browsing the package list, remembering what I had installed, re-installing them and tweaking things.

So far so good, the graphs are working again, and installing a package doesn't result in the webif dying, and everything else I've tried seems to be ok as well, so whatever went wrong has been fixed.

Thanks. :)
 

Kev_w

Member
I have also noticed that a couple of my packages have stopped working properly. "Fan" and "undelete".

Is there a way of recovering these packages without resetting the whole of CW? I tried just uninstalling a reinstalling those packages but no luck.

I noticed that all my settings for the two packages remained after uninstalling/installing so I assume there is part of the package that persists after removal - any way to just reset the problem packages?
 

Black Hole

May contain traces of nut
Have you done a fix-flash-packages?

fan does seem to have a habit of dying for no apparent reason.
 

prpr

Well-Known Member
All fix-flash-packages does is force a package reinstall, so if you have already uninstalled and reinstalled then there is no point in doing it again.
 

Kev_w

Member
fix-flash-packages fixed my issues.

It must clear something a normal uninstall doesn't?

Although I don't think I power cycled before reinstalling manually when I tried that... if that could make a difference?

All fixed now anyway. So glad - I forgot how annoying the standard function of the fan was.
 
Last edited:
Top