• The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

WebIf / EPG problem on HD-FOX T2

#2
Strange one this, I have two HDs, both same configuration, on one the EPG works on the other EPG does not work! Both have all the same packages installed and latest webif 0.6.4-1. Tried reinstalling webif but gives same result, strangely however if I click on more options then a genre it displays the list of matching programmes with channel logos but won't display the regular EPG. I don't use this feature normally so am not that bothered, however if you have any bright ideas on how to fix I am happy to test.
 

af123

Administrator
Staff member
#6
Unfortunately mine fixed itself before I could investigate further. It could have been that the EPG database was being updated, or that something about the current programme on BBC1 was unparsable for some reason.. will have to keep an eye on it.
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#7
Super-Lurker is still reporting complete failure getting the EPG, despite refreshing everything. I suppose I shall have to break out my HD-FOX and try to replicate the problem.
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#9
S.Lurker has installed 1.11 already! I don't think that will have changed the disc-based stuff though will it. For what it's worth, here's what happens when he tries an EPG search:

Runtime Error: /mod/var/mongoose/lib/epg.class:136: near "/": syntax error in procedure '.00000000000000000001>' called at file "epg_search.jim", line 97 in procedure 'epg get_channel_info' called at file "/mod/lib/jim/oo.tcl", line 46 at file "/mod/lib/jim/oo.tcl", line 62 at file "/mod/var/mongoose/lib/epg.class", line 136
 

af123

Administrator
Staff member
#10
That's very odd. I can fix the error which should get him further, but that really shouldn't happen. (It's a non-numeric service id in his EPG data).
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#12
I have been delivered a screen grab of the next runtime error (with 0.6.6-1):

Runtime Error: /mod/var/mongoose/lib/epg.class:80: expected number but got "" in procedure '.00000000000000000001>' called at file "epg_search.jim", line 99 in procedure 'epg ended' called at file "/mod/lib/jim/oo.tcl", line 46 at file "/mod/lib/jim/oo.tcl", line 62 at file "/mod/var/mongoose/lib/epg.class", line 80
I hope I don't have to type out many more of those! (Phew! - SL's learned how to select-copy-paste)
 

af123

Administrator
Staff member
#13
Something is definitely screwy in the EPG data. This one is due to an event having a null start time or duration. More defensive programming required.
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#14
Far be it for me to criticise, but one of the first lessons I got when "apprenticed" in hardware design (well, mentored really) was when my supervisor hit my circuit with unexpected input and broke it. But I know it's hard work trapping all error input.
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#15
Super Lurker is now reporting EPG success with WebIF 0.6.5. However, he says the pie chart keeps dropping back to the USB stick even though his hard drive is the top of the list.

New info: :confused: he seems to have different versions of WebIF installed on the HDD and the USB stick, and gets different results according to whether he's got one or both plugged in! More of a standardised test environment required...
 
OP
OP
Black Hole

Black Hole

May contain traces of nut
#17
He's been playing.

Configuration: Buffalo Ministation HDD + USB pen drive (UPD) via Trust USB port multiplier. /mod folder exists on both HDD and UPD. Starting with only the HDD...

Super Lurker said:
The HDD by itself shows the correct Pie chart as you would expect, and is Drive 1.
Hot plug in UPD and it shows up as Drive 2. When highlighted the Pie chart still shows that of the HDD.
Everything is normal on the TV-Media view. Pie chart switches between the two.
However, rebooting with both drives plugged in crashes the WebIF interface. Rebooting with both drives plugged in (but having removed the /mod folder from the UPD)...
Super Lurker said:
Went through the same procedure as before, except when I rebooted I got the basic Webif screen with the invitation to- 'Download and Install the Full Web Interface' (I think they are the words - it's the screen you get after installing the modded firmware and restarting). Didn't do it.
I pulled out the UPD but when I re-accessed the Webif I still had the basic screen.
Required a reboot to get the full Webif back.

Obviously the UPD must not be left in. It is strange that the Humax detects the UPD first.

It seems that the Pie chart shows whichever drive is first in the lineup and stays stuck on that.
And apparently...
Super Lurker said:
I can only see the UPD Pie chart in Webif if the UPD has the mod folder.
Commentary: I'm not sure about the "when highlighted" part - is the pie chart supposed to follow the highlighted drive?

Super Lurker said:
I have had a thought about why the UPD is detected first. Nothing to do with the position in the USB extender.
The UPD is alive, so to speak, as soon as it receives power but the HDD takes a little longer to spin up. Enough of a lag for the HDD to come second.
Does any of that make any sense?
I think he's probably hit the nail on the head there.

I'm getting this second hand and I only bring it up because of the current issues with the pie chart logic. SL says his kit does what he needs it to do and he is only pushing boundaries.
 

af123

Administrator
Staff member
#18
Ok, that makes sense. On the HD model, the mod software has to be installed on an external disk and it is always going to boot from the first one that the Humax detects. It should be possible to change this behaviour in a future version however.
 
Top