WebIf not displaying anything, with undelete installed


Over the last couple of days WebIF has brocken.

I load the page from firefox, in Windows 7 and I get asked for my password then is displays just a line across the top but no text.

I've tried updating the firmware to the lastest 3.02 with 2.32 but still the same
I've tried the 'system flush' file, but it just made me retune but still no WebIf display.
I've tried clearing my broser cache.
I've tried reinstalling WebIF via a USB stick and the log file said it was succsessful. But still the same.
I don't have Internet Explorer to try.

Then I tried the 'reset' WebIF file. This seemed to work....
I had to reinstall WebIF from the web and it seemed fine, just my setting and installed packages were gone.
I then installed all the packages I use. But when I returned to WebIF's home page it would not display correctly again. I clicked back in the browers and it displayed the package page OK. So then I uninstalled the odd package retring the home page each time. When I removed 'Undelet' it worked again!

So I'm guessing there's a icon or something which has become corrupt and isn't removed in a reset.
Does anyone know what files I'd need to munally remove to make this work again? :cool:

I'm in maintainance mode now running sidk checker
I recommend you download Chrome or something and see if the problem is the same in a different browser.
Thanks, but just the same in Chrome.

With undelete installed WebIF home page will not show, just the bar across the top.

I've tried the 'reset' WebIF file via USB. I'll try a 'remove all custom firmware packages and setting' now I've the WebIF working.
OK tried 'Remove all custom firmware packages and settings' but same thing.

I only install 'WebIF', which works. Then I install 'undelete' and the home page is gone again.
/mod/webif/lib/system.class:159: Error: 16 /media/My Video/[Deleted Items]du: /media/My Video/[Deleted Items]/Recent Comedy/1 Cartoon/The Simpsons/_duplicates: Input/output error
in procedure 'header' called at file "/mod/webif/html/index.jim", line 5
at file "/mod/webif/lib/setup", line 33
at file "/mod/webif/html/lib/header.jim", line 46
at file "/mod/webif/html/lib/topbar.jim", line 11
in procedure 'system' called at file "/mod/webif/html/diskspace/diskspace.jim", line 16
at file "/mod/webif/lib/system.class", line 159
OK I tried to delete "/media/My Video/[Deleted Items]/" using the TV interface and it got stuck, so I deleted it with WebIF and its all working again:).

Thanks foir the help, gave me something to do today...:thumbsup:
Last edited:
Needs looking at if a dodgy file in the media folders can kill the WebIF! Unfortunately you've now swallowed the evidence...