WebIf Remote Controller 'OK' 'OK' 'OK' 'OK' 'OK'

Black Hole

May contain traces of nut
If that is so, and yet the OP used my instructions to check and came up with mode 1, there is something to investigate.
 

michael.h

Member
FIXED!!:)
Problem Remote handset and Settings remote control mode did not match.
Perhaps a hi-lighted panel in the http://wiki.hummy.tv/wiki/WebIf_Remote_Controller detailing how to check the mode currently set for the Remote handset and where to change the setting in the webif might help.
I will now be able to help friend who also have the Humax and want continual hand hoding.
Thanks guys.
 

af123

Administrator
Staff member
So your physical remote /was/ set to mode 6?

The on-screen display that Black Hole had you bring up should have said something like

"You can change the remote control mode.
Press a Numeric Key (<1> ~ <6>) to select the mode
Current mode: Mode 6."

I'm glad you have got it working though. Only BH's to fix then... *<: )
 

af123

Administrator
Staff member
graphics which pop up when you press an unallocated mode button (probably DVD or Audio) on the handset.

They pop up when you:
  • press any of the four mode buttons, allocated or not;
  • press any standard key whilst in an unallocated mode.
It's the first behaviour that particularly annoys some people, hence the option to suppress them. I don't see them now I don't use the original Humax remotes.
 

michael.h

Member
Yes physical remote set to mode 6 but Settings remote control mode set to the default Mode 1.
When I did the OK + 0 on the handset it definitely reported Mode 1!
I have checked again and still get mode 1!
 

Black Hole

May contain traces of nut
Yes physical remote set to mode 6 but Settings remote control mode set to the default Mode 1.
When I did the OK + 0 on the handset it definitely reported Mode 1!
I have checked again and still get mode 1!
Then how do you know the remote is set to mode 6? Is it only because you found setting mode 6 in the WebIF settings made it work???

If the on-screen panel (in response to "OK"+"0") says you are in Mode 1, then you are in Mode 1 and there is a problem to sort out in the WebIF or ir package. I will see if this cures my HD-FOX.
 

Black Hole

May contain traces of nut
Damn!

I didn't check whether ir still was not working first. I checked the handset mode, and it came up with Mode 1, but rather than leave it to time out I pressed "1". ir is now working, but I can't say what made the difference (it might have been working before, I have not checked for ages).
 

Black Hole

May contain traces of nut
@ michael.h, bring up your mode again and exit by pressing "1". ir should stop working. Then go and change the WebIF setting to Mode 1 and it should start working again.

If this is the case, there is a bug somewhere but I can't figure out where. Suppose the Humax had a bug which caused the factory default to be mode 6 but report mode 1, then anyone who had not changed their handset mode at all would have a non-functioning ir package, and replacement universal remotes would be non-functioning unless they were assigned mode 6.
 

Ezra Pound

Well-Known Member
It's probably of no consequence but I just noticed that the time stamp michael.h's Humax in #14 is Epoch plus 71787 (about 20 hours), i.e.
Code:
route: SIOCADDRT: File exists
[RR] Thu Jan  1 19:56:27 1970: Ring going blue, full boot.
DRV_DSC_Init_Begin
SIOCDELRT failed , ret->-1
 

af123

Administrator
Staff member
If the on-screen panel (in response to "OK"+"0") says you are in Mode 1, then you are in Mode 1 and there is a problem to sort out in the WebIF or ir package.

The IR package reports the actual remote control codes received, and the remote control is definitely transmitting mode 6 commands.
 
Top