Webif site has wrong IP for DLNA server

Configured DHCP on my WiFi router to assign static IP address to the Humax's MAC address. All working fine. Tested all the major functions (decrypt, streaming via Webif, download); all working fine.
Just wondering if this worth a note in any WiFi FAQs there might be around in this site?
Finally - I assume that there is only one way to set a Fixed IP address for the WiFi? (i.e. via the on-screen menus in the standard configuration for the Humax) - just wondering whether Ollie might have configured the Fixed IP via a different route to me.

Anyway, many thanks to all for your assistance. Also, this software is really great; I'm very impressed.
AFAIK there is only one way which is via the Humax config menus and that's certainly how I configured mine.
Since its pretty simple to do I wouldn't think there would be any point doing it another way and as has been said its not strictly necessary to set up the Humax with a static IP, as long as its done on the router.
I agree with you, the software is excellent and i'm keeping my fingers crossed that it might in time be able to turn a youview box into a standard HDR.
No I mean completely ditch the youview firmware (including the catch up) and turn a youview box into a standard HDR. Why? Because as lovely as catchup TV is, the Humax youview box is like taking a high end car with all its luxury and useful features, stripping out the inside (and all those lovely features) and replacing it with nothing but a top of the range sat nav. Yes its nice, but no DNLA, both USB's are redundant so no copying off the box, nor playing anything via USB, or network for that matter, No wifi support (yet) no folders, no portal (custom or otherwise) no webif, over 2 mins for the box to load and that's not even mentioning half the extras the custom CF brings. Anyone who buys a YV box after using and owning a HDR would be very very disappointed.
I'm still a bit confused as to why you would want a Humax YouView box converted to an HDR when you could just buy an HDR in the first place, there have been some hardware changes in order to get the YouView features to work but they would give little advantage in HRD mode
Because companies such as Talktalk and BT are giving away free boxes on certain packages so if I got a free box I would much rather have it operating as a HDR rather than a YV. £300 for a HDR vs £0 for a YV box!
Not only that some people might already have a YV box they wouldn't mind converting ;)
hmmm... not sure that the YouView to HDR conversion will ever happen - don't think it will be as easy as you think!

Thanks for doing the groundwork on this Wifi dongle issue though - I think I was having the same issue but just ended up using a homeplug instead! I've just got my hd-fox T2 box for the bedroom that I will use my dongle with - i'll be sure to assign the ip on my router...
Because companies such as Talktalk and BT are giving away free boxes on certain packages so if I got a free box I would much rather have it operating as a HDR rather than a YV. £300 for a HDR vs £0 for a YV box!

Just to clarify, the TalkTalk and BT boxes, will not be made by Humax.
oh I didn't know that about the 'free' boxes from the ISP's. In any event yes the Humax YV seems pretty locked down, it cant be found or accessed via network, but I believe the YV specs state that it must be upgradable via USB which leaves open the possibility of installing a firmware (custom or otherwise) and depending on exactly what hardware changes have been made and if they would conflict with the HDR firmware.
I have just experienced the identical problems (and IP numbers) described by opj1970 in respect of two files which I wanted to download to my PC which is connected to the Humax by wireless. I noticed that each file had an exceptionally long title (in excess of 44 characters including the numerical date.) I renamed both files to approximately 30 characters for my own convenience and lo and behold when I tried to download for a second time they both downloaded without any attempt to connect to the non-existent device, successfully connecting at Have I inadvertently stumbled on the real problem - an excessively long title in excess of a given parameter?
Sorry to resurrect an old thread but I've started to notice the default wlan0 IP address ( assign itself to the Mediatomb interface on my Wifi connected HDR.
The Humax is assigned a DHCP [fixed] IP (on a different subnet) by my router and WebIf works fine on this.
The hosts file contains the correct IP however modinit.log is riddled with the default IP.

Setting a static IP via the Humax system menu seems to result in the inbuilt DLNA server suffering the same problem.

Did this issue ever get fixed? Is there a way to manually assign Mediatomb the desired IP as a workaround?
can I add that I'm having the exact issue as tech76 ...

DHCP is randomly allocating IPs (too often imho but nvm) but the web interface works fine once you've worked out what the right ip is...
however... mediatomb points to

I checked my hosts file and this is what I have (which at time of writing is correct) localhost humax (it has been 4, 7, 8 and 15 with restarts this week)
as an FYI: I've discovered something

/mod/mediatomb/config/mediatomb.html contains

where xxxx = http: //

it works now after correcting the IP - but I'm guessing only until DHCP decides to be silly buggers again :(
I think this is a slightly different issue to the one at the start of the thread - I'll have a look at it.