1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WinSCP

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Wallace, Aug 8, 2011.

  1. Wallace

    Wallace Slightly Pickled

    Could some please tell me which package I need to install (custom firmware), to be able to access the Humax using WinSCP?
    I have a Topfield 5810 connected to my network via a ASUS router (running LINUX). I have found WinSCP to be very useful.
    Thanks.
     
  2. af123

    af123 Administrator Staff Member

    dropbear-ssh is what you need.
     
  3. Wallace

    Wallace Slightly Pickled

    TBH. I have tried that, but still couldn't log in. I must be doing something wrong.
     
  4. rogdog

    rogdog Member

    I am using WinSCP and connect using the following settings

    PortNumber: 22
    Protocol: SCP
    username: root
    password: humax

    [EDIT]
    corrected password
     
  5. Wallace

    Wallace Slightly Pickled

    Surely, those are YOUR user name and password? You have changed it/them from the default?

    I have not altered the factory default password (still 0000), and is the user name humaxftp?

    Cannot connect, access denied.!

    What are the user name and password?

    FYI: dropbear-ssh is now installed!
     
  6. Black Hole

    Black Hole Ron Glum

    Somebody wanna let the rest of us in on what SCP is supposed to do for us?

    "WinSCP: open source Windows SFTP client with support for legacy SCP" - so what?
     
  7. rogdog

    rogdog Member

    whoops, let's try again

    The settings for SSH are

    PortNumber: 22
    Protocol: SCP
    username: root
    password: humax

    The username and password you are using are for FTP.
     
  8. rogdog

    rogdog Member

    Try wikipedia

    http://en.wikipedia.org/wiki/Winscp
     
  9. Wallace

    Wallace Slightly Pickled

    Nope, still not playing....
     
  10. rogdog

    rogdog Member

    Not sure why it's not working for you.

    Maybe there is a clue in the following post from af123

    http://hummy.tv/forum/threads/customised-hdf-file-released.232/page-2#post-2591

     
  11. Wallace

    Wallace Slightly Pickled

    Dropbear is installed. Username :root, password:humax

    Still not working. Never mind. Running out of time to play tonight. I will try again soon.

    Thanks for you time.
     
  12. rogdog

    rogdog Member

    After installing dropbear did you make sure it is actually running. You can check its status via the web interface under service management.
     
  13. Wallace

    Wallace Slightly Pickled

    Yes. The service management confirms installed and ON.
     
  14. rogdog

    rogdog Member

  15. Wallace

    Wallace Slightly Pickled

    PuTTy works. Always has done with the Humax. Must just be a setting in WinSCP.
     
  16. rogdog

    rogdog Member

    Have you actually had Putty working when configured to use SSH or just FTP ?
     
  17. Wallace

    Wallace Slightly Pickled

    Thinking about it, SSH. I just checked.
     
  18. Black Hole

    Black Hole Ron Glum

  19. Wallace

    Wallace Slightly Pickled

    Ha. Things seem to be going my way tonight. Having just got file copying/decrypting on the fly working I thought I would try WinSCP again.

    Got that working too! This time it was my fault. Simples. I wasn't waiting long enough for the connection! WinSCP threw up a warning box stating that it was over 15 seconds and no connection. I thought it was a time-out message so hit abort. If I had more patience and waited a wee bit longer, the Humax's folder tree would have appeared.

    I am one happy bunny tonight.

    Thanks all for you help.