1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

0GB on internal HD

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by RJL, Nov 2, 2012.

  1. RJL

    RJL New Member

    Hi all
    Firstly great forum and site, if i get the thing working again I look forward to getting to grips with all the extra stuff it can do. I thought I was reasonably switched on tech wise but this has got me stumped for a few days now so here I am seeking guidance from those in the know.

    Woke up a few days a go to The HD must be formatted message at start.

    Checked the settings data storage of the HDR-FOX-T2 and all aspsects were 0GB

    Cannot access the media folders of which about half of the 500GB was used.

    Disk check comes up fine and everything else seems to work fine i.e epg etc.

    I read somewhere that it could have been down to having a large file recorded on it and hence the whole disc is now full? Could that be the case?

    The suggestion was to load the custom software upgrade (in order to check the disks/delete files via the web if) which I have done and on boot up it displays Cust FW 2.13

    The TV Portal works fine.

    I have checked the IP address and tried both static and dynamic addresses however I cannot get my computer to bring up the webpage.

    I have tried Pinging the address and it is fine and even tried looking for it using Telnet and it finds HUMAX#

    I am assuming therefore that the web-if has not loaded but I am empty of ideas and tech knowledge.

    I would be grateful for your help, and my wife would really like all the Downton Abbey episodes back. Personally I would rather format the disk again!!!
     
  2. xyz321

    xyz321 Well-Known Member

    If you haven't done so already, try running fix-disk from the telnet connection.

    Edit: If it fails to run, don't be too discouraged, please post any error message here so that someone can help.
     
  3. The customised software is loaded onto the hard disk, only a small part of it is in the flash memory. If you have a disk read/write problem the webif would not be able to run because it couldn't be loaded to the hard disk. The telnet option is I believe in the flash so you should be able to talk to the Hummy that way and run the disk utils which are also now in flash memory.
     
  4. Black Hole

    Black Hole Felinos Guru

    To put some flesh on that, the main advance in CF2.12 (and improved in CF2.13) is a disk checking and repair utility burned into the firmware, without requiring any further download or the WebIF. As long as you can connect to the command line interface by Telnet, you can type "fix-disk" at the command prompt.

    Note that the Humax operating system is based on Linux, therefore expects UNIX-type end-of-lines. A DOS/Windows system uses the two-character CR-LF combination as an end-of-line (Return), which is interpreted as two end-of-lines by the Humax, and one can get away with it for single line commands (it just generates a second command prompt) but not when a command requires additional input (eg fix-disk). The Windows Telnet client has a command (before opening a connection to the server) "unset crlf", PuTTY and some other clients have an option setting, clients with no method to control this setting at all are not suitable.
     
  5. af123

    af123 Administrator Staff Member

    The link in xyz321's post takes you to the section of the wiki that goes through the fix-disk process and includes a link to the telnet configuration notes. Give it a go, in most cases it will restore the recordings even if it takes a couple of goes with different options (people here will advise).
     
  6. RJL

    RJL New Member

    I get this from PuTTY
    touch: /var/lib/humaxtv/mod/maintenance.boot: No such file or directory
    The Humax will now reboot into maintenance mode
    After reboot please wait until the front panel display shows:
    MAINTENANCE
    and then telnet in and type this command:
    fix-disk
    Rebooting.......

    The Humax reboots straight back into normal mode with format disk message ?????
     
  7. Ezra Pound

    Ezra Pound Well-Known Member

    I'm not sure why you are entering the 'touch' line, rather than starting with fix-disk
     
  8. Black Hole

    Black Hole Felinos Guru

    It's part of the new scripts in 2.13.

    I think you had better try with 2.12. If your drive has gone read-only, it won't be able to set markers to control the boot process in the way that 2.13 has introduced. af123 might need to reconsider the way this works.
     
  9. RJL

    RJL New Member

    Thanks will give 2.12 a go.
     
  10. Ezra Pound

    Ezra Pound Well-Known Member

    Where is that documented?
     
  11. xyz321

    xyz321 Well-Known Member

    No, no, no, please don't revert, that part has not changed between 2.12 & 2.13.
    It is a bug in both versions of fix-disk :(

    Try this before running fix-disk:

    Code:
    mkdir /var/lib/humaxtv/mod
    
    You should only need to do this once since this directory would normally be created if the mod had previously been installed on a working disk.

    Ah well, I've got some other changes that may be able to go into the CF.
     
  12. RJL

    RJL New Member

    No difference
    :(
     
  13. xyz321

    xyz321 Well-Known Member

    Sorry, what have you tried, old firmware or the mkdir command or both?
     
  14. RJL

    RJL New Member

    Just doing the above and fix-disk is now working....will post results shortly
     
  15. RJL

    RJL New Member

    I did revert to 2.12 and no difference but as you mentioned xyz321 i entered mkdir /var/lib/humaxtv/mod
    and it seems to be working so far the fix-disk is running :)
     
  16. RJL

    RJL New Member

    Are you having problems with a delete loop Y/N
    What does that mean?
     
  17. Black Hole

    Black Hole Felinos Guru

    There is a failure mode which causes the HDR to lock up deleting everything in sight. If you are not having that one the answer is "no".

    Sorry about my mistake earlier, the Maintenance front panel message is new in 2.13 so I presumed the method used behind the scenes had changed a bit - if not, the touch command is still part of the scripts, it's just been there longer than I thought!

    Is there an issue (in general) booting into maintenance mode, if it relies on flags on a drive that might have become read-only?
     
  18. RJL

    RJL New Member

    That has worked. :) Thank you very much indeed. All recovered. All working fine. Web-IF works so intend to update back to 2.13....
    Thank you all very much and thanks xyz321
     
  19. xyz321

    xyz321 Well-Known Member

    Yes, the problem will only occur if the mod. has not been previously installed and the hard disk is read only or not mountable.
     
  20. Black Hole

    Black Hole Felinos Guru

    Okay... so perhaps the logic should be inverted: boot into maintenance mode unless there is a /mod flag to stop it?