1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Before I reformat....

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Chris Ames, Jul 19, 2012.

  1. Chris Ames

    Chris Ames New Member

    Been lurking for a while, since researching what PVR to replace a homebrew PC based set up with and it's time to ask a question that I couldn't find an answer to anywhere:
    Is reformatting the only solution to the message to the effect that a reformat is required, or are there any other ways of resurrecting the hours of recordings, possibly wget to a PC, reformat then import? The unit is still under warranty, so applying screwdrivers isn't really an option I'd like to pursue just yet. For completeness, it is a HDR-FOX T2 1TB, running 1.2.28 courtesy of the OTA update recently and no custom firmware (yet).
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    There is a Hard disk checking utility under the Storage Menu you could try e.g. Menu >> Settings >> System >> Data Storage >> HDD Test. It is also possible to FTP all your files to a P.C. and then FTP them back after a HDD format, just set Menu >> Settings >> System >> Internet Settings >> FTP server =ON. FTP notes on the Wiki HERE
     
  3. Chris Ames

    Chris Ames New Member

    Thanks for the suggestions, but it looks like format time. The HDD test failed, error code 8 and nothing shows when connecting to the FTP server:

    ftp> dir
    200 Port command successful
    150 Opening data connection for directory list
    drwxr-xr-x 2 root root 100 Jan 01 00:00 .
    drwxrwxr-x 18 root root 175 May 26 15:19 ..
    226 Closing data connection.
    ftp: 91 bytes received in 0.00Seconds 30.33Kbytes/sec.
    ftp>

    I've tried installing the custom firmware, but I guess as the HDD is playing up, installation didn't work, as the web interface isn't accessible.

    Ho hum, time to rerecord my son's favourite programs.
     
  4. Ezra Pound

    Ezra Pound Well-Known Member

    The link HERE shows how to use the in-built FTP in Windows Internet Explorer or Windows (File) Explorer, in order to use a program called foxy, you don't need the foxy bit but the FTP set-up screen may be of use
     
  5. xyz321

    xyz321 Well-Known Member

    I think the best bet would be to run the file system check in maintenance mode. However, you have a 1TB disk which will probably fail due to lack of memory. There is a package 'fix-disk' which contains a script to perform all the steps and also set up a swap file. Unfortunately the installer, opkg, needs to write housekeeping data to the hard disk, which in your case will fail.
     
  6. Black Hole

    Black Hole Felonius Gru

    For circumstances such as this, is it possible to roll a version of maintenance mode which loads on an external drive? Or some kind of toolbox package which the CF can run from USB (or even better boots from USB)? I have it: a firmware update image that loads as usual, then on reboot runs from the same stick.
     
  7. xyz321

    xyz321 Well-Known Member

    The fix-disk package does install onto the internal flash drive and can then be run sometime later if a disk fault appears. However, it can not be installed if the hard disk is already broken since opkg will no longer run.

    I think a diagnostic script would be the best solution and would be happy to write it if af123 thinks it is a good idea.
     
  8. xyz321

    xyz321 Well-Known Member

    If you have version 2.12 (or later) firmware installed, use the new procedure below. If you have an earlier version installed, then update the box to the latest first.

    Edit: Version 2.13 or later is now recommended since it fixes a few bugs which would occasionally prevent fix-disk from running.

    Edit old method now deleted - it was causing problems and general confusion.

    Version 2.12 (or later) firmware
    This already contains fix-disk - no need to install any additional packages/files.
    To enter maintenance mode (take note of the displayed warning messages):
    Code:
    fix-disk
    
    After the box has rebooted, telnet in and run fix-disk again:
    Code:
    fix-disk
    
    Note that the progress bar may appear stationary for up to 10 minutes.
    After a long series of checks, you should see 'Finished - type reboot to return to normal operation'.
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    I have added this very useful addition to the Wiki HERE Bundle3.png (scroll down to fix-disk)
    With Fix-disk notes HERE for both HDD (CF 2.12) and USB versions
     
  10. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Is this limited to 500GB disks as per your earlier comment?
     
  11. xyz321

    xyz321 Well-Known Member

    It creates a swap file so it should be OK with 1TB disks - I only have the 500GB model for testing. I believe that af123 has successfully tested his 1TB disk using a similar method some time ago.
     
  12. cheesemaster

    cheesemaster New Member

    Chris - I don't know if you have gone ahead and done the format, but I was in this situation recently - I saw exactly the same FTP messages as you, it did take me a couple of goes (and I don't think I did anything differently each time :) ) but I got the FTP working using filezilla fairly easily.

    Then it's just drag-and-drop... Left it overnight punting stuff onto my laptop, formatted the disk, then the following night transferred back. No 2-year old daughter freaking out coz all her Little Charley Bear and In the Night Garden had gone! (phew!) Definitely worth persevering with the FTP stuff.
     
  13. Chris Ames

    Chris Ames New Member

    CM - FTP wouldn't work at all, I tried command line FTP from Windows and a Debian virtual machine as well as Filezilla. The disk has been formatted and my son's favourite series are back on series record. Luckily, I had downloaded .avi files of most of his current "Can I have a little TV time" favourites, so things aren't quite as bad as they could be.
     
  14. Black Hole

    Black Hole Felonius Gru

    FTP needs to be turned on in the Humax settings, unless you have the custom software beta-ftp package installed.
     
  15. xyz321

    xyz321 Well-Known Member

    The FTP transcript in post 3 above suggests that the partition containing the media files was not mounted. It is not going to be affected by FTP settings.
     
  16. xyz321

    xyz321 Well-Known Member

    I have updated my original post regarding fix-disk, with details for version 2.12 firmware.
     
  17. Black Hole

    Black Hole Felonius Gru

    I think you had better review it - there seem to be problems with colour tags in the formatting.

    Update: that's better!
     
  18. MarkHT

    MarkHT New Member

    My 1TB HDR-Fox T2 has just started claiming it needs to reformat the hard disk when I boot it up. I have not reformatted it as I want to recover my many recordings on it. It is running Humax firmware 1.02.28 and customised firmware version 2.11

    I cannot open the web interface but I can connect via ftp and telnet. I am trying to run the fix-disk utility off a USB key drive using the above procedure, running telnet via a wifi link. I have managed to install the utility but when I try to run it I get a permission denied message. Here's the detailed telnet session:

    humax# cd /var/lib/humaxtv/mod
    humax# untar /media/drive1/fix-disk_0.1.tar
    Extracting from /media/drive1/fix-disk_0.1.tar
    Extracting file fix-disk
    Extracting file minibb
    Ignoring symlink mkswap
    Ignoring symlink swapoff
    Ignoring symlink swapon
    End of /media/drive1/fix-disk_0.1.tar
    humax# ./fix-disk
    -/bin/sh: ./fix-disk: Permission denied
    humax#

    If anyone has any ideas how to get round this I'd be very grateful for their assistance.

    Mark
     
  19. Ezra Pound

    Ezra Pound Well-Known Member

    Could you enter :-
    cd /var/lib/humaxtv/mod
    ls -al
    Then post back the display showing the fix-disk attributes e.g.
    -rw-r--r-- 1 root root 10240 Sep 21 14:19 fix-disk
     
  20. MarkHT

    MarkHT New Member

    Here's the result as requested:

    humax# cd /var/lib/humaxtv/mod
    humax# ls -al
    drwxr-xr-x 3 root root 0 Sep 21 13:26 .
    drwxr-xr-x 5 root root 0 Sep 21 13:23 ..
    lrwxrwxrwx 1 root root 27 Oct 14 2011 2 -> /var/lib/humaxtv_backup/mod
    -rw------- 1 root root 3690 Sep 21 13:26 fix-disk
    -rw-rw-rw- 1 root root 6 Oct 14 2011 hostname
    -rw------- 1 root root 17356 Sep 21 13:26 minibb
    -rwx------ 1 root root 22212 Jun 29 21:52 rsvsync
    drwxr-xr-x 2 root root 0 Jul 11 21:10 xinit.d
    humax#