• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

Can’t remove auto-schedule-restore

DAsh

Member
I tried auto-schedule-restore earlier, but quickly got annoyed when I found it causes my Hummy to boot twice on every power up (it is only supposed to reboot a second time if there has been a retune). So I decided to remove it. But I found that’s not possible because it’s not showing in the ‘Installed’ list (strangely, it’s still showing in the ‘Available’ list!).

Any ideas as to how I can remove this package?

Thanks
 
OP
DAsh

DAsh

Member
If I go into Diagnostics, File Editor and browse to /mod/etc/init.d I can see ‘S03autoschedule’. Also present in /mod/sbin/autoschedule where I see ‘autoschedule’

Is it possible to edit the name to small S, or delete in an attempt to disable this package? All I can do is view the file structure, but cannot delete or rename. Can someone point me in the right direction for the place where I can edit/delete file names?
 

Trev

The Dumb One
The better fix would be to find out why it is causing a double boot on every boot cycle.
 

prpr

Well-Known Member
The better fix would be to find out why it is causing a double boot on every boot cycle.
Presumably because he doesn't have anything in the schedule and it's restoring the old one.
Did this not get fixed to support Real-Time Scheduling?
 
OP
DAsh

DAsh

Member
I get “No packages removed” when I enter ‘opkg remove auto-schedule-restore’ in the system command line

Where do I go to edit code so I can disable the package?

Thanks
 

Black Hole

May contain traces of nut
Try re-installing it (clearly something is broken, which a fresh install should fix). If you still don't want it after you've fixed it, an uninstall should work.
 
OP
DAsh

DAsh

Member
I tried force reinstall but it’s still not showing up in the installed packages list (so can’t uninstall from there).

If I can rename/delete the lines shown in post #2 I can hopefully disable the package, but I could do with some guidance as to how to do this
 
Last edited:
OP
DAsh

DAsh

Member
Following advice from Ezra Pound in this thread (auto-schedule-restore problem) I’ve renamed S03autoschedule to s03autoschedule in mod/etc/init.d and my Hummy now reboots normally 😊. However, what should I write in the command line to delete a line of code so I can clear the autoschedule references from the locations in post #2?
 
Last edited:

prpr

Well-Known Member
Did you follow all the way to the bottom of that thread and repeat the suggested actions? What output did they produce?
 

Trev

The Dumb One
Why don't you just try to fix the underlying problem instead of just uninstalling it? Auto-schedule-restore is a really useful package.
 

MontysEvilTwin

Well-Known Member
A general tip: if you want to remove a package but it does not uninstall, then add --force-depends to the end of the command line and try again.
 
OP
DAsh

DAsh

Member
Did you follow all the way to the bottom of that thread and repeat the suggested actions? What output did they produce?
Yes. Followed all way, and no output (same as OP in that thread)
 
OP
DAsh

DAsh

Member
The same. I've tried install again from the available packages list, and force reinstall from the diagnostic window to no effect.
 

prpr

Well-Known Member
Can you PM me a copy of your /mod/var/opkg/status file so I can try it? I think you'll need to Zip it as well for the forum to accept it.
 
OP
DAsh

DAsh

Member
I've attached the file as requested (remember, I renamed S03autoschedule to s03autoschedule in mod/etc/init.d, just in case it affects the data I've just collected)
 

Attachments

OP
DAsh

DAsh

Member
A general tip: if you want to remove a package but it does not uninstall, then add --force-depends to the end of the command line and try again.
I tried as suggested, but again see the message "No packages removed"

Thanks for trying to assist
 

prpr

Well-Known Member
I don't know what that file contains, but it's some unreadable __MACOSX Apple sh!te (AppleDouble encoded Macintosh file).
Oh, I found a zip within a zip, but it's no better:
Code:
Processing archive: :mod:var:opkg:status.pages

Testing     Index/Document.iwa
Testing     Index/ViewState.iwa
Testing     Index/CalculationEngine-5037.iwa
Testing     Index/AnnotationAuthorStorage-5036.iwa
Testing     Index/DocumentStylesheet-5040.iwa
Testing     Index/DocumentMetadata.iwa
Testing     Index/Metadata.iwa
Testing     Metadata/Properties.plist
Testing     Metadata/DocumentIdentifier
Testing     Metadata/BuildVersionHistory.plist
Testing     preview.jpg
Testing     preview-micro.jpg
Testing     preview-web.jpg
 

EEPhil

Number 28
I don't know what that file contains, but it's some unreadable Apple sh!te (AppleDouble encoded Macintosh file).
The file can be opened by 7z and the contents ":mod:var:opkg:status.pages" in the top directory saved and then opened with 7z to reveal directories Index and Metadata along with some jpgs - if that is of any help. I've repacked this if anyone is interested. :)

Edit: Oh 5 hit! You edited or completed your post as I was writing mine. :eek:
 

Attachments

Last edited:
Top