1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cant restore saved Schedule via webif

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by steve2525, Sep 1, 2011.

  1. steve2525

    steve2525 New Member

    Had to do a full rescan and then tried to restore a saved recording schedule, which has worked previously, I get the following error, any suggestions?

    I had updated webif to the latest version before I tried to restore the schedule.

    Restoring scheduled events... Restoring 0000000000000 Runtime Error: /mod/var/mongoose/lib/rsv.class:122: near "s": syntax error in procedure '.00000000000000000001>' called at file "restore.jim", line 85 in procedure 'rsv fix_hsvc' called at file "/mod/lib/jim/oo.tcl", line 46 at file "/mod/lib/jim/oo.tcl", line 62 at file "/mod/var/mongoose/lib/rsv.class", line 122
     
  2. af123

    af123 Administrator Staff Member

    There must be a channel name with an apostrophe in it - I'll upload a fixed version shortly - just want to test it when Torchwood's finished recording.
     
  3. af123

    af123 Administrator Staff Member

    Ok, just uploaded 0.6.6-1 which should hopefully fix this.
     
  4. steve2525

    steve2525 New Member

    Thanks for the rapid reply! I have tried a opkg update then opkg upgrade but cant see an upgraded version of webif, will try again tomorrow.

    Do I need to uninstall webif or can I upgrade?

    Thanks again, the modified firmware and webif are great and the speed that the solution has been produced has been impressive :)

    Stephen
     
  5. af123

    af123 Administrator Staff Member

    Upgrade should work fine, hope it lets you restore.
     
  6. steve2525

    steve2525 New Member

    Updated webif - mixed results , newly created backup restoes ok, old backup dosnt restore, not a big problem have re-entered enties manually:- get the following errors and then the channel restore section which looks ok.
    Restoring scheduled events... Restoring 0000000000000 Cannot find channel, restore failed. Restoring 0000000000000 Cannot find channel, restore failed. Restoring 0000000000000
     
  7. af123

    af123 Administrator Staff Member

    Ok - at least a partial success. I've backed up and restored quite a few times with no problems, and need to next week for the DSO at Elmley Moor. Other people always have more exotic things in their schedule though : )
     
    MattC likes this.
  8. hummyowner

    hummyowner Member

    We have DSO Stage 1 on Sutton Coldfield next Wednesday so I decided to do a test backup/restore (previous attempts worked fine). Unfortunately it has not restored anything even though it reported it had and I lost all of my scheduled recordings and favourite channel which I'd set up. Re-tried several times but no luck at all.

    Tried restoring an old backup but got same result as steve2525.

    Looking on webif it looked as if the recordings had been restored but on the box itself there was nothing (also checked on box EPG).

    Other observations :

    On webif it showed old events which had expired (shown in red on the date/time details) and it showed each event multiple times (both old & future events), at least four times sometimes more.

    Also shows this strange event at the top :

    1.png [​IMG]

    Running Webif 0.6.7 and epg 1.0.3.
     
  9. af123

    af123 Administrator Staff Member

    After you do a restore, it says in the web interface:

    ---
    After restoring the scheduled recordings you MUST restart the box using
    the link at the top of the screen or via the remote control and then add
    at least one scheduled entry using the remote control
    (which you can then delete).
    ---

    Did you do that? If not, clear the schedule list again (best way is to do another channel scan) and try the restore again. You need to do the reboot pretty quickly after the restore and before you go into any of the menus on screen.

    Also, are you running mod 1.11? If not, make sure the reboot is initiated from the button at the top of the web interface rather than using the remote control.
     
  10. hummyowner

    hummyowner Member

    Hi,

    I assume mod 1.11 is something to do with remote scheduling ? In which case I don't use it.

    I have done exactly the procedure you specify. I did notice that when choosing reboot from the webif button a progress bar appeared which went to 100% and disappeared, but there didn't appear to be any interruption on the box, ie it didn't appear to reboot to the startup screen.

    Anyway, the result was still the same - no recording events.

    I also tried the above doing a manual reboot on the box but again the results were the same - no recording events.

    Update : Just noticed on the restore, it doesn't matter which backup I select to be restored the confirm box always displays the earliest backup that I have on the humax as the one to be restored, don't know if this has anything to do with it.

    Update 2 : Noticed that even future events all appear in the 'Pending Schedule Events' and nothing in the 'Scheduled Events'.
     
  11. af123

    af123 Administrator Staff Member

    The entries are supposed to be moved across from the Pending table to the real table when the box is rebooted using the button on the web interface (or via the remote control if you have updated the mod software to version 1.11).

    If they're getting to the pending table then that's a good start - I'll have a look to see if the web interface reboot button is broken for some reason.
     
  12. af123

    af123 Administrator Staff Member

    It worked for me. Pressed the button and got the progress bar, then the Humax restarted.
     
  13. hummyowner

    hummyowner Member

    Just tried again and the Humax is definitely not rebooting and a manual reboot does not copy the pending entries.

    What is this mod 1.11 - can't find it in package management at all.
     
  14. af123

    af123 Administrator Staff Member

    It's the latest version of the custom firmware.

    If you're willing to go to the command line, then you can force a synchronisation like this:

    Code:
    humax# jimsh
    Welcome to Jim version 0.71
    . source /mod/var/mongoose/lib/setup
    . require rsv.class
    . rsv commit
    
    Then restart it with the remote control.
     
  15. hummyowner

    hummyowner Member

    Ok, thanks have done that, nothing much seemed to happen.

    Slight change in that according to webif when the reboot happens the recordings are moved from pending to scheduled but nothing is shown on the Humax itself and as soon as I add a new recording the only entry showing on the Humax and webif is the new recording.

    Just in case it was a rogue backup, I have also created some new recordings and backed those up and tried to restore them but get exactly the same results.
     
  16. xyz321

    xyz321 Well-Known Member

    It is the latest modified firmware which has to be installed using a FAT32 formatted USB drive.

    See "Firmware Downloads" & "Install Modifed Firmware" on the Wiki or http://www.hummy.tv/forum/threads/customised-hdf-file-released.232/ You will not have to re-install any packages.
     
  17. hummyowner

    hummyowner Member

    Ok thanks, the previous note from af123 should have resolved that but to be certain I have downloaded the file and applied it.

    And now everything is working! I had previously read that this new amendment was only for those who wanted remote scheduling.

    The reboot works properly with this version and the restore is completely successful. :)

    af123 I can confirm that there is an issue with the reboot from webif without the 1.11 update and using the remote control does not get around this. I would suggest that you recommend everyone to upgrade to 1.11. Also, in the restore process the text in the confirmation box needs to be altered because at the moment it always suggests that you are restoring the first backup you took even if you have chosen a different restore. It restores the correct file but is a bit misleading.

    Many thanks to af123 and xyz123 for you assistance, hopefully DSO will go smoothly on Wednesday!
     
  18. af123

    af123 Administrator Staff Member

    Excellent news - I'll update the confirmation text, thanks.

    I think the backup/restore might be used a few times over the next couple of weeks...
     
  19. TomT

    TomT Member

    How do I check if I have 1.11 installed.? How do I get it and install it?
    Thanks
     
  20. af123

    af123 Administrator Staff Member

    There will be a file on your Humax hard disk, /etc/modversion which contains details of the version you have.

    See http://wiki.hummy.tv/wiki/Firmware_Downloads for download locations.