1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[CFW 2.14] Customised Firmware version 2.14

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by af123, Nov 18, 2012.

  1. af123

    af123 Administrator Staff Member

    I'm pleased to announce the release of version 2.14 of the customised firmware with the following changes over 2.13:
    • Telnet server now automatically converts Windows new line sequences (patch from xyz321);
    • Telnet server now properly handles client window size changes (patch from xyz321);
    • By default, the telnet server will display a menu system rather than a system command line prompt;
    • Option to revert to the previous telnet server behaviour (with webif >= 0.10.0-4 - Settings->Expert mode telnet server);
    • fix-disk works properly if CFW installed whilst the hard disk cannot be mounted (patch from xyz321);
    • fix-disk works properly if run more than once in the same maintenance mode session (patch from xyz321).
    Download from the usual place - http://wiki.hummy.tv/wiki/Firmware_Downloads
    Also see http://wiki.hummy.tv/wiki/Firmware_Upgrade_Path for details on how to upgrade from various firmware versions.

    instructions on how to install or upgrade, see http://wiki.hummy.tv/wiki/Firmware_Upgrade_Path

    This release is mainly focussed around improving the experience for users who need to use telnet to repair or recover their disk filesystems and for other operations such as flushing the EPG cache. Many thanks to xyz321 and Black Hole for providing suggestions, patches and helping to test the release.

    With this firmware update, when you telnet to the Humax, you will be asked for the system PIN (which is four zeros (0000) by default) and then you'll get a simple text menu. Advanced users can still drop to the system command prompt or make that the default if they wish.

    [​IMG]
     
    Tron, brian, SimpleSim and 2 others like this.
  2. Black Hole

    Black Hole Felinos Guru

    It will be handy not to have to type "unset crlf" every time (or tell others to).
     
    af123 and SimpleSim like this.
  3. Pablo Pablo

    Pablo Pablo New Member

    Fantastic. af123, your commitment and dedication to improving the lot of us Humax users is wonderful and so appreciated. Thanks!
     
  4. Brian

    Brian Administrator Staff Member

    I have got this installed on my boxes, and have just tried to access the new telnet features. I was initially stuck at the "Enter system pin:" stage, I started typing 0000 but did not see anything happening on screen, and the cursor did not move, so I thought that it wasn't working. Then I just tried 0000 followed by Enter, and it worked. Perhaps it should be pointed out in the release notes that this is what to expect.

    Perhaps it would be worth putting a link to where the firmware is available from for those who do not know to look in the WiKi.
     
  5. af123

    af123 Administrator Staff Member

    Yes, unfortunately the standard busybox shell as compiled by Humax doesn't support the feature I need to make this a bit better.. the shell in the custom firmware environment (on the hard disk) does though, so there's hope.. I'll have a look.

    Done, thanks.
     
  6. Brian

    Brian Administrator Staff Member

    Thanks.
     
  7. Ezra Pound

    Ezra Pound Well-Known Member

    Note now added to WiKi HERE
     
    brian likes this.
  8. YuppieScum

    YuppieScum New Member

    It seems that my ISP has begun blocking ZippyShare - is there an alternate location to download the custom firmware?

    Thanks...
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    Not really, but if you post what version you want to download, I'm sure something can be arranged
     
  10. YuppieScum

    YuppieScum New Member

    Thanks muchly - would like to grab "HDR_FOX_T2_1.02.29_mod_2.14.zip" if at all possible...

     
  11. Black Hole

    Black Hole Felinos Guru

    The files are on Zippyshare so the originator can monitor downloads. Previously they were on 4share which caused problems.

    Are you sure it is your ISP blocking this, and not some over-zealous malware blocker on your PC?
     
  12. YuppieScum

    YuppieScum New Member

    Quite sure - I've tried this from several machines (Windows & *nix) including the Nexus 7 tablet I'm typing this on...
     
  13. Nole

    Nole New Member

    I don't know whether or not it is just coincidence but after installing CF 2.14, Filezilla client stopped working. I tried reconfiguring using the built in wizard but with no success. It doesn't seem to recognise the URL like it used to but TV portal connects and works OK. Any ideas.

    Nole
     
  14. fenlander

    fenlander Active Member

    Sounds like the Hummy has picked up a different IP address from your router. Is the Hummy getting its IP address automatically from the DHCP server or are you using a fixed address?
     
  15. Nole

    Nole New Member

    I have set the ip address manually via the menu as 192.168.1.65. The wizard suggests 92.2.228.127 but this doesn't work either!!

    Nole
     
  16. Black Hole

    Black Hole Felinos Guru

    Has the internal FTP server become enabled by accident? The standard server cannot coexist with betaftp.
     
  17. YuppieScum

    YuppieScum New Member

    Ezra,

    Thanks for the potential offer, but took my tablet to the pub tonight and grabbed it from there :)

    However, it does show that some UK ISPs are now blocking ZippyShare...

    Thanks,
    YS
     
  18. prpr

    prpr Well-Known Member

    Would you care to name and shame your ISP then?
    Have you informed them of the problem?
     
  19. Ezra Pound

    Ezra Pound Well-Known Member

    It may be that ZippyShare has detected 'anti-tracking' software, I run a plug-in to Firefox called Ghostery which prevents sites tracking your visits, however I have to switch if off when downloading from Zippyshare in order to make it work
     
  20. YuppieScum

    YuppieScum New Member

    My ISP at home is T-Mobile - using Chrome on my Nexus 7 tablet to get the custom firmware returns an HTTP error code of 500.

    Using the same tablet and browser in my local (unsure of ISP) downloaded the file with no issue...

    On that basis, I would say it's an ISP blocking issue.

    I don't want to come off all whiney - I'm not only grateful for all the efforts put into the custom firmware and packages, I now have an extra reason to go for a beer :)

    Cheers,
    YS