Chrome and humax web portal

annonimouse

New Member
I've only just started going to my humax again in a browser, with custom firmware installed. In chrome though, it seems to not be rendering properly, in fact it doesn't seem to be downloading all images unless i do a forced refresh (shift-f5). In IE its fine.

Is this a known problem, is there a package i can install to fix this?

Cheers.
 

Ezra Pound

Well-Known Member
Yes there is a known problem with the Current version of Chrome, I think the best advice at present is to use another browser if possible, Firefox for example. There is a thread that discusses the Chrome problem starting HERE, it is mentioned on and off throughout the thread right up to the last post #134
 

Mike0001

Well-Known Member
Yes there is a known problem with the Current version of Chrome, I think the best advice at present is to use another browser if possible, Firefox for example. There is a thread that discusses the Chrome problem starting HERE, it is mentioned on and off throughout the thread right up to the last post #134


Just use the extension IE Tab Multi in Chrome on a PC until webif is fixed.

https://chrome.google.com/webstore/...nhance/fnfnbeppfinmnjnjhedifcfllpcfgeea?hl=en
 

MikeSh

Well-Known Member
Well, I had this problem and for a week or so used Firefox instead. Today (Tues 14) I forgot and used Chrome to do some fiddling and it all worked fine. I only realised my 'error' 10 minutes after I came out and put the box back in standby :oops:

Don't know if Chrome has changed in the last day or two - it currently say it is: Version 26.0.1410.64 m
(this is on a W7 PC btw. Don't know what the m means - possibly because the Google account used shares with another instance on my tablet?)
 

Wallace

Traveler 34122
Well, I was thinking about posting the same. Chrome and the WebIf seemed to be working again for quite some time. However, I just tried it again (your post prompted me), and it was broken again! FYI, I am using the same Chrome version as you.

Ah well, I have kind of got used to using FireFox Portable anyway.
 

Mike0001

Well-Known Member
Well, I was thinking about posting the same. Chrome and the WebIf seemed to be working again for quite some time. However, I just tried it again (your post prompted me), and it was broken again! FYI, I am usig the same Chrome version as you.

Ah well, I have kind of got used to using FireFox Portable anyway.


I am using Chrome v27.0.1453.81 beta-m and the problem is still there. (Bl**dy fonts! :mad:)
 

Black Hole

May contain traces of nut
In your edit window you should see an "A" tool top right - that takes you to a plain text version of the editor so you can see the embedded codes instead of WYSIWYG. Remove the [font]...[/font] tags (or at least those you don't want).

Return to WYSIWYG by clicking the "rich text" at bottom left. For help see "BB Codes" in the help section.

PS: Habitual iPad users (eg me) only get the plain text version, for some reason neither Safari nor Chrome under iOS show the rich text tools.

PPS: You would be staggered how many font tags litter up some people's posts. I think setting a different font embeds every line in font tags instead of just the whole post. (What's wrong with the default forum font? It's much tidier!)
 

Mike0001

Well-Known Member
In your edit window you should see an "A" tool top right - that takes you to a plain text version of the editor so you can see the embedded codes instead of WYSIWYG. Remove the [font]...[/font] tags (or at least those you don't want).

Return to WYSIWYG by clicking the "rich text" at bottom left. For help see "BB Codes" in the help section.


Thanks!
 

MikeSh

Well-Known Member
This is a weird 'feature'. Since my post on 14 May it went to being OK in Chrome, then broke again, and now is working.
When not working it's OK in Firefox.
Oddly the index page is usually (maybe always) OK, it's only the detail pages that don't get formatted when it's broken. :eek:
 

newmikeman

New Member
I'm using Chrome 27.0.1453.110 m and WebIf was displaying badly. I disabled all my extensions (only 3 & simples) and it made no difference. I checked the box on the Extensions page marked Developer Mode, and hey presto it now displays correctly. Of course, it might not be thecure for everyone...
 

fenlander

Active Member
Old topic, I know, but having just done a factory reset/reinstall of my laptop, I thought I'd just confirm that the latest version of Chrome is still pants with the webif.
BUT: try the portable version of Pale Moon as a dedicated webif browser. It's stand-alone, lightweight, quick and being an offshoot of Firefox displays the webif just as well as FF does. Just make the webif your home page.
 

af123

Administrator
Staff member
I've seen reports over on AVForums that Chrome is still having trouble with the Foxsat web interface too... unfortunately, Chrome works fine for me otherwise I would be able to try and diagnose it.
 

Wallace

Traveler 34122
Ever since this trouble with Chrome started, I moved over to FireFox Portable purely for the WebIf on both my HDR's, I have also added a bookmark for the RS service and Hummy.TV

It's great and uncluttered. TBH, I like it the way it is now and don't think I would use Chrome to access the WebIf now anyway!
 

sooty83

Member
There has been some discussions on the net about this problem (e.g. here). The problem occurs when the browser asks for a piece of css and the web server returns 304 (content not modified) but with an incorrect content type of text/plain. This is exactly what happens with the Humax webif. The following request/response was captured by the Chrome Developer Tool:
Code:
Request URL:http://192.168.0.12/css/style.css
Request Method:GET
Status Code:304 Not Modified
Request Headers
Accept:text/css,*/*;q=0.1
Accept-Encoding:gzip,deflate,sdch
Accept-Language:en-US,en;q=0.8
Authorization:Digest username="xxxxx", realm="webif", nonce="1375466735", uri="/css/style.css", response="4f7a978b4892c21d1ec8b9db80f03f2c", qop=auth, nc=00000468, cnonce="f3d25c1420f37f41"
Cache-Control:max-age=0
Connection:keep-alive
Cookie:__utma=212263380.1204960855.1362998529.1362998529.1362998529.1; __utmc=212263380; __utmz=212263380.1362998529.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
Host:192.168.0.12
If-Modified-Since:Mon, 01 Apr 2013 23:23:14 BST
If-None-Match:"515a08d2.16ca"
Pragma:no-cache
Referer:http://192.168.0.12/browse/index.jim?dir=/media/My%20Video/The%20White%20Queen
User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36
Response Headers
Connection:keep-alive
Content-Length:0
Content-Type:text/plain

af123, does this provide enough clue to identify a fix?
 

af123

Administrator
Staff member
Just uploaded mongoose 3.0.10 which should get the content type right for not-modified responses. Can anyone who uses Chrome confirm whether it fixes the issue? Thanks.
 

Wallace

Traveler 34122
I have updated both my HDR's to v3.0.10 and have been using Chrome. So far so good. I have been trying to 'hammer them' and haven't seen an occurrence of the problem - yet.

It was weird though. It used to be OK for ages then the problem re-occurred so jury is still out but defo looking good for me. Although I think I will continue to use FF portable anyway!
 

fenlander

Active Member
Initial impression is good - no dud pages yet. I will resume using Chrome for the webif and report back later on results.

Edit: still no problems: 2 PCs over a couple of hours. Nice one, af123!
 

Ezra Pound

Well-Known Member
I don't normally use Chrome, but did use it to display a few Web-If page errors before installing mongoose 3.0.10, all the previous errors I had seen were correctly displayed after the update, so, for me, looking good
 
Top