1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Content sharing

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by makem, Mar 4, 2012.

  1. makem

    makem Member

    I hve just tried remotely via a tunnel to decrypt in situ a recording. I got the 'Is content sharing turned on' error. As this sometimes turns itself off, is it at all possible to turn it on remotely?

    If not that is a major problem when away from hone.
     
  2. af123

    af123 Administrator Staff Member

    If it is turned off then it probably means your box is just half awake rather than fully turned on. Could that be the case?
     
  3. makem

    makem Member

    It should have been recording at the time but I cannot be exactly sure of the timings because it was due to turn off at 13.30 but had a recording set to end after that. In addition I was in company and could not really spend time checking things. It must have been half awake because the content sharing was still turned on when I returned to the box.

    What made me concerned was the error message which said the the content sharing sometimes turns itself off. I seem to remember that happening one time. That was why I asked if it could be turned on remotely when I would expect to know exactly what state the box was in.
     
  4. Black Hole

    Black Hole Felinos Guru

    It's never happened to me.
     
  5. makem

    makem Member

    I have seen it mentioned twice now. One time by af123 in his error message and once by Sam Widges who asked if there was a possibility of programatically setting it to ON.
     
  6. makem

    makem Member

    Ok, I am tryibg to do exactly the same thing again - decrypt a file before I transfer it via secure ftp.

    I am getting the same error as before:

    The Humax media server is not running, cannot decrypt. Have you enabled Content Sharing in the Humax menus? It can sometimes turn itself off so it's worth double checking. If it is on then try turning sharing off and on again.

    I know that content sharing is on as it was last time. The error is created for another reason.

    At the time of attempting this decrypt in place, the Humax is in AR mode, recording a continuous schedule of 3 programs.

    Any idea why I am getting what appears to be a wrong error.

    EDIT: Using the OPT+ download option I get the error:

    Unable to connect

    Firefox can't establish a connection to the server at 127.0.0.1:9000.

    I will need to think about that error.

    EDIT1: When I use HTTPS web server I get the same error. I forwarded port 9000 to the Humax but still get the error:

    The Humax media server is not running, cannot decrypt. Have you enabled Content Sharing in the Humax menus? It can sometimes turn itself off so it's worth double checking. If it is on then try turning sharing off and on again.

    The problem is the content sharing turning itself off! When I turn it off (as suggested in the error), and then on again it works ok. This definately did happen one time in the past.

    Without a way to access this setting remotely, remote downloading and decryption is not reliable.

    EDIT2: Will use Virtual Disk via Tunnel + WinSCP then won't need Content Sharing :)
     
  7. Sam Widges

    Sam Widges Active Member

    Content sharing doesn't disable itself, but it can crash - I think that's what the "turn itself off" reference is.

    If the content sharing is enabled but isn't there, rebooting the box or restarting the humaxtv process should cure that.
     
  8. af123

    af123 Administrator Staff Member

    I have seen Content Sharing disable itself occasionally. I think it happens when you wake the box up from standby while it is recording.

    I can't test this myself at the moment but wait until it is recording in standby, wake it up and look at the Content Sharing option in the Humax menus; I think it will be Off. If you then wait until the recording is complete and do a full power off/on again I wonder if it turns on again?
     
  9. af123

    af123 Administrator Staff Member

    Forgot to mention - it would be possible to write a package that forcibly re-enabled the option on every boot if it does prove to be an issue.

    Regardless, you shouldn't expect the content sharing to be on unless the box is fully awake.
     
  10. makem

    makem Member

    I have just woken the box up whilst it was recording in standby with the TV turned off (not sure if it was on whether that would have any effect) and the Content Sharing is still 'On'.

    Using the same remote method and the same netbook I would use when remote, I was then able to decrypt a file whilst on the LAN but using my no-ip address.

    Previously I had turned the box on before leaving but did not check if Content Sharing was on (It is always set 'On''), or whether it was due to record before I went out.

    I was able to access the box remotely as expected, locate a small file I wanted to make the test on, selected OPT+ and Decrypt. then I got the Content Sharing error. I tried to download the file and received the same error. Returning home I checked the box which was still on and not recording to find Content Sharing was set to 'On'. That suggests to me the error was incorrect. Previously it had actually turned off whilst it was being used via the LAN and I turned it on from Settings.

    Is it possible that the method of accessing the box is contrary to 'Permissions' in some way and causing the error? I was able to download a file via WinSCP. On that occasion I did not check if I could copy a file to the Virtual Disk as I did not have that installed but think I would have been able to.


    One thing I have never checked (not related to the current error), is whether the box stays 'On' after it records and finishes a recording whilst 'On'. I feel it must stay 'On'.

    Later today I will need to make another remote test. (Only 2 days left), in which I will ensure the box is on and not recording or about to record which is how it will be when later I am remote between 04.30 and 13.30 each day UK (+8 hours where I am). I have Disable OTA installed.

    I want to be sure I can copy a file to the Virtual Disk and then download it from anywhere.

    Can Content Sharing crash but still show as On? Is there a way to check if the Content Sharing has crashed as Sam suggests, whilst remote? Can I restart the humaxtv process whilst remote?