1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dead box - can any one help ?

Discussion in 'HDR-FOX T2 Freeview Recorder' started by jaymonkey, Oct 9, 2012.

  1. jaymonkey

    jaymonkey New Member

    Hi ,

    I bought a Humax HDR-Fox-T2 about 6 months ago on ebay, the 500Gb version. I have been really happy with the unit and once I found this site and installed the custom firmware it’s been the ultimate freeview box.

    However a few months ago, it started locking up, sometimes it would not come out of stand by, sometimes a full power off and switch on would restart the box and it would work for for a few hours, sometimes I had to switch the box off overnight before it would power up.

    I’m a electronics engineer but am not familiar with humax products, I spoke to my local dealer who told me that some Humax products power supply’s are prone to this sort of behavior because of cheep or faulty capacitors in the PSU and recommended a SATCURE repair kit.

    I subsequently ordered the kit ( you have to specify the cap values for the HDR-T2) and replaced all the caps on the switching PSU. Prayed and plugged in the box and it worked fine, I installed the latest official firmware and then updated the custom firmware, the box worked perfectley …. for two weeks then it died completely, no led’s or display, no system start msg, no output to the TV ?

    I’ve checked the psu output to the processor board and the +5.8V and +12V supply’s are all there and fine. I’ve tried to do a restore to the lasted firmware via the front USB port but the box just does not do anything

    Does anyone know of a repair center or expert I could send the box to, I don’t think sending it to Humax will be of any use, as its not registered in my name, the warranty sticker is no longer on the case and of course the caps on the psu have been all been changed even though the psu output stage is fine.

    Can anybody help me or do any of you have any suggestions?

    Thanks for reading
    Cheers
    Jay
     
  2. MattC

    MattC Member

    Is it not still under the 2yr warranty? I thought it still applied even if you bought it off someone else, but maybe you'd need the original proof of purchase?
     
  3. jaymonkey

    jaymonkey New Member

    Not sure, as the box has been opened, and i've changed the caps, i'm guessing that Humax will say the warranty is invalid, also section 2 of the warranty conditions on the Humax site state :-

    2. This warranty will be honoured only if the Warranty Certificate has been duly completed by the purchaser and is presented to the retailer with the original invoice or receipt.

    So I think i'm screwed with regards to the manufactures Warranty.

    Cheers
    Jay
     
  4. grahamlthompson

    grahamlthompson Well-Known Member

    Will the box boot if you disconnect the Hard Disc ? Afaik the capacitor problem is restricted to some Foxsat-HD models only.
     
  5. jaymonkey

    jaymonkey New Member

    Hi grahmmlthompson,

    I just tried your suggestion of disconnecting the hard drive (power + sata) and powering up but the box still seems to be dead despite having power to the processor board.

    Cheers
    Jay
     
  6. grahamlthompson

    grahamlthompson Well-Known Member

    Worth a punt :)

    Can't think of anything else but phoning Humax.
     
  7. jaymonkey

    jaymonkey New Member

    Agreed,

    I fear that the processor board has died, unless anyone else has a better idea or knows of a 3rd party repair shop in the UK, I think the only thing i can do is be upfront with Humax and explane the situation and hope that they dont sting me too much in reapir costs.

    Jay
     
  8. xyz321

    xyz321 Well-Known Member

    I did have a similar problem where the box appeared to be completely dead (no red/blue/orange LED). Eventually it started working again after touching the front panel main "button" many times. It has been fine since.
     
  9. jaymonkey

    jaymonkey New Member

    Thanks xyz321,

    I'll give that a go, how many times was "many" :)

    Jay
     
  10. xyz321

    xyz321 Well-Known Member

    I must have rapidly "pressed" it 10-20 times.
     
  11. jaymonkey

    jaymonkey New Member

    OK, I tried that, several times and some form of life has come back to the box :)

    Now the blue led lights up around the main button and the display reads 'START SYSTEM' then nothing, still nothing on the screen ( have tried HDMI & SCART)
    Its almost as if the boot loader is failing to initialise and load the firmware.

    Has anyone seen this behaviour ?, I dont suppose anyone knows if there is some magic button sequence you can hold down while switching it on to reset the firmware.loader ?

    Cheers
    Jay
     
  12. af123

    af123 Administrator Staff Member

    You could load a firmware update file onto a USB flash disk and plug it in while turning on, but you should at least be getting the bootloader messages on the screen. Is your hard disk reconnected?
     
  13. jaymonkey

    jaymonkey New Member

    Hard drive is reconnected and have got a known working usb stick in te front usb slot, its the one i always use to load firmware ;-)
    Like i said no boot loader message either on front panel display or TV

    Jay
     
  14. jack616

    jack616 Member

    I would have suggested you dash out to farnell or maplin or somewhere and buy a can of spray cold but it sounds like you're
    past that stage. It may still help but it is doubtful now.
    Now you have no warranty I think I'd strip it all down and do a very close search for broken track and dry solder joints.
    Also check the crimps in the plugs etc. Basic mechanical stuff.
    Also put the back of your finger on things to see if they appear excessively hot (you're an engineer you know whats safe if you can work on switch modes - nobody else ever try that - it is seriously dangerous)
    (2x240volts depending on design - not nice but quite bracing first thing in the morning)

    Do all the usual - disconnect anything you can (inc front panel) and see what seems to power up etc. Does the drive spin up ?
    I havnt looked at the boards closely but I'm willing to bet there is a firmware reset by shorting 2 pins somewhere on the board
    if something looks like that it may be worth a go as a last resort
    It may be worth just checking the front panel buttons arent jammed or shorted too.(I really hate that "power" button)
    After that I expect I'd be looking to get a replacement board. (dead processor or memory would be my guess)
     
  15. Black Hole

    Black Hole Felinos Guru

    If the dry joint is under a BGA that will take some finding!
     
  16. jack616

    jack616 Member

    with a dead board all measures are last resort "on the off chance" anyway
    A dead board is the one thing that always annoys me the most
    I much prefer them to only partly work or to catch fire or explode - anything but just
    lie there looking at me going, "go on then smartypants, fix me - I dare you"
     
  17. Black Hole

    Black Hole Felinos Guru

    Tee hee! Curiously enough, when I was fault-finding early production runs in the lab, we preferred the "totally deads" - much easier to find the problem than the "fails production test at step 3,125 - out of specification".
     
  18. jaymonkey

    jaymonkey New Member

    Hi jack616

    Thanks for your post and extensive suggestions. I've already been round with the freezer spray, nothing is unduly hot.

    The hard drive does not spin up, but that also sugest that the boot loader/cpu is not getting very far in the boot up process, usually the hard drive will not spin up until its gone thorough its system start which usually takes a few seconds.

    The wired thing is that if i leave the power on, the main processor with the heat sink, does start to get warm, so obviously there is power to the processor and its obviously doing something otherwise it would not get hot.

    Have been through a few of the more accessible / know IC's to check power between pin 1 and gnd and most seem ok.

    I did remove the front panel, i had the same though that maybe a switch is jammed on, have seen that many times before on different devices, and I agree with you, that main power button is so vague as are the volume and prog up/dn buttons (although these seem to be touch sensitive in any case). I havent removed the processor board yet. The fact that the boot loader does not initialise does indeed sugest that it is either the processor or memory. My personal guess is the rom (flash ?) that stores the boot loader is either corrupted or damaged.

    I'll take the board out and do what you suggested, i'll get it under the lamp with a large magnify glass and look for broken tracks ... etc but i dubt i'll spot anything, if it's on the memory bus its going to be almost impossible to spot but it worth a shot.

    Not sure how to go about getting a replacement processor board, I guess a email to humax would be a start.

    Will let you know how i get on.

    Cheers
    Jay
     
  19. jaymonkey

    jaymonkey New Member

    Black Hole,

    I dont suppose you have a source of processor boards, maybe i could send the unit to you. I'd be happy to pay ?

    Jay
     
  20. Black Hole

    Black Hole Felinos Guru

    No, sorry. Those days are long in my past.

    I would have thought the HDD should spin as long as there is power on it?