Desktop Notifications

Black Hole

May contain traces of nut
Here's one for the people more knowledgeable about Internet matters than myself (that means most of you...):

I've been getting annoyed about a pop-up I get when I log in to my BT Yahoo web mail. It says something like "would you like to turn on desktop notifications", with "yes" or "not now" or X (to close the box). There doesn't seem to be "go away and stop pestering me" (reminds me of the retune nag).

I decided to try to do something about it, so I got hold of BT via web chat. The operative asked a few questions than asked to view my desktop (I have Teamviewer on my PC, but this was some Citrix thing that got downloaded). The operative was looking around my system for something that might be popping up nothing to do with them (that annoyed me), and couldn't find anything, then I explained again and they had a look at the settings button on the web mail page where there is an "enable desktop notifications" option that is not ticked.

They then told me it's because I'm using Chrome, that it's the same in Firefox, but there wouldn't be a pop-up if I used IE and it's Chrome's fault not theirs.

No one ever seems to have a "go away and stop pestering me" button.:mad:
If there are no useful popups on the website you could try and block all popups from your web mail.
If you do a google search on "chrome block popups" you should find some information.
google said:
Turn pop-ups on or off
On your computer, open Chrome.
At the top-right, click More .
Click Settings.
At the bottom, click Show advanced settings.
Under "Privacy," click Content settings.
Under "Pop-ups," select an option: Do not allow any site to show pop-ups (recommended) Allow all sites to show pop-ups.
There is an option to allow exceptions - so you might be able to block the offending web site causing popups.
If this is like anything else google, it probably won't work!
I use STMP on my mobile devices, and the web mail browser page on my PC. It still announces itself as BT Yahoo!, even though BT and Yahoo! got divorced.

In Chrome under Advanced Settings -> Privacy -> Content Settings -> Notifications ->Exceptions you should be able to configure a permanent block for that site..


Edit: I suppose it might not stop the site from asking you if you want to enable them on each visit, but it's worth a try.
Last edited:
Okay, well I'd like to see another one pop up so I can grab it, and I assume I will be able to find the offending process in the process list.

What is it? Is it, as the BT rep claimed, something BT is not responsible for? Has Google recognised this as an email access site and are trying to push their own desktop email client? If so, it seems rather draconian to me, and goes beyond what's reasonable.
Not sure about that. I feel certain that I have seen it on my computer recently and I'm not with BT (why on earth would I be?) I'll keep my eye out for it again.
The possibility that other web sites contain a trigger is not excluded!

Something has to trigger it, otherwise I would see the pop-up for any web page not just (in my case) BT Mail.
Here is something you can do in Windows 10.

Last edited by a moderator:
You can also disable icons in the bottom rhs system tray. You may find something more specific to disable. I never got this notification message ever when using Chrome or Firefox when I was with BT. Have you thought that it may be Yahoo that is the culprit? It is easy to find other free web mail providers.

Last edited by a moderator:
Right, so basically this is something that is triggered from the BT end by having something embedded in their web page?
If I'm right, yes. Look for 'Notification.requestPermission' in the page source or in one of the javascript modules. Easiest way is to open developer tools and search for that string in all files.