[disable-ota] Seems To Have Stopped Working

Black Hole

May contain traces of nut
I've been fiddling around with my boxes this morning, requiring reboots. They are on CF auto-update, and diasble-ota is installed (I've checked). The Auto Update entry is still in the schedule, despite the reboots.

This is on 1.02.32 and 1.03.12, so I doubt it is Humax firmware related (I first thought they might have sneaked something in with 1.03.12 to re-establish the OTA search immediately).

This may be what mihaid was talking about here: http://hummy.tv/forum/threads/auto-update-event-sneaked-through-disable-ota-protection.6060/

Update 2015/02/10: This now appears to be a difference (currently unexplained) between a cold boot (start-up from standby) and a forced reboot from WebIF/Telnet, and not the fault of disable-ota in particular.
 
Last edited:

Trev

The Dumb One
Just as a matter of interest, can you not disable OTA firmware update on the HDR T2 by disabling automatic update in its menus?
 
OP
Black Hole

Black Hole

May contain traces of nut
No. There is no SUI menu option for this, otherwise we wouldn't need the anti-OTA strategies that have been developed over the years.

I am not in danger of an OTA even with the schedule entry still present, because it is masked by the Disable OTA reminder entry.
 

Trev

The Dumb One
Didn't look far enough down the menu. Thought the 'Automatic Update' would have an On Off switch.:oops:
 

af123

Administrator
Staff member
I've been fiddling around with my boxes this morning, requiring reboots. They are on CF auto-update, and diasble-ota is installed (I've checked). The Auto Update entry is still in the schedule, despite the reboots.
Could you try running /mod/boot/xinit.d/xota from the command line? If you check the schedule on the web interface straight afterwards, the event should be gone (although it won't survive a proper restart as the Humax software will re-rewrite the database at shutdown. The other place to look at is the xinit.log file which should show what happened at boot.

Code:
humax# /mod/boot/xinit.d/xota
Opening /var/lib/humaxtv/rsv.db
XOTA: Removed auto-update scheduled events.
Found 1 existing OTA reminders.
Reminder already set.

If that doesn't work then can you look at the raw schedule? It deletes any events where the eRsvType column is 7. Maybe your new events have a different value there?
 
OP
Black Hole

Black Hole

May contain traces of nut
If that doesn't work then can you look at the raw schedule? It deletes any events where the eRsvType column is 7. Maybe your new events have a different value there?
I had a look anyway, and it's still type 7. Now trying another reboot for good measure...

Could you try running /mod/boot/xinit.d/xota from the command line? If you check the schedule on the web interface straight afterwards, the event should be gone (although it won't survive a proper restart as the Humax software will re-rewrite the database at shutdown.
Code:
HDRFOX4# /mod/boot/xinit.d/xota
Opening /var/lib/humaxtv/rsv.db
XOTA: Removed auto-update scheduled events.
Found 1 existing OTA reminders.
Reminder already set.
HDRFOX4#
Yes, it's gone from the live schedule.

The other place to look at is the xinit.log file which should show what happened at boot.
Code:
73    Reminder already set.
72    Found 1 existing OTA reminders.
71    XOTA: Removed auto-update scheduled events.
70    Opening /var/lib/humaxtv/rsv.db
69    XDSO: Removed DSO scheduled events.
68    Opening /var/lib/humaxtv/rsv.db
67    SQLite3: 3.7.5
Looks like it's working there...
 

af123

Administrator
Staff member
Perhaps it's just being particularly persistent in coming back at the moment, although that isn't consistent with any behaviour I've seen before. I never see the event in my schedule and I tend to look at it most days through RS if not the web interface.
 
OP
Black Hole

Black Hole

May contain traces of nut
Another reboot, and it's back:

OTA_problem.jpg

What's more, nothing has been added to xinit.log that time (still ends at line 73).
 
OP
Black Hole

Black Hole

May contain traces of nut
Perhaps it's just being particularly persistent in coming back at the moment, although that isn't consistent with any behaviour I've seen before. I never see the event in my schedule and I tend to look at it most days through RS if not the web interface.
Don't forget this is happening on two HDRs (the other one doesn't have disable-ota installed).
 

af123

Administrator
Staff member
Another reboot, and it's back:
What's more, nothing has been added to xinit.log that time (still ends at line 73).
The log is cleared on each reboot.. that probably explains that.
What do you mean by happening on the one that doesn't have disable-ota installed?
 
OP
Black Hole

Black Hole

May contain traces of nut
Not sure what you mean.

Two HDRs are running disable-ota, and the OTA event is still in the schedule despite reboots. The third does not have disable-ota installed, so I expect the OTA entry to be there, but it is masked by a daily reminder event that was set manually.

If I delete the OTA event on the disable-ota boxes, I will lose my test case. I can delete it on the non-disable-ota box and see what happens...
 
OP
Black Hole

Black Hole

May contain traces of nut
...it's still there! (1.02.20/3.02)

This can't be anything to do with Humax if the OTA entry is persistent even on firmware 1.02.20. Something must have happened in the CF to cause attempts to delete that type of entry to fail - but I am amazed that nobody is confirming this observation (apart from mihaid of course, but there are some confounding circumstances in his case).
 

Trev

The Dumb One
Tell me how to test it and I'll have a go on mine. I can't make head nor tail of what's happening/not happening from the previous posts.
 
OP
Black Hole

Black Hole

May contain traces of nut
Quite simple: presuming you have disable-ota installed, do you see an Auto Update entry in WebIF >> Schedule as per line 2 of the screen shot in post 8? If you do, is it still there after a reboot (disable-ota should remove it during boot-up)?

Mine isn't being removed at boot, on two HDR-FOXes (both running disable-ota, my third active HDR-FOX does not have disable-ota installed). Further, the non-disable-ota unit won't delete the Auto Update entry by marking it to delete in WebIF >> Schedule and then rebooting - it just comes back.

If you need more explanation, see Preventing External Events from Disturbing the CF (click)
 
Last edited:

Trev

The Dumb One
I do have DOTA installed
I just booted my box and the disable OTA event is in my schedule for tomorrow morning.
There is no Auto update entry.
Reboot from diagnostics
Wait a while
Disable OTA event still in the schedule
There is no Auto update entry.
Boot from box
Wait a while
Disable OTA event still in schedule.
There is no Auto update entry.
I really don't understand what's what or how it's supposed to work but that's what I got. Does this help?
 

Ezra Pound

Well-Known Member
BH is saying that if you have Disable-OTA installed that after a re-boot there should be no OTA (Auto) Event in the schedule
 
Last edited:
Top