[dlna-filter] Filter out DLNA traffic to prevent crashes.

I have an HD-T2 which I use to watch recordings via DLNA on an HDR-T2 in another room. The two devices are connected to the network via homeplugs and I've used this setup for some time now without any problems. I've recently changed my router to a D-Link VR900, which has an built-in DLNA server to share media connected to the router via USB. When the HD-T2 can "see" the DLNA server on the router, the HD box will crash every few minutes while watching a recording on the HDR box. At all other times it works normally. If I isolate the HD box from the DLNA server on the router (either by disabling the DLNA service on the router or by powering off the homeplug that connects to the router) then it works normally. The trouble is, my kids will then complain that they can't watch Netflix on the telly (which uses the same dual-port homeplug as the HDR-T2 and therefore can no longer reach the internet, or they can't play media stored on the USB storage attached to the router.

I was hoping that the dlna-filter package might solve my problem but it only installs on the HDR box, not the HD box. Would the dlna-filter package fix my problem if it could be installed on the HD box?
There isn't a customised kernel for the HD model. As far as I know, nobody has managed to build one.
Hi All

I have just got myself a NSA310 and was in the process of setting it up when I noticed my hummy crash. I remembered about the issue with Twonky so came here to see what to do.

I connected to the hummy through my browser and installed the dlna package. It took a while to install and didn't give me chance to look at any settings etc but I think it has now worked because it's no longer crashing but I can't access the webif from any browser on either my pc, phone or tablet so I can't get into the settings to set it to just filter traffic from the NAS. The connection is refused by the hummy on all of them.

I can connect using my ftp software so I know it's accessible on the network but I'm not sure how I can get in to change the dln filter settings, can anyone help please?

**** update ****

No sooner had I posted and it started working again, no idea quite why but I have now been able to change the dlna filter settings and can access my hummy again.
Last edited:
Actually, seem to be having the problem again, this time after I tried to update my packages. I got an internal server error and when I tried reloading a page it got the connection refused error again and I can't get back into the hummy again
Hi. I had this package installed when I was using the DLNA feature of my router. It worked and stopped the Humax from crashing. I eventually turned off the router DLNA server on my router and then forgot I'd installed dlna-filter. After not using the DLNA on the Humax for a while I needed to use it again but noticed VLC could no longer see it. I just went through a massive investigation to find out why this was. I eventually noticed that "gupnp-universal-cp" was giving a port timeout on the Humax (it's part of gupnp-tools Ubuntu package ). Then I remembered I'd installed dlna-filter, removed it and BINGO ! My DLNA is visible again !

Is this expected behaviour for dlna-filter ? I could swear it used to be visible with dlna-filter installed but can't be sure. Is this a bug ?
You might want to read the package notes for DLNA filter at ... It sounds to me as though "DLNA-Filter will block access to the Humax DLNA server if the Settings for DLNA-Filter package is left blank" is relevant in this case.

OK. Thanks. I was not aware of the setting. It must have originally been set to the IP of my router but then somehow got unset and just blocked port 50001 everywhere.
I recently had to install dlna-filter because turning on the the Windows 10 dlna server seemed to be causing crashes but without without specify an ip address list that also blocks the humax server.

Would it be possible to automatically let the humax server through or to have a simple setting to indicate block everything except humax server.
It's all iptables under the hood. The init script is driven by a config file that's a list of addresses (as defined for iptables -s ...) to be routed to DROP; if no file exists all port 50001 packets are dropped.

From the depths of my memory and man iptables, it seems that we could use the ! address syntax without changing the config file processing significantly, since this should cause every port 50001 packet not sourced by localhost to be dropped:
! localhost
The UI could have a check-box [ ] Allow local server such that checked causes ! localhost to be written at the end of the config and unchecked removes it (deleting the file if empty, or change the test in the init script from -f to -s -- probably a good idea anyway).

You could test this manually by adding that entry to /mod/etc/dlna-filter.
It's not clear to me what's being blocked from travelling where and in which direction.
"also block the humax server" - from what?
"let the humax server through" - through to where?
I'm confused by the use of "server" as well. Is "client" meant here? What are you actually trying to do?
It's not clear to me what's being blocked from travelling where and in which direction.
"also block the humax server" - from what?
"let the humax server through" - through to where?
I'm confused by the use of "server" as well. Is "client" meant here? What are you actually trying to do?
It is not clear to me either being a novice to all this!
What are you actually trying to do?
Prevent the humax from crashing but still allow the humax server to be visible on other devices,

By default on installing dlna-filer the humax server becomes invisible unless you specify the ip address of a least one other server in settings

It seemed to me that instead of needing to find server addresses it would be more user friendly to have a seting that effectively says don't filter out the humax.
I didn't check what validation (if any) was applied between the WebIf UI and the config file ...