DLNA to Smart TVs

Thanks for trying to help me but Im totally lost
I've tried cd .. cd My video etc etc but nothing
My Video files are on the normal drive path set up by the Modified firmware hd2/My Video/Auto Shrink
how do I get there from the Humax# prompt it says "-/bin/sh: cd cann't cd to my video"

I need a kind soul to type the line exactly as I need to type it after Humax #
including the "stripts -F and file name using BBC News at Ten.ts" as required
for me to follow.
As I get older It gets Harder and Harder
Thanks Alan
cd "/media/My Video/Auto Shrink"
cd /media/My\ Video/Auto\ Shrink

and similarly for the file name:
stripts -F "BBC News at Ten" "BBC News"
stripts -F BBC\ News\ at\ Ten BBC\ News

The file names usually have the date/time in them. It is much easier to use the Tab auto-complete than type it out.
Hello prpr
Thanks for your help I tried both but I seem to keep getting -/bin/sh: " then "whatever I've typed" not found to anything I type
bin is the first directory following / according to Filezilla so I seem to be stuck in /bin folder
I assumed as the drive is hd2 and tried cd "hd2:/media/My Video" but same result
I'm always so close to being able to view T2 from Bedroom but never quite getting there
Thanks Alan
If this is an HDR Fox T2, then just type what I put above. Forget any preconceptions about hd2 or whatever. You don't have 'drives' as such under Linux so your use of a colon in "hd2:/media" above is just wrong.
Thanks once again

I had missed a space where I've put stars in the stripts part -F****** "BBC News at Ten" "BBC News"

Its always a space missing that causes the problems in these things

So again thanks a million off to see if that's fixed the file so that it plays
Best regards Alan
Hi tech76
I think so, but is there a command so show the files in the folder, ? in DOS DIR does it, but I'm so unsure in telnet
I had followed what prpr said but missed a space corrected that and it worked Fine
I typed your suggestion afterwards just for learning, and it didn't produce an error message but as I have no way to see the files in telnet prompt, unless I try scripts again will not know have to record something else to try.
Hi dandnsmith Tech76 and prpr
Thanks thats given me the clue to unravel simple Telnet use
If I'm correct cd / moves you up a dir to see the folders and files in that dir use ls

Using this I moved up to see the following folders
bin etc lib mnt opt root share tmp var dev home media mod proc sbin sys usr
all the folders I see via FTP Fileziller and am familiar with.

so cd /media gives My Music My Photo My Video virtual
then cd /My Video and ls shows the folders and Video recordings the T2 has made

So now I can move around like in DOS. its very hard to get a list of commands from a google search though
only did a quick search did not find any of these commands like cd space / and the one from dandnsmith ls

So another big thank you to you Guys
This isn't DOS, it's Linux, so look up the Linux shell commands. As you have discovered, cd works but the slash has to be the other way. ls is short for list, "ls -l" (list long) provides more info.
As BH says, look up the linux shell commands:
cd / always moves to the 'root' of the file hierarchy
cd .. moves up a level
pwd lists the name of the current directory
I seem to recall that my first post was in the thread titled 'WebIF "Shrink" option'.
Apologies Black Hole, I don't know how to cross reference to other threads.
For reference, it is only a case of bringing up the topic in question then selecting and copying the link in the browser address bar and pasting it into the post. The forum software will patch it up with the appropriate tags when you post it. Prettying things up is a nicety, but not essential.

It should have been a matter of course for whoever did actually split the topic (Brian in this case), or any other surgery performed, to have added a post leaving an audit trail. This normally happens but got missed out this time, and when I was trying to track back I couldn't work it out.

Presumably you mean this one:


Just came over from AVF general thread as recently on this topic, and have read this thread (most of it - skimming the Linux bits :( )

Result, I thought - I have never got my Sony TV or BDP-S370 to play HDR recordings and I thought the Decrypt+Shrink should work. No luck though - They only see the HDR DLNA client not the Mediatomb one and only show SD as available even when HD is decrypted. The same HDR-T2 DLNA Server via my DS-DPS1000 lists SD and HD ????

Just Decrypt >> Black Screen / Wait timer
After Decrypt+Shrink >> BDP SD = File is Corrupt or Unsupported

The DS-DPS1000 plays both SD and HD but with or without Shrink they are pixelated and have audio stutters !
DHR-T2 files run through ProjectX portable (re-sync TS>TS) play just fine on the DPS1000.

I have just checked this thread - http://hummy.tv/forum/threads/transcode-hd-recordings.2608/#post-31476
and it seems the Shrink function has been changed back to not include the benefits of StripTS (or something like)

Making the DLNA fix part of the normal shrink process has caused problems for some people. Recordings don't fast forward, rewind or skip properly.
I've backed the change out for now until I have time to investigate.

I can't seem to find StripTS in the WebIF ? and have no idea how to use it any other way.

Would it be possible to add it as a function to the WebIF ? and/or add ProjectX ? Or ?????

Would be nice to have streaming to Sony TV/BDP/DPS1000 etc.


ps. Sorry if I have missed anything and this has been covered . . .
Stripts is in the Packages Advanced section, advanced Packages are only displayed in the Package Management screen if 'Turned On' in Advanced Mode, With :- SETTINGS >> Show development and advanced package
Thanks - Found StripTS in the list of installed stuff - Can we have it added to the Opt+ Menu ??

Is there a simple userguide for stuff that has to be used from a command-line thingy ?

Is it tel-net that has to be used ?

The shrink option in Web-If >> Browser >>{select file} >> OPT+ >> shrink runs the strips package. It can also be run from the command line (using Telnet) as follows :-
humax# stripts
Humax TS Stripper Tool v1.1.2, by af123, 2012.
Syntax: stripts [options] <input> [output]
    -a          Analyse an input file.
    -A          Quickly analyse an input file.
    -c          Check if there are any EIT packets.
    -C          Show address of first EIT packet.
    -D          Dump NTS file.
    -f          Also fix PAT packets.
    -F          Only fix PAT packets.
    -T          Dump TS file.
    -v          Verbose.
    -z          Analyse entire TS file.
    -d [level]  Set debug level.

Tried Decrypt + Then Shrink from the OPT+ but that doesn't run stripts any more (apparently problems for some)

I have managed to load telnet on my Win7 (Control Panel / Programs / Windows Features)
typed in Password 0000
typed cli
cd to Media / My Video
stripts -F name newname

and . . . the file that comes out now plays on the BDP-S370 (Yippee)
(no playback on a 40HX703 or a 40EX503 maybe newer SONY TVs work?)

Both Shrink and StripTS produce files that will play on the DS DPS1000 but they have bad pixellation (especially HD) and audio issues - the only solution for this seems to be a quick run ProjectX .

Maybe there could be a choice of Shrink to install as it seems the older version based on StripTS might work for the purpose of certain DLNA streaming needs.

Can I get the older Shrink version anywhere ? Instructions on how to install would probably be needed too !

Any chance of ProjectX being added to the package list and if poss. the WebIF ?