DTR-T1000 unable to access the internet

#1
Hi,

I really hope someone can help or at least point me in the right direction.

I have a Humax DTR-T1000/GB/500G/BT YouView product code 067002
Ver A7.76 on the loading screen.

I've had it for 3-4 years and never had a problem with it.

This year I moved from BT Residential to BT Business which was approximately the same time that the new update was rolled out that changed the user interface. Around this time the box reported that it was unable to access the internet so couldn't use any of the online players, download images for the tiles, etc.

I mainly use it for record terrestrial TV and anything I wanted to watch in iPlayer, I used my computer.

However, I thought it was about time I got this sorted as I want to use iPlayer, All4 etc and this is proving a nightmare to try to resolve.

I personally put it down to the update as it seemed coincidental that it stopped working after the update was sent out, however having had subsequent conversations with BT they tell me that it won't work on a BT business internet connection, only residential as it is only residential that BT TV is available on.

Then having had conversations with YouView they tell me that it should work on any internet connection and only BT TV services aren't available. So I go back to BT and because I have moved to BT business and BT TV is not available on BT business they won't provide me with support so I am stuck between a rock and a hard place.

Is it the internet connection or is it the box after the update?

The TV aspect was working so at least I could watch telly, just the players didn't.

YouView advised me to go through the various reset procedures:

1) Hold the power button for 10 seconds until it resets - no difference
2) Turn the box off, back and let it boot up - no difference
3) Maintenance reset, Factory reset, keep recordings - no difference

However, the big problem is that because it has reset the box wants to go through the setup procedure and a key part of the procedure is it accessing the internet, which it can't do, so now I am completely stuck, it can't access the internet, I can't proceed with setup, the box is all but useless now.

I have tried using a DrayTek router - (with necessary IGMP settings) can't access internet
I have tried using BT Business router - can't access internet
I have even tried connecting via Utility Warehouse internet to test with a different provider - can't access internet

I have spent an hour with YouView and about 1.5 hours on the phone with BT.
I have spent about six hours searching the internet and forums and I am still unable to find a solution.

The network connections are fine, tested with a CAT5 cable tester, the cable is fine.
I have tried different cables, the cables are fine.
I can see the Humax box on the network so I know it is connected and can be identified.

So why, why, why cannot the box not access the internet?

If anyone has any ideas, I would be very, very grateful.

Regards,

Rob
 

Trev

The Dumb One
#2
YouView advised me to go through the various reset procedures:
3) Maintenance reset, Factory reset, keep recordings - no difference
That was particularly stupid of them. As you have found, no internet, no setup.
Presumably all other internet connections are good?
 
OP
OP
R

rwassell

New Member
#4
Hi,

Thank you for your replies.

Yes, all other devices on the network are fine.

Internet connection is fine to both BT business and Utility Warehouse.

I have rebooted the router.

I also have a further update - finally I was able to speak to a knowledge person in BT Business Technical Support.

He advised me to do a full reset including deleting recordings, I felt I had little choice but proceeded anyway and guess what, it still can't access the internet.

I reset the router and still it didn't work.

He then looked into further and apparently found a reference on the YouView site that if you use BT Business you need to have a static IP and open some ports on the router.

I then phoned BT Business Sales to enquire about obtaining a static IP, I told them the reason and he told me that it won't work because 'BT branded YouView boxes are hard-coded to not work on the BT business network'.

Basically they have been modified so that they will not work. This is obviously not what I want to hear and also, that still doesn't explain why the box doesn't work on a Utility Warehouse network connection.

However, taking this even further, I have now spoken to a manager who is handling this issue as a complaint but she herself needs to speak to others at BT to find out what is the truth and why it might not be working.

I will update this post further when I have more information in the hope I can find a solution but if anyone else has any ideas in the meantime, I'd love to hear them.

Thanks

Rob
 

Mike0001

Well-Known Member
#6
You don't need to open ports on the router, that is just so that BT streaming can piggyback on your internet connection. My daughter has one of these boxes that works on Sky Broadband, and it doesn't have a fixed IP either. That is all call centre fluff!

BT needs to be closed down!
 
OP
OP
R

rwassell

New Member
#7
Thanks all for your feedback, I have an update.

A BT call centre manager has been looking into my complaint and spoken with the necessary technical teams and I now have an official answer.

A BT YouView box should work on any internet connection, including BT Business to be able to access publicly available services like iPlayer, All4, etc. However, only BT subscription TV, BT Sport etc are available on a BT Residential line and will not work on BT Business - this makes perfect sense and is acceptable.

BT Residential have this year been replacing aging BT YouView boxes and have rolled out a software update with the new tile based interface. This update is not designed to work with the original Humax DTR-T1000 boxes and this is why it is no longer working - their update broke the box.

It is a shame that they didn't send out the update only to newer boxes and excluded the older boxes as I much preferred the original interface and it would have kept working, but at least I now know that it was the update, as I suspected.

BT are going to replace it as they broke it, but still, this has taken a lot of time, pain and tears to try to get to the bottom of.

I would like to try to get the old box working and will look at that as a separate project to try to upgrade it with a previous firmware.

Regards,

Rob
 

gomezz

Well-Known Member
#8
Have a look at

https://support.youview.com/youview-box/software-updates/bt-software-update-27-50-0

This is the update that introduced the tile format and lists it as applicable to your box. So while the update process may have broken your box, the update itself did not. By comparison the last update stopped by BT Youview box from recording scheduled timers until I did a manual reboot which needed me to pull the power plug rather than the long press of the power button that usually works.
 
OP
OP
R

rwassell

New Member
#9
Thank you. I've see that.

I've tried everything. Literally everything.

The box is stuck in an endless loop - it needs to access the internet to continue setup - it can't access the internet.
 

JC.

New Member
#10
Have the same problem with same model box, standard BT broadband though, but the same problem for I guess the same reason, cant get passed "no internet connection" was looking for solution also, I've had no luck either, thought I might find some way to overwrite the BT software so it could be used as a standalone PVR.
 
OP
OP
R

rwassell

New Member
#11
Hi JC,

For your information I tried everyone I could hold of, from managers at BT to technical support bods and technicians to engineers at Youview themselves.

I am not one to give up easily but when you've spoken to, probably around 20 people and spent about 14+ hours on the phone, one has to accept when one is flogging a dead horse.

A real shame, but I bought a new box in the end. At least that works.

All the best.

Rob
 

JC.

New Member
#12
Cheers Rob,
I knew the BT people were a waste of time, more clueless working there who pretend they know what they are taking about, occasionally you get an occasional experienced engineer who does know what he's talking about, but they are now the exception rather than the rule.
Seems such a waste to scrap a workable box if only the software could be reset, sign of the times I suppose, so much for saving the planet!
All the best,
JC
 
Last edited:
#13
Hi Everyone,

I appear to have exactly the same problem as detailed in the original post.
I have a DTR-T1000 which has been fine for years and recently it had a problem where it could not connect to the internet.
I got this box from BT, but I left BT over 1 year ago... the box continued to work fine, albeit not the BT services.
I have been using the new YouView tile interface for some time and it had been working fine with the new tile interface until recently.

Recently the tiles would not load any preview images, etc. and it would say that it could not connect to the internet on various screens.
If I disconnected the Ethernet cable, it would show a pop-up broadband connection lost and plugging it back in again would say it is restored.
However, this did not make any difference to whether the tiles or screens could get information from the internet and the error persisted.

Wanted to try and fix this so I could get the Netflix app installed, as I had recently signed up to a free trial of Netflix.
Did various diagnostics, reset everything, changed Ethernet cables, tried different ports, etc.
The router, etc. was working fine so it was definitely a problem with the box.
I tried a factor reset (keep recordings), wish I had read this post earlier, and then ended up with a non-working box.
The box now enters the setup menu when starting up, but is unable to connect to the internet so cannot proceed with the setup.

I thought it could be a hardware fault with the Ethernet adapter, but saw this post which makes me think otherwise.
As I am no longer a BT customer I am not sure it is worth contacting them, but will contact YouView to see if they can confirm this issue.
How I have read the above and from the diagnostics I have undertaken, I now believe the following...

My DTR-T1000 with BT specific software has recently downloaded an update from YouView and can now longer connect to the internet because of a software issue.

It would be good to know if anyone else has had the same issue, whether anyone has had any updates since the previous posts, etc.

Thanks in advance!!

Paul
 

Luke

Well-Knwοn Мember
#14
It would be good to know if anyone else has had the same issue, whether anyone has had any updates since the previous posts, etc.
The last update for the BT DTR-T1000 units that were supplied as part of a BT subscription is dated April 2017.
Those have been some reports of DTR-T1000 outside of a subscription that have lost internet connectivity with that version
e.g.
https://community.youview.com/youview/discussion/7514020/no-internet-connectivity
As that particular thread went quite it was not clear that anything else happened, pr perhaps youviw provided a USB updatable version but requested the owner not to publicise it.

From the same period (as the Humax branded retail bought DTR-T1000 has since had an update made available *)
https://community.youview.com/youview/discussion/7546586/youview-couldnt-connect-to-your-router

* Although an update was made available for retail sourced DTR-T1000 I can't actually find a reference anywhere to anyone actually having the upgrades.

Although they might look similar to a HR-FOX T2 these units haven't got as good a reputation for hardware reliability
e.g. https://myhumax.org/forum/topic/dtr-t10x0-successful-repair
but presumably that is why you are asking about software in an attempt to identify the likely cause.
 
#15
Thanks Luke!! I have heard back from YouView, who also saw your reply, and they also mentioned that these boxes would not have been updated since the original tile based version. It may not be a software issue and I can’t rule out a hardware fault, but I am now wondering if the services to access tile images, the App Store, etc. have just been blocked by the service provider. I have asked YouView some further questions and will report back, but if you have any theories I would really like to hear them... does anyone know where these tile images are downloaded from and whether it is possible these could be being blocked now?
 
Top