Enable HDMI output?


New Member
Given that it appears Humax nuked the proper manuals from it's site, and I can only locate that youvew guide, can someone tell me how to enable the HDMI output on a DTR-T1000?

I've just hooked it up to a different TV using HDMI-->DVI-D and analogue audio, and only have output using SCART which I had to add afterwards to get a picture at all. Ubnder HDMI Resolution it says output is currently NO HDMI, but I can't seem to find this setting to change it.

All help appreciated.
Really? Seems a bit... well, crap.

I can't output HDMI after using SCART at all, short of a total reset, removing all recordings?

I'll leave it on the SCART as there re plenty of recordings SWMBO wants, and buy something decent this time then, screw Humax. BT, who I got the box from assured me I could do this. Should really have known better than to listen to them, and given all the other problems with them I have had, roll on July when I am out of contract.
It's not Humax's fault, YouView is in control. The very idea that a system reset deletes your recordings is stupid from the start.

Seriously, I can't believe that unplugging the SCART and plugging in HDMI doesn't give you output on HDMI automatically. I can understand that it might not do both at once. Have you tried turning it off and on again, with the HDMI connected?
I have indeed trird it. I am a tech for a living, so this *should* be simple enough. Multiple power cycles, cables and combinations of cables. I know the input on the TV, and the cable connecting the two are fine, as a PC shows up just great. No input on the DTR-T1000 other than SCART, hence my though it would be a setting I was missing.

I do accept that it is probably YouView causing the issues. I will be giving anything with the YV branding a very wide berth in the future, or springing for a Topfield box and switching to FTA Sat.

I did think that technology was, by and large, past intentional crippling at a whim. Oh well.

Thanks for the input.
There is no need to "enable" HDMI output. What may be happening is your (Sony per chance?) is not handshaking properly in which case try switching the input on the TV away from then back to the Youview box.

There is an HDMI Display Setting: 1080p or 1080i or 720p so make sure your TV can support the format you choose there.
HDMI doesn't work on my DTR-T1000 to my Sony TV. It worked until about this time last year, and then a firmware update broke the HDMI. This being YouView, there is no ability to downgrade back to a previous working release. The picture works over HDMI during early booting when there is no HDCP copy protection, but then at the point the picture shifts from early boot 720p to the real resolution it dies, usually. About 1 time in 50 I got a picture.

I used RGB scart for a while then got fed up with the limited picture quality. The DTR-T1000 is now boxed up in the loft gathering dust. I replaced it with a second Humax HDR Fox T2, a Grade A from Humax Direct.
Is there a way to disable HDCP?:mad:

HDPP, more like: High Definition Playing Protection!:(
No there isn't, because that's what is imposed on the equipment makers by the content providers to try to prevent unauthorised ripping of HiDef streams. Unfortunately the HD/HDR-FOX (and presumably other Humax kit) insists on HDCP regardless of whether the content being sent by HDMI is HiDef or StDef.
If only they could get it right. You would think that if it was so important to protect this content, they would at least devise a system that actually worked.

I wondered whether it was possible to fit a gadget into the HDMI stream that broadcast that "this device does not record?" Someone online claims that an HDMI hub does that, but the one I used to use certainly didn't.