• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

HDR-FOX Lock up - custom firmware problems afterwards

MontysEvilTwin

Well-Known Member
One of my machines locked up and I had to switch it off using the rear switch. After turning it back on, I could not access webif: it gave me a '500 - internal server error'. I ran fix disk which corrected a number of filesystem errors. A second fix disk run gave no errors, but still no webif. I reinstalled webif which worked but with some error messages:
Code:
Collected errors:                                                              
 * pkg_get_installed_files: Failed to open /mod/var/opkg/info/libreadline.list: No such file or directory.                                                      
 * pkg_get_installed_files: Failed to open /mod/var/opkg/info/jim-cgi.list: No such file or directory.                                                          
 * pkg_get_installed_files: Failed to open /mod/var/opkg/info/ncurses.list: No such file or directory.                                                          
 * file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico: No such file or directory.
Now it is like the custom firmware is only partly functional. Lighttpd is running as is network file sharing, but only some functions are available within webif. Not all functions work from Telnet either. I wonder if some files have been corrupted? I reinstalled the standard firmware and then the custom firmware. There was no webif bootstrap page and nothing has changed. Any ideas on how to fix this without having to remove all traces of custom firmware first?
 
OP
MontysEvilTwin

MontysEvilTwin

Well-Known Member
Regardless of the clean fixdisk run, this sounds like a drive on its way out.
You could be right. Generally the smart stats look OK but there is a non zero value in line 188 (command timeout) - 'The count of aborted operations due to HDD timeout' and I have not seen this in any of my other units.
To update, I copied the three missing files from another system to '/mod/var/opkg/info/' and this allowed me to reinstall packages from Telnet without error messages. However the installation still seemed pretty broken. In the end I ran 'reset' from the Telnet menu. This removed most packages and settings and reverted to the bootstrap page in webif. I had to reinstall and configure my addtional packages, but this was probably the quickest way to get back to a fully functioning system.
 
Top