1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP!: Can't get WebIF up or login via SSH

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Ravi, Jul 27, 2012.

  1. Ravi

    Ravi Member

    My HDR has been running fine since new last month, and been on .28 and CF2.11 with no probs.

    Yesterday, I installed a few new packages (the NFS stuff) and disabled the MediaTomb since I've yet to use it.

    I also put the box in standby overnight - normally I leave it on so that it decrypts everything, but not much got recorded this week.

    This morning I try to log in, via WebIF, it gets to the login prompt and logs in ok, but after that I get a blank screen, though the tab at the top says something about <div class=toolbars> <div id... etc. (If its important I'll do a screen grab, as I can't cut and paste the text)

    If I go to the scheduler direct (https://humax.local/sched/sched.jim) I get:
    Code:
    Error 500: Internal Server Error
    CGI program sent malformed HTTP headers: []
    I've also tried SSHing, but it refuses connection as does Telnet (although I have that disabled so not a surprise)

    I've don a full reboot, powered down and turned it off at the mains, rebooted my router, and tried connecting from a Windows PC and Ubuntu PC, and 3 different browsers with caches cleared etc.

    Still not having it.

    Anyone any ideas? Or is a full firmware reinstall required?

    Is it possible that the new packages cause an issue - they seemed to install fine, and the box was rebooted several times yesterday with no problems.

    thanks in advance!
     
  2. Ravi

    Ravi Member

    Also getting .jim error when launching the portal. Looks like something is corrupt?
     
  3. af123

    af123 Administrator Staff Member

    What's the error message? It might provide a clue.
     
  4. Ravi

    Ravi Member

    This is what the Hummy shows on the TV screen when selecting the Custom Portal (TV Portal Button)

    Code:
    An error occurred whilst launching the application http://localhost/portal/index.jim
     
  5. Black Hole

    Black Hole Felonius Gru

    That sounds like a system clock problem! That's exactly the message we get when trying to connect the standard portal when the clock is wrong.
     
  6. af123

    af123 Administrator Staff Member

    I can't work out what has happened to your installation. Too many things seem to have gone wrong at once!

    I think your best bet is to reset the custom firmware via a USB flash disk as you don't have any other access to the box.

    Put the reset package from http://hummypkg.org.uk/hdrfoxt2/reset_1.0.1_mipsel.opk into the root directory of a USB disk (or USB flash drive) then plug it into the Humax while it is on. Wait for the light to stop flashing then remove the disk and reboot the Humax (using the remote control) - it will clear out all of the custom firmware packages and files without affecting your recordings or scheduled recordings. If you point a web browser at the Humax then you'll be back at the initial installation interface.

    If you want to be selective then you could use the package at http://hummypkg.org.uk/hdrfoxt2/enable-telnet_1.0.0_mipsel.opk which will just re-enable the telnet service for you. Same mechanism, put it in the root of the USB drive then plug it in.
     
  7. Ezra Pound

    Ezra Pound Well-Known Member

    Have started a seperate Wiki table for the USB only Utilities HERE, which includes the two above
     
  8. Ravi

    Ravi Member

    Thank you guys - I can now telnet into the box.

    I'm kind of tempted to do a full Factory Firmware reset, but before that I'd like to get any recordings off the box, and more importantly pull any log files out that might be of help.

    Please let me know what files would be of use to you guys?
     
  9. Ravi

    Ravi Member

    WebIF up, but got these errors on full WebIF install:

    Code:
    Collected errors:
    * pkg_write_filelist: Failed to open /mod/var/opkg/info/jim.list: Input/output error.
    * opkg_install_pkg: Failed to extract data files for jim. Package debris may remain!
    * opkg_install_cmd: Cannot install package webif.
     
    Error installing packages. Please try again.
    
     
  10. Ravi

    Ravi Member

    Whats the built in equivalent of show / more?

    Or have you got a USB installable BusyBox?
     
  11. Black Hole

    Black Hole Felonius Gru

    Everything is installable by USB - details are on the Wiki.
     
  12. Ezra Pound

    Ezra Pound Well-Known Member

    Not sure about show, but there is 'ls = show list of files' and 'cat = display (show) the contents of a file' in busybox together with 'more' in Wiki packages
     
  13. Ravi

    Ravi Member

    Thanks - I've got Busybox on there now.

    Had a look at the log files:
    Code:
    humax# pwd
    /var/log
    humax#
    humax# ls
    banner.log  hosts        ifstate      rag.log
    dnsmasq.pid  if-up        modinit.log  xinit.log
    humax#
    but didn't spot anything interesting. Are there any other log files (I'm sure it's all documented on Wiki)?
     
  14. Ezra Pound

    Ezra Pound Well-Known Member

    There are more log files in /mod/tmp
     
  15. Ravi

    Ravi Member

    Nothing in there, possibly got cleared when I did the WebIF reset?
     
  16. xyz321

    xyz321 Well-Known Member

    I think "Input/output error" is a major clue. It usually means a corrupt filesystem or disk failure.
     
  17. Ravi

    Ravi Member

    Something is not right.

    I can not get rid of the CF, even done factory reset and tried to install the original factory firmware, but it looks like nothing is getting picked up when the box boots up with a USB stick in it.

    The WebIF is not working at all - I just get a page saying:

    Code:
    Index of /
     
    Name    Modified    Size
    Parent directory    -      -
    img/    29-Jul-2012 10:44      [DIRECTORY]

    Which I can drill down into the img folder.

    Only access I have is via telnet.
     
  18. Ezra Pound

    Ezra Pound Well-Known Member

    If you want to remove the Web-If using Telnet you can enter :-
    Code:
    diag remove_mod_yes_i_am_sure
    NOTE:- The above will require the Humax to have internet access
     
  19. Ravi

    Ravi Member

    Ok I tried that, but it looks like there was a problem

    Code:
    humax#
    humax# diag remove_mod_yes_i_am_sure
    Running: remove_mod_yes_i_am_sure
    killall: mongoose: no process killed
    killall: bootstrapd: no process killed
    === diag =================================================
    Filesystem                Size      Used Available Use% Mounted on
    /dev/root                16.4M    16.4M        0 100% /
    tmpfs                    61.0M    24.0K    61.0M  0% /tmp
    tmpfs                    61.0M        0    61.0M  0% /media
    /dev/mtdblock1            2.0M    520.0K      1.5M  25% /var/lib/humaxtv
    /dev/mtdblock2            2.0M      1.3M    736.0K  64% /var/lib/humaxtv_backup
    /dev/sda1                7.5G    412.6M      7.0G  5% /media/drive1
    /dev/sdb1              1011.4M    36.8M    923.3M  4% /mnt/hd1
    /dev/sdb2              906.1G    624.7G    235.3G  73% /mnt/hd2
    /dev/sdb3                9.8G    373.4M      9.0G  4% /mnt/hd3
     
    eth0      Link encap:Ethernet  HWaddr DC:D3:21:66:19:2F
              inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:707 errors:0 dropped:0 overruns:0 frame:0
              TX packets:622 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:321103 (313.5 KiB)  TX bytes:67826 (66.2 KiB)
              Interrupt:16
     
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
     
     
      PID USER      VSZ STAT COMMAND
        1 root      1248 S    init
        2 root        0 SW  [migration/0]
        3 root        0 SWN  [ksoftirqd/0]
        4 root        0 SW  [migration/1]
        5 root        0 SWN  [ksoftirqd/1]
        6 root        0 SW<  [events/0]
        7 root        0 SW<  [events/1]
        8 root        0 SW<  [khelper]
        9 root        0 SW<  [kthread]
      10 root        0 SW<  [kblockd/0]
      11 root        0 SW<  [kblockd/1]
      12 root        0 SW<  [khubd]
      13 root        0 SW<  [kseriod]
      14 root        0 SW  [pdflush]
      15 root        0 SW  [pdflush]
      16 root        0 SW<  [kswapd0]
      17 root        0 SW<  [aio/0]
      18 root        0 SW<  [aio/1]
      19 root        0 SW<  [ata/0]
      20 root        0 SW<  [ata/1]
      21 root        0 SW<  [ata_aux]
      22 root        0 SW<  [scsi_eh_0]
      23 root        0 SW<  [scsi_eh_1]
      24 root        0 SW  [mtdblockd]
      25 root        0 SW<  [scsi_eh_2]
      26 root        0 SW<  [usb-storage]
      28 root        0 SW<  [kpsmoused]
      30 root      1244 S    {rcS} /bin/sh /etc/init.d/rcS
      76 root        0 SWN  [jffs2_gcd_mtd1]
      77 root        0 SWN  [jffs2_gcd_mtd2]
      131 nobody    932 S    /usr/bin/dnsmasq
      136 root      816 S    /sbin/utelnetd -l /bin/sh -p 23 -d
      149 root      1244 S    {S90settop} /bin/sh /etc/init.d/S90settop start
      159 root      371m S    /usr/bin/humaxtv
      368 root        0 SW<  [kjournald]
      432 root        0 SW<  [kjournald]
      434 root        0 SW<  [kjournald]
      649 root      840 S    tinyftp -i HumaxFTP -p 0000 -c /media
      653 root      1248 S    -/bin/sh
      660 root      1240 S    {diag} /bin/sh /bin/diag remove_mod_yes_i_am_sure
      664 root      1244 S    /bin/sh
      674 root      1252 S    {modinit} /bin/sh /sbin/modinit
      681 root      1336 R    ps -w
     
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.1.0    *              255.255.255.0  U    0      0        0 eth0
    default        192.168.1.1    0.0.0.0        UG    0      0        0 eth0
     
    === reset_all ============================================
    Found reset trigger file at /var/lib/humaxtv/mod/_RESET_CUSTOM_FIRMWARE_ENVIRONMENT
    Resetting custom firmware environment.
    rm: can't stat '/mod/bin/inotifywait': Input/output error
    rm: can't remove '/mod/bin': Directory not empty
    rm: can't stat '/mod/lib': Input/output error
    rm: can't remove '/mod/var/opkg/info/jim-sqlite3.list': Operation not permitted
    rm: can't remove '/mod/var/opkg/info/jim-sqlite3.control': Operation not permitted
    rm: can't remove '/mod/var/opkg/info/jim-oo.list': Operation not permitted
    rm: can't stat '/mod/var/opkg/info/jim.list': Input/output error
    rm: can't remove '/mod/var/opkg/info/inotify-tools.list': Operation not permitted
    rm: can't remove '/mod/var/opkg/info/jim-oo.control': Operation not permitted
    rm: can't remove '/mod/var/opkg/info': Directory not empty
    rm: can't remove '/mod/var/opkg': Directory not empty
    rm: can't remove '/mod/var': Directory not empty
    === upgrade_bootmod ======================================
    === setup_directories ====================================
    === create_rcS ===========================================
    === migrate_bootmod ======================================
    === setup_hostname =======================================
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
    192.168.1.0    *              255.255.255.0  U    0      0        0 eth0
    default        192.168.1.1    0.0.0.0        UG    0      0        0 eth0
        Interface: [eth0]
        IP: [192.168.1.6]
    === run_init =============================================
    === complete =============================================
    humax#
    I power down the box (to the HDD click) and put a USB flash drive in with the factory FW on it. The Hummy just boots up as normal and goes to the last TV channel. No attempt to install the Firmware. I ran the internal HDD check from the Humax Menu and it didn't report any errors.

    I'm wondering if some files have got locked some how?
     
  20. Ezra Pound

    Ezra Pound Well-Known Member

    It looks to me like the Humax is just not seeing the USB device, this is fairly common there are some guide lines for getting the USB to be seen e.g. :-

    Some USB Flash / Disk Drives* are reported not to work. The reason for this is not fully understood; however the following tips are known to help :-
    • Remove any other USB devices and power cycle twice (waiting for HDD spin down each time)
    • Do not use a USB extender cable
    • Removing all other files / re-formatting can prevent file fragmentation
    • Try both USB ports (HDR)
    • As a last resort, try a different USB Flash Drive