Help with setting up my Harmony 650 Remote

#1
I am currently waiting on Logitech to get back to me but I suddenly thought that someone here is probably better placed to answer my question.

I got a Harmony 650 last week and have spent some time trying to set it up and understand it. My major outstanding issue is that I cannot get it to turn on my Humax hdr Fox-T2. I have had to change my HDR activity to only turn on my TV and HDMI switch. I can then turn on my Humax box with its own remote and everything works fine. Kind of defeats the object of having one remote. CVan anyone tell me what I need to do. Thanks.
 

Black Hole

May contain traces of nut
#2
You could try sending a "0" - that acts like a power on code (there's no equivalent power off code that I know of).

I've not had any problem with the power toggle code on my Harmony (300), and several forum users have various Harmony models without having reported anything like this.
 

Trev

The Dumb One
#3
Not very helpful. but my H 650 works with my T2 just fine. I haven't set up an activity to do it though.
Presumably other than the ON OFF the other buttons work with the T2 OK?
 
OP
OP
J

jimbo116

New Member
#4
Not very helpful. but my H 650 works with my T2 just fine. I haven't set up an activity to do it though.
Presumably other than the ON OFF the other buttons work with the T2 OK?
Thanks for that. I don't know what I am doing wrong. How do you have it set up?
 

Trev

The Dumb One
#5
Just as per the 'manual'. Does the ON/Off toggle button work on its own?
And I'll ask for the second time: Do the rest of the buttons work OK on the T2?:confused:
 
OP
OP
J

jimbo116

New Member
#6
You could try sending a "0" - that acts like a power on code (there's no equivalent power off code that I know of).

I've not had any problem with the power toggle code on my Harmony (300), and several forum users have various Harmony models without having reported anything like this.
I tried pressing 0 but nothing happens. When I simply switch to devices on Harmony 650, select, Humax DVR, and press Power Toggle, Nothing happens.
 
OP
OP
J

jimbo116

New Member
#7
Just as per the 'manual'. Does the ON/Off toggle button work on its own?
And I'll ask for the second time: Do the rest of the buttons work OK on the T2?:confused:
No it doesn't. As I can't get the DVR to switch on using my remote, how can I test the other buttons?
 
#8
My Harmony 950 works fine with the T2 (using a power command, not '0', as part of my 'Watch TV' activity). I have the power on of the Humax set as the first command to be transmitted by the remote when starting the Activity.
 
OP
OP
J

jimbo116

New Member
#10
I switched it on using the Humax remote but nothing else works with the Harmony. It looks as if it just doesn't see the Humax. Perhaps Logitech will come back with an answer eventually.
 

Trev

The Dumb One
#13
No it doesn't. As I can't get the DVR to switch on using my remote, how can I test the other buttons?
By either taking up Black Holes idea or by switching it on using the Humax remote and then pressing the buttons on the Harmony. :frantic:
Are you using the correct set of remote codes on your Harmony?
That's where I was going by asking if any of the buttons worked as he only said the power button didn't work.
I think that the Harmony database has at least two of the codes for the T2 when I set up mine a year/18months ago, but I can't remember exactly.
 
OP
OP
J

jimbo116

New Member
#14
By either taking up Black Holes idea or by switching it on using the Humax remote and then pressing the buttons on the Harmony. :frantic:
That's where I was going by asking if any of the buttons worked as he only said the power button didn't work.
I think that the Harmony database has at least two of the codes for the T2 when I set up mine a year/18months ago, but I can't remember exactly.
I appreciate the effort you guys are putting in trying to help me but I am new to this and most of what is being said is going over my head. Is there something simple I can try?
 

Black Hole

May contain traces of nut
#15
So that multiple units can coexist in the same room, each HDR-FOX/handset pair can be programmed to one of four command code sets. In order to respond, the handset needs to transmit the same code set as the HDR-FOX has been programmed to - and that includes the codes programmed into your Harmony.

Use the instructions in your HDR-FOX manual (or via the link in post 12) to ensure your HDR-FOX is programmed to code set 1, and ensure you have programmed your Harmony with the code 1 set from MyHarmony.
 
OP
OP
J

jimbo116

New Member
#16
So that multiple units can coexist in the same room, each HDR-FOX/handset pair can be programmed to one of four command code sets. In order to respond, the handset needs to transmit the same code set as the HDR-FOX has been programmed to - and that includes the codes programmed into your Harmony.

Use the instructions in your HDR-FOX manual (or via the link in post 12) to ensure your HDR-FOX is programmed to code set 1, and ensure you have programmed your Harmony with the code 1 set from MyHarmony.
Thanks so much. I checked and the HDR was set to code 2. I have changed it now and the HDR is powering up ok. I now have different issues as the input on my Portta Switch is changing every time I hit a button on the remote and the signal from the Humax to the TV is lost. I will keep trying to find a fix for that but at least I can switch on the Humax. Need to find now how to control it and use the Opt+ etc.
11.57 I have had another go at setting up the activity although I must admit that I am a bit confused about the various inputs and the question about whether or not the Hummy ignores unused inputs etc. I have set it to use TV Input although I would have thought that should be Ant. Current position is that, Thanks to Black Hole, I now get the Hummy turned on correctly when I use the activity. I then don't know how to get around and use the Opt+, Media, or Guide buttons. If I press the channel down on the harmony the channel changes ok but if I press the channel up my Portta Switch changes to input 1 and I lose the connection. If I then use Help it recovers that for me. Any further help would be appreciated as I am obviously doing something wrong.
 

gomezz

Well-Known Member
#17
You can go in and check what functions are assigned to each key press and change them if they are wrong. There is no obvious button to match Opt+ so I suggest you set up a soft button for that which will appear on the screen. For my Humax Foxsat HDR I have set up soft buttons for ON/OFF; OPT+; Text; Slow Mo; Search; Bookmark; Audio and Sleep. The UP/DOWN keys directly under the screen I have set up to change my HDMI switch to Next/Previous input which is useful for when it gets confused changing activities (ie misses a signal).
 
OP
OP
J

jimbo116

New Member
#18
How do I check the functions for each key press in a given activity? I have made some further progress in that I can now get the guide and media buttons working. I have set up a soft button for options and that allows me to say that I want to delete something. When it then asks do you want to delete this, yes or no, I press the left arrow to go to yes and the screen goes blank causing me to use the help to get back up. Any ideas on that. Apart from that my only remaining funny is that the Portta switch does go off when I Press the 'All Off' button but then it comes back on again and I need to use Help to get it off. Very strange.
 
OP
OP
J

jimbo116

New Member
#19
This is an update on where I am now:

I think that I have made some progress on this as currently:
i. My Watch TV is working as I think it should.
ii. Watch a Movie is fine.
iii. Following some advice from 'Black Hole' I found that my Humax box was actually set to IR 2. I have changed that back to IR 1 and it is now powering on from the remote. It now looks to me that the issues concern the connection between the Harmony 650 and my Portta HDMI switch as follows:

When I press the Humax Box it does switch on the TV and the Humax DVR but the Portta switch quickly flashes and then goes off. When I press the Help button it then comes on. When I press the All off button then everything goes off except the Portta switch and again I need to use Help to do that. There is no problem with the switch going off when I use the Watch a Movie which also uses it.

I have also found that pressing the button to the left of the ok button moves the Portta input each time it is pressed and pressing the up button beside 'Menu' moves it the other way each time I press it. This obviously stops what I am watching on the DVR and again I need to use Help to fix it.

Have I done something wrong in setting this up?
 
Top