1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Missing audio on HD recordings

Discussion in 'HDR-FOX T2 Freeview Recorder' started by cheesemaster, Jun 8, 2012.

  1. cheesemaster

    cheesemaster New Member

    Hi Guys,

    I have a problem with HD recordings - all 4 HD channels record the video stream fine, but there is no audio! I've tried a full re-scan, and a re-install of the firmware, but this is still happening.

    All the SD channels record absolutely fine.

    Anyone seen this issue before?
     
  2. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Have you tried changing the audio output settings?
     
  3. cheesemaster

    cheesemaster New Member

    Yeah - doesn't make a difference...

    I am running old firmware, though (pre "background delete") as I have the permanently deleting issue that quite a few people seem to have seen... I'm trying to run down the amount of stuff I have recorded before I resort to formatting the disk (Mrs Cheesemaster would kill me if I screwed up the back-up of recorded files and lost all the stuff she watches!)

    The only options I had were

    -audio description: on/off
    -digital audio out: multichannel/stereo
    -lip sync

    Are there more settings in the latest firmware?
     
  4. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    You ought to be able to safely go back to a later firmware having fixed the problem. I don't think it is very common so you would be unlucky to experience it again and you know how to fix it. I don't think formatting the disk will make any difference to this problem.
     
  5. cheesemaster

    cheesemaster New Member

    I agree formatting the disk won't solve this - I was just wondering if the newer firmware had more/different audio options.

    I'm guessing this is going to be a specific hardware issue with the receiver in my box - it seems to have started about 2 weeks ago based on my recordings, and I can't believe no-one else would have been shouting about it on the forum if this was a common issue... Maybe time to dig out my receipt!
     
  6. TeeJay

    TeeJay New Member

    Hi, Ive had my box for over two years now, and by and large, it's been brilliant.
    However, some time ago, when running the latest firmware (1.02.20), we found that some recordings, during playback (mainly ITV1-HD and CH4-HD) would either pixelate and "jump" about 30 seconds, OR, occasionally the screen would go blank (although the front display would continue to scroll) and stay that way before continuing where it left off (???)

    The only way I've found to avoid this was to re-install version 1.01.09 - which seemed to resolve these "issues" - although it removed the TV Portal and background delete functionality.

    All went well until 1st June 2012.

    Any HD recording made after midnight of 31st May, failed to play back any sound!

    Except, by re-instating 1.02.20, the sound returned to these recordings!!

    Version 1.01.09 - NO SOUND on HD recordings (although live viewing of HD channels was fine)

    Play back those same "silent" HD recordings using version 1.02.20 - the sound is fine.

    Any ideas anyone?

    Thanks.
     
  7. Black Hole

    Black Hole Felonius Gru

    Anybody know if there's been a change in the audio stream encoding?
     
  8. cheesemaster

    cheesemaster New Member

    Interesting TeeJay. That sounds like the same time-frame for my sudden drop-out on audio, and I'm also using 1.01.09 as I have the background delete issue which means I can't make any new recordings with the later firmware.

    Looks like I need to back up all my recordings and format my disk so I can install 1.02.20.
     
  9. af123

    af123 Administrator Staff Member

    Backing up is a sensible precaution, but why reformat the disk? I've never heard of an upgrade removing recordings.
    (If you don't have another disk for the upgrade, then buy a small USB Flash drive from Tesco or somewhere for a couple of quid)
     
  10. cheesemaster

    cheesemaster New Member

    Coz the reason I'm not running 1.02.20 is that I had a recording that got corrupted - and using that firmware version the disk displays "deleting" permanently, and I can't record anything new to it as the disk is being permanently accessed (I'm not the only one with this issue, from the looks of things)... 1.01.09 dosen't allow background delete, so it behaves normally in that respect, apart from losing the audio on the HD channels! :(

    I think I need to format the disk to get over that hurdle, but I've got a heap of stuff recorded that I've not got as far as watching yet.
     
  11. Brian

    Brian Administrator Staff Member

    Is your box the 1TB version by any chance, as the deleting issue seems to mainly affect that version.
     
  12. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Why do you think that? Several other people have just reinstalled a later version. The permanently deleting problem is not a file system problem but a background process that doesn't terminate properly.
     
  13. cheesemaster

    cheesemaster New Member

    No - it'd the 500Mb one. As things stood I was just getting by with the old firmware, and making sure I didn't try to delete the file (even with 1.01.09 that would lock me out of any new disk access), but if what TeeJay says is true then I will need to put the newer FW on in order to get audio back on my HD recording.

    It's a bit odd that the different FW would behave differently with the audio stream on the HD mux, isn't it?
     
  14. af123

    af123 Administrator Staff Member

    ...which restarts straight away on reboot if a certain file exists on the disk..
    Custom firmware should allow you to get past this though.
     
  15. TeeJay

    TeeJay New Member

    My problems originally started with the background deletion issue when running v1.02.20 (icon permanently showing in top right of screen and locking out any other disk access). Initially I powered off and re-installed version 1.o1.09 then immediately reinstated v1.02.20 and this cleared the problem and all seemed ok. I had this happen about three times before it finally seemed to "fix" itself.

    Shortly after this, I noticed that some recordings (only a few) would pixelate and occasionally jump forward about 30 seconds (mainly ITV1-HD and CH4-HD - I think!). Other times, the screen would go black - which I believe is a common issue - for up to 90 seconds, during which time the front panel would continue to scroll the program info but it wouldn't respond to any remote commands, before returning to playback mode precisely where it left off!?!

    I had a theory at one time that this "black screen" phenomena possibly coincided with the start of another recording, not necessarily at the time of playback, but maybe it occurred at the point of another recording starting while IT was being recorded - but I could never actually prove that. Strangely, if I rewound to a point before the black screen, it would invariably play back without a pause perfectly OK!!!! (so annoying!)

    I eventually decided to "permanently" return to FW v1.01.09 - which has been running fine (with its inherent limitations) ever since - until someone - somewhere, decided to mess with the sound on the HD channels. I can't understand how the 1.01.09 can actually record sound on HD, but fail to play it back???

    BTW, the box is the 1Tb version.

    At no time have I reformatted the hard drive. Not really convinced this would help.

    Thanks for your thoughts guys - keep the ideas coming!

    TJ
     
  16. Black Hole

    Black Hole Felonius Gru

    I can at least offer a hypothesis for that: it would appear that the sound encoding in the broadcast stream has changed as of 1st June. The data recorded to disk is exactly what is received (via an encryption). Only when you play it back does it have to be decoded, and 1.01.09 appears not to be able to configure the hardware appropriately to do that.

    What interests me is whether the sound is OK live (don't expect it to be), and whether it is the same on all HiDef channels (different provider, different encoding)?
     
  17. TeeJay

    TeeJay New Member

    Thanks BH, yes, that does seem perfectly plausible.

    When viewing a "live" HD channel (via v1.01.09) the sound is absolutely fine!! (although rewinding a live stream the audio is silent - as I would expect)
     
  18. Black Hole

    Black Hole Felonius Gru

    That's odd, it seems to be a point against my hypothesis.
     
  19. cheesemaster

    cheesemaster New Member

    One thing that does make a bit of sense is the timings of this - I read on another forum that there was a change to the HD mux on 1st of June to allow for extra HD streams over the olympics - that ties in with TeeJay and me having the problems starting at that point.

    I also have audio on all the HD channels live, but none of them on recordings.

    There's probably a thread on this somewhere else, but I did notice an over-the-air software update a few weeks back at which point I had to re-install 1.01.09 as it got the background delete stuff going crazy again. If it truly is related to an encryption vs firmware issue, I guess most people wouldn't have noticed it as their box may well be running different firmware under the hood without them even noticing.
     
  20. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Over on DigitalSpy a couple of people have reported this problem and both reported it solved by installing a later firmware. So if you want sound from the recordings it does appear you will have to go to a later firmware. To get rid of the deleting problem you either need to format (I was wrong previously) or to install the custom firmware. I would suggest installing the custom firmware is the easier option and you could remove it again after fixing the problem.