Networking problems with WiFi

dandnsmith

Forum Supporter
Having, repeatedly, found that the link wasn't being made using wireless, I attempted to engineer a link which gave an ethernet cable connection to an Access Point, and thence over wireless to my wireless router. I failed to get the configuration to work, so switched back to the wireless dongle. This precipitated another period of frustration as the device wasn't being recognised (so was unconfigurable) until I had switched off completely (at the rear of the unit) several times.
It is now working again, but I dread further trouble, as the WPA2 passphrase is long enough that the unit can time out when I'm almost at the end of input.
Is there any help to be had:
- showing the passphrase in clear, so one can see if it has been lost/corrupted?
- a way of forcing the dongle to be recognised?
- any messages which will showing whether a connection isn't being made because of timeout or mismatched passphrase etc?
 

af123

Administrator
Staff member
Is there any help to be had:
- showing the passphrase in clear, so one can see if it has been lost/corrupted?

Run the /sbin/swifi command from the command line:

Code:
humax# /sbin/swifi
ssid=MYSSID
key=mywirelesskey
manual=0
auth=8
ip=172.29.0.22
mask=255.255.255.0
gw=172.29.0.254
dns=172.29.0.254

- a way of forcing the dongle to be recognised?

Try running /sbin/wifi-up. Of course that assumes you have access via Ethernet.
 
OP
dandnsmith

dandnsmith

Forum Supporter
Many thanks for the informations and suggestions - I'll check them out.

However:
Try running /sbin/wifi-up. Of course that assumes you have access via Ethernet.
seems a bit odd to me, as, if I had an ethernet connection, it would be pointless to try to get a dongle working (wouldn't it?)
 

4291

Well-Known Member
You will need a temporary ethernet connection to access your box via Telnet.
 

af123

Administrator
Staff member
/mod/sbin/swifi is a utility I added in CFW 2.15 which reads the wireless settings from the database and prints them out. It's a good double check for things like the WPA key and doesn't need a dongle connected.

if I had an ethernet connection, it would be pointless to try to get a dongle working (wouldn't it?)

You can have both connections working at the same time. It's only really useful for diagnostics though. Connect over Ethernet and then connect the dongle and see if wifi-up can bring the wireless up. If it doesn't work it may at least point to the problem.
 

prpr

Well-Known Member
/mod/sbin/swifi is a utility I added in CFW 2.15 which reads the wireless settings from the database and prints them out. It's a good double check for things like the WPA key and doesn't need a dongle connected.
Never had wireless on this machine but the utility crashes...
Code:
humax# swifi
Segmentation fault
humax#
 
OP
dandnsmith

dandnsmith

Forum Supporter
You can have both connections working at the same time. It's only really useful for diagnostics though. Connect over Ethernet and then connect the dongle and see if wifi-up can bring the wireless up. If it doesn't work it may at least point to the problem.
That helps - I suppose I could have them both if I could have different IP addresses and sort out the routing, but I'm puzzled as to why the hosts file is in /tmp, and gets rewritten at each boot.

I ran swifi after that previous post - no problem with it, certainly no seg fault

Has anyone tried ethernet wireless repeaters - my Edimax 7728AP has this capability, but I cannot seem to get it to cooperate (or in Bridge mode, but the wording in the manual makes me think I have a mis-perception of how to do it)
 

af123

Administrator
Staff member
I'm puzzled as to why the hosts file is in /tmp, and gets rewritten at each boot.

Some services like Samba rely on the hosts file so it gets updated on boot once an IP address is allocated (to support DHCP). It's in /tmp and linked to from /etc because /etc is read-only.

If you have any custom entries you want in the hosts file, put them in /mod/etc/hosts and they'll be automatically added to the end of the generated /etc/hosts -> /tmp/hosts file.
 

jdtaylor

New Member
Hi, I had trouble getting wifi going myself, but what I found is under ip configuration choosing manual and setting a fixed IP address works and then under gateway giving the wifi router address and for Dns the broadband router got the connection working but this was using a visible wifi network and a wpa2 password.

I hope this helps.
 

dragon-it

Member
I gave up on wireless for any thing other than phone/tablet ages ago though didn't try with the humax, I didn't have the option to lay Cat-5 everywhere have tried a few different "home-plug" systems and this one is working very well at the moment:

http://www.scan.co.uk/products/zyxel-pla-4201-500mbps-mini-powerline-adaptor-twin-pack

Have HD-FOX-T2, HDR-FOX-T2 connected via this on different ring mains and playing HD between them fine etc.

Also then one of these behind the TV stuff,

http://www.zyxel.com/uk/en/products_services/pla4231.shtml?t=p

So two wired ethernet ports for Humax etc., wireless access point both sent back over power lines to router.

You can get multi-port ones too, and routers with power-line built in, or just connect with an existing switch / router.
 
I'll add my two-pence worth. If your WiFi password is so long and complicated that it is a pain to re-enter, make it simpler and easier, whilst sticking to the numbers and letters format. I wouldn't worry too much about hackers getting your wifi password, as if they want to hack it, all they have to is run a very easily sourced piece of software which exploits your router's WPS. They don't need your password at all and won't even try to guess it. Essentially how it works is, you know that number on the bottom of your router which is 8 digits long? And that button on the front for easy connection to another device? Well, this is the weak point. What that does is share the wireless key between devices, and the software I'm talking about fires 8-digit numbers at the router repeatedly until it hits on the right one in a brute force attack. Once it gets the right one, it will give up the password. Anyone who knows your router's 8-digit number can access it forever no matter what you change your password to since it will only take seconds to get the new password when you change it. The only way to try to prevent this is disabling WPS on your router, but modern hacking software could even get around that too. Simply put, don't make it too hard for yourself.


Hmmmm. Beef with Apple. Sounds delicious.
 

HarveyB

Active Member
That is unless you disable WPS, I assume, as you can on many routers now.


Sent from my iPad using Tapatalk HD
 

Ezra Pound

Well-Known Member
the software I'm talking about fires 8-digit numbers at the router repeatedly until it hits on the right one
It looks like it isn't even a 8 digit combination which would be 100 million, because acknowledgement is given in two halves, one for a 4 digit number and another for a 3 digit number (The other digit is a checksum) so you only need to send 11000 requests to find any 8 digit number ! ! !
I wasn't aware of WPS as my router is too old to have that feature, thankfully
 

Black Hole

May contain traces of nut
I thought you had to press the button at both ends to establish a WPS link, within a certain time of each other. I could be wrong, I've never used it.
 

Ezra Pound

Well-Known Member
Good ol'e Wikipedia says WPS has 4 modes, 8 digit PIN and Push button modes are mandatory, there are also two optional modes of Near-Field-Communication and USB access, It also says that on some routers disabling WPS doesn't disable the 8 digit assess, the one you would want to disable
 

dragon-it

Member
I suppose I really should set encryption on the powerline adapters ... or the outside power socket on the front of the house is effectively an open network socket too! I wonder if anyone has tested how far these things go, and whether the signal can get beyond the incoming meter?
 

Black Hole

May contain traces of nut
We have had a reported case of somebody discovering their HomePlug had connected through next door's Internet connection.
 
Top