ntpclient won't update, claims older version is newer

Owen Smith

Active Member
I have several boxes which won't update ntpclient as they think 2010-365-4 they are running is newer than 2010-365-5 which is the new version available. Any ideas? The line from the update screen isn't very clear when copied but here it is:

ntpclient 2010-365-4 2010-365-5 Network Time Protocol client - maintains the system clock using Internet-based time servers. Newer
 

af123

Administrator
Staff member
If the packages screen say "Newer" in italics then it means that it thinks your locally installed version is newer than that in the repository. Could be a bug in the version comparison code though.

Can you try:

Code:
humax# opkg list ntpclient
ntpclient - 2010-365-5 - Network Time Protocol client - maintains the system clock using Internet-based time servers.
humax# opkg list-installed ntpclient
ntpclient - 2010-365-5
 

af123

Administrator
Staff member
Yes, it was a bug in the package comparison routine. It couldn't handle a package version containing two - characters.
(I'm not sure if that's even a legal package name actually)

Fixed in webif 1.3.4-12
 
OP
O

Owen Smith

Active Member
Yes, it was a bug in the package comparison routine. It couldn't handle a package version containing two - characters.
(I'm not sure if that's even a legal package name actually)

Fixed in webif 1.3.4-12

So do you want me to try anything now, or is it simply fixed in webif and we're all done here?
 

af123

Administrator
Staff member
So do you want me to try anything now, or is it simply fixed in webif and we're all done here?
It's fixed in webif so will be ok from now on. If you don't want to upgrade the web interface you can do an upgrade through the command line (opkg upgrade ntpclient) and that should work fine.
 
OP
O

Owen Smith

Active Member
It's fixed in webif so will be ok from now on. If you don't want to upgrade the web interface you can do an upgrade through the command line (opkg upgrade ntpclient) and that should work fine.

I'm not that bothered about updating ntpclient, the old version is working for me. It's just something was obviously wrong with the update screen. You've fixed that, so this will all work itself out after a while.
 
Top