Post crash and installation wizard

mihaid

Well-Known Member
Is it always needed to do a manual or an auto tune or is there some automated process which would do that?

I can't remember exactly what all the auto**** packages do.
 

Black Hole

May contain traces of nut
You have to go through the installation wizard, it won't let you do anything else. A manual tune of just one mux is the quickest way, if it will let you, but let it auto-tune to get the benefit of tunefix (see below).

If you took measures beforehand, you can then restore practically all the old settings just by rebooting:

boot-settings restores all the general preferences;​
tunefix tweaks the tuning set to your liking;​
auto-schedule-restore reconstructs the recording schedule database from the latest backup (automatic daily, or manual).​
The only thing not covered is the networking. Of course, all those packages need to be installed and configured before they can do any good.

See also https://hummy.tv/forum/threads/is-there-a-good-time-to-retune.7624/post-103888
 
OP
M

mihaid

Well-Known Member

Black Hole

May contain traces of nut
how, when does it do it?
If the schedule is empty at boot. The schedule empties if an auto-retune takes place (or after a factory reset), and auto-schedule-restore uses that as a cue to restore from backup. That means you always need at least a dummy entry in your schedule, if you are going to use ASR.

WebIF makes the backups - just look in WebIF >> Scheduled Events.

Any other questions about packages? https://hummy.tv/forum/threads/index-of-package-primary-topics.8005/

I saw the title of that thread but thought it was about sthing else. it would be better named "installation wizard" step by step
Sure, but things often develop out of something else. That's why I spend a lot of time sifting wheat from chaff and providing pointers (which people then ignore or can't be bothered).
 
Last edited:

MikeSh

Well-Known Member
I must have rebooted 3 if not 4 times, lost count. but no schedule
OK. Sometimes I've had it manage to save an empty schedule in asr during these events.
The fix then is to use WebIf to look at the backups from the newest back in time until you find the most recent sensible one and manually restore that.
 

Black Hole

May contain traces of nut
IIRC sometimes it needs a second reboot to get everything sorted. Possibly worth doing two before checking it's all set up properly.
I thought it rebooted itself a second time, automatically.

I must have rebooted 3 if not 4 times, lost count. but no schedule
Is the schedule actually empty, is ASR installed, and has the latest backup (inspectable via WebIF >> Scheduled Events) got anything in it? If the latest backup is empty, just manually restore one which isn't.
 
OP
M

mihaid

Well-Known Member
Is the schedule actually empty, is ASR installed, and has the latest backup (inspectable via WebIF >> Scheduled Events) got anything in it? If the latest backup is empty, just manually restore one which isn't.
after auto tune it should be empty right? yes. yes. done so because impending recording
 

mr-b

Member
Good catch! (if it's right that is)
I think this is why I've been having longstanding issues with the schedule not being restored automatically after various retune/reset events.
If I went back to prev schedule backups they were populated as expected. No idea if this could/should be changed i.e. make it restore the last populated backup ...
 
...
boot-settings restores all the general preferences;​
tunefix tweaks the tuning set to your liking;​
auto-schedule-restore reconstructs the recording schedule database from the latest backup (automatic daily, or manual).​
The only thing not covered is the networking.
I have just seen my first (that I can remember) post crash installation wizard.

As luck would have it, it didn't finish until it had past the start of a recording, which I had to start recording by tuning to the channel and hit the red remote button.

The networking is a faff, as it seems to default to DHCP, whereas I have all my devices on static IP addresses in the 10.0.0.x range.

Is there no way to have the network settings auto-restored?
 

everthewatcher

Forum Supporter
The networking is a faff, as it seems to default to DHCP, whereas I have all my devices on static IP addresses in the 10.0.0.x range.
See if your router will has a setting to let you reserve an IP address for each device based on its MAC address. If it does then kit can be set to DHCP but will always have the same address, controlled from the router.
 
See if your router will has a setting to let you reserve an IP address for each device based on its MAC address. If it does then kit can be set to DHCP but will always have the same address, controlled from the router.
I prefer to leave well alone as regards my router.

I suspect it would hand out 192.x.x.x IP addresses which I don't want.

Last night, I put in the usual static IP address as well as the gateway IP address and connected to restore my schedule backup.

Oddly, this morning, these IP addresses were gone again.
 

Black Hole

May contain traces of nut
I suspect it would hand out 192.x.x.x IP addresses which I don't want.
You should expect 192.168.xxx.xxx - that is the default for local home networks (with 0 or 1 in the third field). Are you using something else? If so, you must have fiddled with the router to configure that "something else".

Regardless, assuming you are not operating independent networks over one set of cables, the first three fields of IP address must be preset, and netmask = 255.255.255.0. DNS and Gateway addresses conform to this also. The easiest way to achieve this with a static setting is to accept a DHCP and then convert it to static (altering just the fourth field of IP address as desired).

Note however that you must ensure your selection of static address cannot be handed out to any other device by the router, by choosing it outside the router's DHCP pool or reserving it in the router.

Last night, I put in the usual static IP address as well as the gateway IP address and connected to restore my schedule backup.

Oddly, this morning, these IP addresses were gone again.
Are you using WiFi? If so, see here: https://hummy.tv/forum/threads/hdr-lan-wi-fi-settings-mysteriously-corrupted.9511/post-136810

Generally, see here: Configuring IP Address (click)
 
... you must have fiddled with the router to configure that "something else".
The easiest way to achieve this with a static setting is to accept a DHCP and then convert it to static (altering just the fourth field of IP address as desired).
Yes, I turned off DHCP and assigned static IP addresses in the 10.0.0.x range.

Here is a list of my devices, taken from my router Local Network Devices table:-
Code:
DesktopBlackBox      10.0.0.4    Ethernet Interface

TiVo-2               10.0.0.12   Ethernet Interface   
Humax-Recorder       10.0.0.14   Ethernet Interface
Sky-Box              10.0.0.15   Ethernet Interface
NOW-TV-BOX           10.0.0.16   Ethernet Interface 
Raspberry-Pi         10.0.0.17   Ethernet Interface
Hitachi-TV           10.0.0.18   Ethernet Interface   

iPod-Touch           10.0.0.20   WLAN Interface   
TescoHudl            10.0.0.21   WLAN Interface   
Tesco-Hudl-2         10.0.0.22   WLAN Interface
Samsung-Galaxy-Tab   10.0.0.23   WLAN Interface
Are you using WiFi?
I am not using WiFi on the Humax.

Note however that you must ensure your selection of static address cannot be handed out to any other device by the router, by choosing it outside the router's DHCP pool or reserving it in the router.
Once again living up to my username, I don't quite understand this.

However, I dug around in my router and found this:-
Code:
    TCP/IP Configuration
    Auto-IP Enabled:    Enabled
    Use DHCP Server:    Enabled
    IP Addresses

IP Address/Mask    Type   
10.0.0.1/24    Static
10.0.0.138/24    Static
169.254.90.28/16    Auto

    DHCP Pools
DHCP Pool Name    Address Range    Gateway   
LAN_VIRT    192.168.1.253 - 192.168.1.253    192.168.1.254
dhcp_pool_2    10.0.0.16 - 10.0.0.19    10.0.0.1
dhcp_pool_1    10.0.0.25 - 10.0.0.39    10.0.0.1
I must have configured those years ago.

I presume DHCP Pool means that the router should only hand out those addresses??
 

everthewatcher

Forum Supporter
I presume DHCP Pool means that the router should only hand out those addresses??
Correct.

FWIW I had used fixed addresses when I only had a couple of things on the network but it got more difficult to keep track as more were added. Then I saw the DHCP reserved address trick and haven't looked back.
 
See if your router will has a setting to let you reserve an IP address for each device based on its MAC address. If it does then kit can be set to DHCP but will always have the same address, controlled from the router.
FYI I investigated this further, and it doesn't appear to be possible with my router.
 

everthewatcher

Forum Supporter
FYI I investigated this further, and it doesn't appear to be possible with my router.
That's a pity. AAMOI what is it?

My Netgear DGND3700 has it under Advanced>Setup>LAN Setup.

The BT Smart Hub it's connected has it too, buried under Advanced Settings>My network, click on the device, change the IPV4 address under 'Device Name:', select 'Always use this IP address: Yes'. But I should add that I've not tried it as the Smart Hub is just being used as a gateway and modem.

[Edit] Apologies - I missed a step there. It's:
My network > Address table, click on the device, change the IPV4 address under 'Device Name:
 
Last edited:
Top