Problem playing MP4 files bigger than 2GB

rfgdrake

New Member
I have ripped all my DVDs to my Synology server using Handbrake. The Humax is connected via ethernet to the server. All the DVDs were ripped to MP4 using Handbrake's 'High Profile' setting with the Large File Size box unchecked. All the files that are below 2GB play just fine through the HDR Fox T2. However, all the files that are bigger than 2GB cause an error message: 'Cannot support this file format'. (Note that no files are larger than 3GB) All the files, no matter their size, play on other devices in the house (e.g. iPad, Android), which suggests there's nothing wrong with the files themselves. I was confused about why files smaller than 2GB would play on the Humax but not those greater than 2GB so I wrote to Humax's Customer Support. Their answer was that they didn't have a problem at their end so the problem must be in the way I did the ripping (and they hinted that there were well-documented problems with using Handbrake, something I've not been able to verify). They dismissed my comment that if the files were all created in the same way, and that files smaller than 2GB played without any problem, then the Humax must be doing something differently with files greater than 2GB. Wondering if this was a limitation of the factory firmware, I've just installed the custom firmware but the issue is the same. It seems that member ACS had the same issue in July 2012 and it was suggested the problem was with his NAS. As explained above, I don't think that's the problem, rather that the Humax is doing something different with files that are larger than 2GB. I'd be grateful to know if anyone else has had this problem and even more so to find a workaround. Many thanks in advance.
 

Ezra Pound

Well-Known Member
I'm guessing that you are streaming the MP4 files to your Humax from your Synology NAS, it is worth copying a failing file onto the Humax to see if the Humax will play the file when it is on the internal hard disk, if this works, it proves that the Humax can't play these large files if they are streamed
 
OP
R

rfgdrake

New Member
Explain exactly how you are moving these files onto the HDR for playback.
I rip the DVDs to the local drive on my PC. I then copy them to the appropriate drive on the Synology server. The server has two media server applications available. I have been using Synology's own Media Server application but since positing my question, I've also tried Plex. On the Humax, if I'm accessing a file greater than 2GB, it makes no difference whether I do that through Media Server or through Plex, I still get the same error message.

Following Ezra Pounds' advice, I've just FTP'd one of the >2GB files straight onto the Humax and it played without a problem. So that means there's nothing wrong with the file itself, which is a good step forward, so thanks for that. Do you think this could be an issue with the way the Humax communicates with the server, presumably DLNA?
 

Ezra Pound

Well-Known Member
What version of firmware are you running?, there was a streaming file size limit on early Humax Firmware releases, see link HERE, note:- this is not quite the same problem that you are reporting
 
OP
R

rfgdrake

New Member
I installed the custom firmware today so my Software Version is currently shown as FHTCP 1.03.12. I'm aware of the 4GB limit but I can't find anything (except from the poster (ACS) that I mentioned in my original question) on a problem with files greater than 2GB. I confess that I don't know how the Humax pulls the file from the server (DLNA?) but is there another way of doing it?
 

MontysEvilTwin

Well-Known Member
I don't know what is causing the DLNA issue, but the file sizes in question made me think of a Samba bug (see here) whereby files below 2GB were OK, but 2-4GB files gave a disk full error. This may not be the cause of your problem, but the bug is now fixed (see above link) for Samba shares with the custom firmware. Now you have CFW installed, even if you can't resolve the problem you describe, using Network Shares Automount with your remote drive set up as a Samba share should enable file playback.

Edit. Out of interest, have you tried playing a file in the 4-6GB range? In the (admittedly unlikely) event that your issue is related to the above bug such files will play.
 
OP
R

rfgdrake

New Member
Sorry for the delay in my reply. Unfamiliar as I am with the CFW, it took me a while to get this working but I'm genuinely thrilled to say that it's working just as it should. I haven't tried it with files >2GB but those up to 3GB are playing just fine. I will just add that though it's been noted elsewhere, it's worth saying that you need to have a USB stick plugged in (it doesn't matter what's on it except that it doesn't want to be the CFW or the Humax will try to set itself up again) and then you can see the share under Media, Storage, USB. One other thing I did, and this may only be relevant for those pulling files from a server, was to create a new user account on the server, one with only Read Only privileges. That's because I'd read that some people had accidentally deleted files by using the opt+ button.
Anyway, thanks to all those who helped me with my question. It's much appreciated.
 

Black Hole

May contain traces of nut
Making your share read-only means the resume and bookmarking mechanisms will not be available, but as you are not talking about native recordings that will not be an issue for you. The deletion risk is greatest when the user mounts the remote share into My Video as a virtual folder - if the folder is deleted the deletion process walks the remote share emptying sub-folders before the sub-folders can be deleted, and finally emptying the top level so that the mount folder can be deleted. For this and several other reasons I recommend staying away from the shareFolder option in [Modsettings]. When the mount is a virtual USB rather than a virtual folder, it is more obvious what you're doing.

The need for a real USB storage device to be plugged in (stimulating the Humax firmware to list real and virtual USB drives), or to install the virtual-disk2 package (doing the same job, but annoyingly popping up a USB menu each boot), is thoroughly documented.
 
Top