• The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

Beta [Real-time scheduling] schedule without rebooting

af123

Administrator
Staff member
#1
There is still one known problem with this new feature. Occasionally a recording will just keep going past the time it should have stopped and require manual intervention. This does appear to be rare but we haven't worked out why it's happening yet.

Any observations and particularly reproducible tests are welcome!


Until now, for as long as it has been possible to schedule recordings via the custom firmware web interface, they have been placed into a pending queue and only moved into the main schedule on the next boot or reboot.

With the latest version of the web interface, this limitation has been bypassed with a new setting to enable real-time scheduling:



Although this new facility has been tested extensively, it is currently regarded as still in beta testing and as such is made available for custom firmware users to try out at their discretion. As the real-time scheduling support is in the core web interface libraries, any application that uses these to perform scheduling (e.g. Remote-Scheduling) will benefit automatically if the option is enabled.

The default setting is "no" and so schedule changes will be queued in the normal way and require a reboot before they are moved into the main schedule. Once the setting is enabled, schedule changes will be incorporated into the main schedule and be visible on the TV screen too [Guide >> Schedule (yellow)] as if they had been entered via the on-TV interface*. No reboot required warning will appear in the web interface**.
It's even possible to schedule events which have already begun showing although the recording will only start from that point.

* The events do still go through the pending phase so there can be a delay of a few seconds.
** There's one exception to this which is that "Refresh" commands are held for the next boot.

To enable this facility:
  • Upgrade the webif package to version 1.3.2-1 (this will be automatic if you have the auto-update package installed);
  • Reboot;
  • Go to WebIF >> Settings >> Advanced Settings, set Real-time scheduling? = YES.
Thanks are due to Black Hole and prpr for their help in testing this new feature over the past few months and for providing valuable feedback and ideas along the way.

You may notice a new screen in the Diagnostics section called Internal Timers which displays the internal timers list that the Humax software is currently using (along with additional information pulled from the schedule database). This is provided to aid diagnostics. The internal timer information can be viewed at the command line with: nugget schedule.timers.

nugget is a new software component which is loaded directly into the Humax settop application. It is able to access and manipulate internal data within that application such as the scheduled events database and timer list. There are plans for it to do more in the future but since RTS has taken 5 months to develop, maybe don't hold your breath : )
 
Last edited:

Black Hole

May contain traces of nut
#2
This is the paradigm shift I was hinting at. Power cycling no longer necessary (except to clear a crash). Control recording through the WebIF without annoying the family with reboots (or being unable to reboot because of an existing recording). RS now with instant (more or less) effect for scheduling recordings away from home.

This may be the best add-on since the CF.

For reference: I have personally tested this on HDR-FOXes with 1.02.20/3.10, 1.02.32/3.10, 1.03.12/3.10; and HD-FOX with 1.03.02/3.02.
 

Wallace

Slightly Pickled
#3
Wow.

I have just set a scheduled recording for later, that has appeared to set OK and appears in the 'guide'. I also set it to record Dragons Den which has been on for over half an hour. It has started to record within seconds.

This could be the next best thing since sliced bread.

Thanks,
 

Wallace

Slightly Pickled
#4
Test recording of Dragon's Den started and completed successfully. It has also been decrypted and shrank, just as normal, with the exception that I started the recording half way through the broadcast and via the WebIf.

Great, smashing, suuuuper.
 

4ndy

Forum Supporter
#8
I have 4 boxes. I just logged onto each of them and found a pink list of updates including (I think) this webif version. The list also showed that each of the boxes had crashed and packages had been disabled. sadly not that unusual.

I ran Fix-flash-packages on two of the boxes but these failed because the package lists are completely empty. Then I power cycled to restore the status quo, came up with the webif installation screen, with my only option to install webif and reload all the packages.

The third box (HDR3)seems to be fine, and has webif 1.3.2-1 installed OK. Fix-flash-packages has run OK and I have rebooted a couple of times.

The Fourth box (HDR1) has updated but is recording, so has not yet rebooted. Time will tell.

This may be nothing to do with this upgrade, but it would be a big coincidence. I was, however without internet from early Saturday to mid-afternoon today, so the normal auto updates were disrupted. This may also be part of the problem.

Is anyone else having similar problems?
 

Black Hole

May contain traces of nut
#9
What about disable-ota and disable-dso?
I normally have auto-update events in my schedules, because my boxes don't reboot for disable-ota to remove it. I was thinking that now disable-ota would remove the schedule entry without needing a reboot, but the auto-update events are still there (masked by reminder reservations).

Is this because disable-ota only runs at boot time?
 

Trev

The Dumb One
#10
Right then. I had the Olympic closing ceremony (OCS) scheduled for tonight (at 2325). I upgraded to the new WI and rebooted at about that time. The box fully recovered from the reboot just after 2325. In the scheduled events, the OCS red blob indicates it is recording, but it's not, no redring and no recording indicated in the WI top bar. Luckily, I noticed this and set it to record manually. It's now showing in the WI top bar as having started recording at 2333 (when I pressed the record button).
The point is not that I probably screwed it by doing stuff at exactly the time the recording was due to start, but the fact that the WI schedule showed it as recording when it wasn't. Any comments other than Poke Off D Head?;)
 
OP
OP
af123

af123

Administrator
Staff member
#11
but the fact that the WI schedule showed it as recording when it wasn't. Any comments other than Poke Off D Head?;)
Unfortunately, at present, the schedule just shows the progress bar based on the scheduled start of the recording + any padding, it isn't linked into whether the recording is actually in progress as it can't tell that easily. I guess that it didn't recover from the power cycle early enough to start the recording on time.
 
OP
OP
af123

af123

Administrator
Staff member
#13
This may be nothing to do with this upgrade, but it would be a big coincidence. I was, however without internet from early Saturday to mid-afternoon today, so the normal auto updates were disrupted. This may also be part of the problem.
I cant imagine how that could be related to this upgrade. Regular crashes aren't normal and can be diagnosed with the crashdiag package (but please start another thread for that if you want to pursue it).
 

MontysEvilTwin

Well-Known Member
#15
Excellent addition to the custom firmware. I didn't think there was much more that could be done to improve it.
I use the multimode package to set some channels to padding (default = AR). Real-time scheduling does not currently apply the multimode settings: a reboot is still required. However, If you manually disable AR in the recording list, for example, this is applied instantly. Presumably the multimode package needs an update to accommodate this new feature. af123 - if you do update multimode, I have found that this package works well with AR as default, but with padding as default, AR recordings usually fail with 'failed to track errors'. If there is no straightforward fix for this would it be better to remove the option?
EDIT: I didn't see that multimode was already mentioned in post#12 :oops:
 

martxw

Active Member
#16
Great feature, thanks!

But I did just have my pre-scheduled series recording of Parks and Recreation on Dave go missing, after real time scheduling the Olympic Closing Ceremony and Match of the Day. There's no sign of it being a zero length failed recording. The series link is still there for next week. And MOTD and the Olympics kept recording fine, and were both on the same channel, so there wouldn't have been a >2 clash.

Could just be pure coincidence, but I don't remember totally invisible failed recordings like this.
Thank goodness Dave have online catch up :)

Fingers crossed it's a one-off.
 

Wallace

Slightly Pickled
#17
All test recordings have completed and saved correctly.

I too use the multimode package, default AR with only Channel 5 set for padding.
 

HarveyB

Active Member
#19
EDIT: ignore this - cleared Safari cache and the message has gone. Though there is no pop up saying that restart not required. So what!

It works but still shows the "reboot required" message in the webif header, even though the entry has gone straight into the schedule.


There was NOT a message saying "no reboot required ...".

I installed webif, rebooted, set "real time scheduling", rebooted then used EPG to schedule.

Have I missed something, or do I just ignore the reboot message?


Sent from my iPad using Tapatalk
 
Last edited:
Top