1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subtitles appear when I resume play after pause

Discussion in 'FOXSAT-HDR Freesat Recorder' started by Sally Burgess, Jul 4, 2011.

  1. Sally Burgess

    Sally Burgess New Member

    Hi,
    Wonder if anyone knows how to get rid of the pesky subtitles which appear if I pause live tv & then resume play. It's driving me bonkers & I can't find anyway of getting rid of them until I press the stop button to go back to live tv.
    Cheers - Sally
     
  2. gomezz

    gomezz Well-Known Member

    Press Exit a couple of times.
     
  3. grahamlthompson

    grahamlthompson Well-Known Member

    On the channel you get the problem try turning subtitles on and then off again. With a bit of luck from then on you won't need the double exit. (Double OK works as well)
     
  4. Sally Burgess

    Sally Burgess New Member

    Brilliant that worked, I'd tried pressing it once but twice was the trick
    Cheers
     
  5. grahamlthompson

    grahamlthompson Well-Known Member

    It will happen again unless you use the sub button fix.
     
  6. Mike0001

    Mike0001 Well-Known Member

    Are you sure about the first part?

    My experience is that it is only happening on BBC HD services. When I pause now, I can guarantee that subs will appear on restart, and you can't then turn them on and off.

    I haven't tried the double Exit trick yet.

    Edit: Double Exit worked. Second time I tried, single Exit worked.

    When timeshifting, it doesn't allow you to switch subs on and off, but after stopping timeshifting your fix appears to work.

    Tried pausing and resuming ITV HD and no subs problem. Couldn't try on BBC HD as the prog was permanently subtitled.

    So, this is a BUG, right?
     
  7. gomezz

    gomezz Well-Known Member

    I could only turn subs ON then OFF from the Menu and only while watching Live. But from then on I did not get subs if I watched delayed.
     
  8. Mike0001

    Mike0001 Well-Known Member

    gomezz, are you only getting the bug on BBC One HD or is it general?
     
  9. grahamlthompson

    grahamlthompson Well-Known Member

    As Gomezz says you need to toggle the sub settings while viewing live, not while using timeshift. The number of exits you need depends on if the progress bar is still on the screen. First press exits progress bar, second gets rid of subtitles. If progress bar has timed out only one press is required.
     
  10. Mike0001

    Mike0001 Well-Known Member

    That makes sense
    That makes sense then. Is it only on HD channels, possibly only BBC ones, that it happens, though?

    Also, I don't understand how the subs on then off could fix it, as isn't that a global setting?

    Finally, it is a bug, right?
     
  11. grahamlthompson

    grahamlthompson Well-Known Member

    Apparently it's a channel specific setting :confused:. Depends on what you call a bug. A bug normally requires a work around. If changing a setting fixes it permanently it's not really a bug. There is however a bug because if you use customise channels only the exit workaround works. For me it only affected 101 (customised) and the BBC-HD channels. I have seen a report of it happening on CH5 though.
     
  12. Mike0001

    Mike0001 Well-Known Member

    Thanks, Graham.
     
  13. gomezz

    gomezz Well-Known Member

    If presumably fixes it because for some reason the setting used for display is different to that used by the subtitling code. Toggling ON/OFF then forces both settings to be the same and correct value. A not uncommon bug and workaround fix in the wonderful world of software.

    AFAIK doing it once has fixed it on all channels for me. But then I very rarely use time-shifting and only tried this on one channel (BBC1 HD I think) out of interest.
     
  14. merlin777

    merlin777 Member

    it happened for me on ITV1. The double exit fixed it.