Troubleshooting rebooting (all ok in safe mode)

rodp

Member
Hi All,

Creating a new thread to troublehoot this (carrying on from this thread which is more to do with replacing my HDD: https://hummy.tv/forum/threads/brand-new-hdd-but-extents_fl-errors.9861).

Quick summary
-My HDD has been getting some bad sectors as reported by Smart
-there has been a long term issue in the HDD saying LBA 0 error
-Programs started taking a long time to start and stop (about 45 seconds). I could hear the heads on the HDD recycling as if there was a sector it couldn't read. This happened on any recording

So I ran fixdisk (via maintenance mode) - see the above URL link for the report, it fixed some errors but had to skip the LBA0 error. Straight after doing that (after a reboot mind you) the unit began rebooting itself after about 5 minutes. If you're watching tv the picture begins to freeze and within about 30 seconds stops, the screen goes black and the Huamx front starts counting down to reboot. This is quiet persistant.

So far I've turn off the timeshifting (TSR-disable), turned off file sharing so no DLNA and made sure that the dms_cds.db file has been deleted from the 2nd partition.

Whilst watching TV within the first 5 minutes (this is in normal mode ie CF is running) I can hear the HDD working hard obviously doing something reading and writing but timeshift is off and there is nothing in the Queue when looking in webif but whatever it's doing if causing for the screen to freeze, then go black, the HDD carrys on for a little longer and then it starts the reboot process.

I've also tried channel 250 (BBC red channel) vs a normal channel like bbc1 but no difference. The HDD is still just as busy and it crashes after abou

I've been following this: https://hummy.tv/forum/threads/steps-for-resolving-hdr-fox-crash-reboot-issues.5320/ and have got as far as ready to reinstall the custom firmware or using the 'System Flush Update File'. But before I do and as I have about 5 minutes between each reboot, is there anything else I can do?

eg. In the terminal window, can i see what processes are running and making the HDD work so hard even though I've turned off what I think would be making it work hard (eg. reindexing the DLNA database, the timeshifting etc.).
What logs should I be looking through? So far I haven't really found anything, they are all really talking about events at boot up not what it's doing at time of reboot.

The queue is empty
pty but the HDD is working away like crazy.

a quick google, there is a command called 'top' which I've run and this is what I see (numerous screenshots over time, so my 5 minute estimate reboot time is a little out, it's about 10-13 minutes)


then finally this one at the time of the actual reboot but I can't be sure if the humax has already decided it's time to reboot at this point so the file vmstat might not be the culprit

I did notice that the media tomb service was running so I've just turned that off.......aha!! As soon as I turned it off in the service menu, the TV has not crashed since.

So, it's mediatomb (either the process called mediatomb or mtdblockd)!! Let me guess, it's scanning files and found one which might be corrupt or the database needs clearing out.

Can anyone enlighten me a little on this perhaps.

I've done a few test, enabled media tomb whilst the box is recording - no problems as I guess it won't let media tomb reindex whilst it's recording but as soon as recording has stopped I can see in the process list, mediatomb and mtdblokd then reappears and the HDD starts going crazy again.

In the mediatomb setup I have the /media folder setup ('inotify' mode) which means it updates the index straight away when anything changes.

Thanks

Rodp
 

Attachments

  • 1599932672348.png
    1599932672348.png
    42 KB · Views: 4
  • 1599933299117.png
    1599933299117.png
    41.7 KB · Views: 4
  • 1599933410569.png
    1599933410569.png
    42.1 KB · Views: 4
  • 1599933645517.png
    1599933645517.png
    42.3 KB · Views: 4
  • 1599933711255.png
    1599933711255.png
    40.9 KB · Views: 4
  • 1599933815161.png
    1599933815161.png
    41.8 KB · Views: 4
  • 1599936328277.png
    1599936328277.png
    42 KB · Views: 4

MartinLiddle

Super Moderator
Staff member
In the mediatomb setup I have the /media folder setup ('inotify' mode) which means it updates the index straight away when anything changes.
First question would be why do you have the Mediatomb package installed? I thought it was mainly for the HD-FOX T2.
 
OP
R

rodp

Member
it's for the HDR too that I know of. You can do alot more with Mediatomb compared to the normal offering too. eg. Chromecast audio devices don't like mpeg-1 layer 2 audio (what you get from recording radio and video off freeview). You have to convert the audio to mpeg 1 layer 3 (as known as mp3) and the humax can't do that efficiently. So what I've done is create a new extension (.mpL2) which mediatomb then knows and will stream the audio to the chrome cast in wav format which is does very nicely.
 
OP
R

rodp

Member
so after removing the Mediatomb package mtdblockd is still in the process list (so maybe that is a standard process). The HDD is still going through some sort of indexing process but at least it's not rebooting. The Queue is once again populated but it's deferring items as the DLNA service is off. So I'll try turning it back on through the tv menu file sharing option (Settings > system > internet settings > content Share = ON). The indexing thing it's taking a lot of resource away it seems so it's gone really slow to respond again.

So it sound like media tomb isn't the only thing that is the problem. humaxtv and mtdblokd are the two resources taking up most of the CPU. The HDD is now busy working through all the files checking they have been decrypted and shrunk I guess and it is meaning that even getting to the media list (videos folder) is taking ages - it just says processing... on the tv screen.

So something else is a foot. Is the next step to use the 'System Flush Update File'. Will that keep a record of the packages and settings I have or at least when I reinstall the package will it have kept a record of the settings or do I need to record the settings on paper or something?

The system evtually quietens down but it's now a crash I think, it doesn't reboot though, the screen just hangs on what ever it's at.

If I do a System flush it's likely I'll lose any evidence of what the problem might be? Edit, looks like I can use the CWF Reset button on webif instead of the system flush so will give that a go.

Going to go into maintenance mode first and run a fixdisk first though.

Thanks

Rodp
 

/df

Active Member
What are you aiming to achieve? Why not use the new disk and Secure Erase the old one?

mtdblockd will be the MTD block device, so handling the flash storage.
 
Top