1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TV Portal app won't launch.

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Bunny, Aug 29, 2011.

  1. Bunny

    Bunny New Member

    Hi all.
    There have been numerous posts that touch on this problem but none of the fixes have worked for me. I am out of ideas now so hope someone can help me.
    When I try to launch the TV portal I get the "an error occurred whilst launching the application http://www.humaxtvportal.com/" error message.
    My HDR-FOX-T2 connects fine to my home network using either wireless or wired ethernet. In either case I am using DHCP to alllocate an IP address and can successfully ping my HDR from other devices on my network. Latest firmware is loaded 1.02.20 and I have tried the usual :
    • Restore factory defaults
    • Power cycle the HDR
    • Power cycle my home router
    I am a BT broadband customer and use a BT HomeHub. The config of the router looks like it should work, I even tried disabling any firewall function in the router but with no success. I haven't seen any mention in any of the threads/forum of special settings needed for the router i.e port forwading etc
    I have even tried taking my HDR to my sons home where a different router and BB provider is used, the result is the same. It looks like a connectivity problem to me, being I can connect to my home LAN but not through the router to the internet, but I am guessing and have no idea how to test this idea.
    Any suggestions on further tests or fixes gratefully recieved.
     
  2. Black Hole

    Black Hole Ron Glum

    I'm sorry you haven't had any help to your problem so far. I believe I have seen this too - when I was toying with the HD-FOX T2 - but that could have been the 1.02.18 HD-FOX update (which was known to be buggy). I don't have a solution.

    I agree it could be your router getting in the way. You can easily check your connectivity to the home network by enabling FTP and/or media sharing and doing a few experiments from a PC - no modding required, see my trail guide for info (click) stage 1.1 (FTP) and stage 2 (non-hacked streaming to PC).

    I think it would be worth you also posting on AVForums (click), which has a different audience with a different perspective and experience.
     
  3. ChrisDaniels

    ChrisDaniels Well-Known Member

    If its a non-modded, stock box that is having this problem, I recommend talking to Humax.
     
  4. sceptic

    sceptic Member

    A bit of a long shot but you could access the hidden service menu and try using the Reset cookie and DRM data option
     
  5. Black Hole

    Black Hole Ron Glum

    Good call!

    I've had another idea about the Internet gateway settings... about to try an experiment - I will post again when done
     
  6. Black Hole

    Black Hole Ron Glum

    Success!

    I have been able to reproduce your symptoms exactly by corrupting the Gateway Address setting, so it is confirmed that either your setting is wrong or the router is the problem.

    How to check

    First you need to know what the gateway address should be. The easiest is to check what your PC thinks it is: type "cmd" in the start menu search, then when you have a command window type "ipconfig". Scroll up the window so you can see the start of the results output and note the code it gives you as "Default Gateway" - should look something like 192.168.1.254.

    Now fire up the Humax Menu button. Under Settings.. System.. Internet Setting.. Configure LAN.. Gateway Address, check it reads the same. Chances are the DNS Address setting is the same, and Netmask should read 255.255.255.0.

    If these are not right you've found your problem. You could try setting Configure IP to "DHCP" and then rebooting the Humax and check again, or you could set Configure IP to "Manual" and insert your desired parameters yourself.
     
  7. Gonzo

    Gonzo New Member

    Hi There, I'm new to the forum and this is my first post.

    I have Fox T2 (amongst others) but am decidedly non-technical.

    I have exactly the issue as described by the OP - do we know if it solved his/her problem?

    Cheers,
     
  8. Black Hole

    Black Hole Ron Glum

    Since Bunny never posted back to report, all you can do is try what we suggested and let us know!
     
  9. thatcherman

    thatcherman New Member

    Thanks for all the help Black hole.
    I have had exactly the same problem highlighted above and have done what you have suggested. My settings differ having done the cmd and ipconfig commands, but I can't find the DNS address you mention. Any suggestions?
    Thanks,
     
  10. Black Hole

    Black Hole Ron Glum

    I'm away from my box at the moment, but I would expect the DNS address to be the same as the gateway address.
     
  11. thatcherman

    thatcherman New Member

    Thanks again. There has been an improvement in so much as the box now says the network is connected, but again, you hit the tv portal button and the same error message comes up. That said, now it has a good old think about it before flashing up the error message. Previously it was instant.

    Any help welcomed.
    Thanks.
     
  12. Black Hole

    Black Hole Ron Glum

    Is that the "an error occurred..." message? Do you have an aerial connected (it is relevant)?
     
  13. thatcherman

    thatcherman New Member

    Hi there. Yes, it's the "an error occurred whilst launching the application http://www.humaxtvportal.com/" error message that started this thread. Instead of flashing up instantly as it did before I fed in the necessary parameters (using the DCHP option doesn't find the gateway or DNS address and misses three digits (255) of the netmask) it now grinds over for a while before flashing it up. At least it feels that I'm getting closer to it working!

    The ariel is plugged in and the box works fine in all other aspects. It just won't launch the tv portal.

    My system is also BT like the initial posting. Could the router be preventing this? I did have a look at the advance settings and found something about portal forwarding for games and applications but not having any idea about setting 'ports' gave up on that idea.

    If you have any thoughts at all I'd love to hear them.

    Thanks.
     
  14. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Odd that the DHCP doesn't work. What have you set the ip address, netmask, gateway and DNS to?
     
  15. thatcherman

    thatcherman New Member

    Hi there,
    If I use DHCP it comes up with

    IP address - 169.254.14.134
    net mask - 255.255.0.0
    gateway - 0.0.0.0
    DNS - 192.168.1.254

    The IP doesn't match that which I get by inputting 'cmd' in the start menu search and then 'ipconfig' as suggested by Black hole so I've been putting in

    IP address - 169.168.1.64
    net mask - 255.255.255.0
    gateway - 192.168.1.254
    DNS - 192.168.1.254

    Any thoughts?
     
  16. af123

    af123 Administrator Staff Member

    The DHCP setting is falling back to an automatic IP address (169.254.x.x) meaning that it didn't find a DHCP server on your network.

    For the manual IP information, your IP address needs to start 192.168 (you've posted 169.168)
     
  17. Jon@Rochester

    Jon@Rochester New Member

    New to Humax and new to Hummy.tv. I'm impressed with all the advice .... please can you help me ?
    Trying to start TV Portal I had the 'error' message already discussed. I checked ipconfig and none of the addresses matched. Followed Black Hole & thatcherman ....
    Set Humax
    IP address 192.168.2.3
    Netmask 255.255.255.0
    Gateway address 192.168.2.1
    DNS address 192.168.2.3

    (My router IP was 192.168.2.2 &
    Gateway 192.168.2.1)
    First time I got a black screen, second time the TV picture remained and there was no message.
    Thanks in advance for any suggestions. I will post a reply !
     
  18. Ezra Pound

    Ezra Pound Well-Known Member

    The DNS should not have the same address as the Humax, It should be the same as the Gateway e.g. :-

    IP address 192.168.2.3
    Netmask 255.255.255.0
    Gateway address 192.168.2.1
    DNS address 192.168.2.1
     
    Jon@Rochester likes this.
  19. Jon@Rochester

    Jon@Rochester New Member

    Thanks Ezra. Matched the Gateway and DNS addresses but unfortunately still no joy. This time I got the 'error launching' message.
    Heyho !
     
  20. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Can you describe your setup (make and model of all devices would help)? What is the Humax connected to? How does that box get to the Internet?