• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

TV Portal Won't Run

Black Hole

May contain traces of nut
There is a previous thread about the HD-FOX TV portal here (click).

Currently on 1.02.20 (unmodified).

Every time I try to fire up the TV portal I get the message:

An error occurred whilst launching the application https://www.humaxtvportal.com/
I have checked my internet settings (inc gateway address), and the portal runs fine on my HDR (on the same network).

Any guesses?
 

Brian

Administrator
Staff member
Have you tried unplugging the HD-FOX T2, then reconnecting it? this has been reported to work on a number of occasions. Perhaps pressing the reset button behind the flap, would have the same effect without needing to unplug.
 
OP
Black Hole

Black Hole

May contain traces of nut
It goes through cold starts all the time, not kept permanently on power. However, I will try it.
 
OP
Black Hole

Black Hole

May contain traces of nut
I've tried a "restore factory defaults" now - no luck, and a right pain because the HD-FOX refuses to do anything unless it has tuned at least one channel, and I don't have an aerial feed where I have it installed (just network for DLNA/iPlayer).

What I've tried so far:

Multiple cold starts;
Reset button under the flap;
Reflash;
Restore Factory Defaults.

I think I shall have to bite the bullet and talk to Humax.

PS: A DS1000 on the same Ethernet wire runs the iPlayer interface (identical) absolutely fine. But I don't want to have the HD-FOX and the DS1000 in the same place just because the bloody HD-FOX won't run its portal.
 

ChrisDaniels

Well-Known Member
The portal is fired up from an internal file called ocontroller.html & ocontroller.js and this is where the error message is fired from.
I've noticed while playing with the custom portal, that on occasion just after boot up i will get this despite the portal page being a local file.

If i leave it for a little longer, its fine.

Is your box on wifi? as this will take a little while longer to set itself up.
 
OP
Black Hole

Black Hole

May contain traces of nut
No, it's not on WiFi (yet).

When you say "leave it for a little longer", how long? Is that from every cold start or just until it gets itself configured as a one-off? I admit it cold-starts every time, I could try leaving it powered up all day to see what happens, but it has been on for several hours at a time and still get the error message.
 

ChrisDaniels

Well-Known Member
From both a cold & warm start, and I mean just a minute.
If you still have the issue after then, I would presume something is wrong with the network setup or the box.
 
OP
Black Hole

Black Hole

May contain traces of nut
Network settings are the same as for my (working) HDR-FOX, and a DS1000 reached the iPlayer portal fine using the same piece of wire (swapped from the HD-FOX).

Looks more and more like a Humax Customer Support issue then (sigh). Something I will have to shelve until next week (and another job on the list).
 
OP
Black Hole

Black Hole

May contain traces of nut
Interesting idea. No, the HDR has always been switched on. That will be a bugger if I have to turn the HDR on to stream and off to access iPlayer!
 
OP
Black Hole

Black Hole

May contain traces of nut
No good.:(

It looks like I have found a use for my DS1000, which tries (but fails) to stream StDef from the HDR-FOX.

If I get the WiFi working into the HD-FOX, does it extend the network out of the Ethernet port (and therefore could be daisy-chained to the DS1000)?
 
OP
Black Hole

Black Hole

May contain traces of nut
I've just had a mad idea:

Could somebody with an HD-FOX and a working portal please try it with the aerial unplugged.
 
OP
Black Hole

Black Hole

May contain traces of nut
One more thing eliminated, thanks, can't be many others.

When you have eliminated the impossible, whatever remains, however improbable, must be the truth. Arthur Conan Doyle
I conclude it's broken. I have emailed customer support.

Post Script: after 3 weeks Humax never responded to my email. We found the solution first.
 

ChrisDaniels

Well-Known Member
I dont want to state the obvious, but I take it you have eliminated your network being the problem?
ie. the IP address of the box can reach the outside world, not just your internal network?

Have you tried pinging say google from the box over telnet?
 
OP
Black Hole

Black Hole

May contain traces of nut
I don't have mods installed, therefore (I presume) no telnet. It also doesn't try very long before the message comes up (almost instant). Can we think of any other way to check? No harm in installing mods temporarily (or permanently) I suppose.

How would it be prevented from reaching the Internet? I have an O2 ADSL+ WiFi router, it's not been known to block anything before and I don't think it's even able to. Installing the CF and then downloading the MSP will prove it!
 

MartinLiddle

Super Moderator
Staff member
How would it be prevented from reaching the Internet? I have an O2 ADSL+ WiFi router, it's not been known to block anything before and I don't think it's even able to.
Have you tried power cycling the router? My D-Link router will from time to time (usually when I am busy) get it self confused and prevent one computer from reaching the Internet whilst others work fine. Because it is infrequent it catches me out every time.
 
OP
Black Hole

Black Hole

May contain traces of nut
Good call, but no joy.

Just checked, and the routrer firewall is set to allow all outgoing and block all incoming.
 
Top