• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

Wakeup for recordings causes TV to switch HDMI inputs

#1
I recently upgraded my main TV from a Pioneer plasma to a Samsung KS7000 series. Unfortunately an unwelcome side effect of this upgrade is that the TV now switches to the HDR-Fox T2 input (HDMI 2) whenever it wakes up prior to making a recording. This can be very annoying if it interrupts the viewing of Live TV or another HDMI input. I tried fitting a CEC blocker (https://www.amazon.co.uk/LINDY-HDMI-Less-Adapter-Female/dp/B00DL48KVI) but this had no effect whatsoever.

Any thoughts/suggestions? The TV is running the latest firmware from Samsung.
 

Trev

The Dumb One
#3
Turn off CEC on the Sammy. Mine did that until I switched it off.
Don't turn the T2 off?
It's the T2 waking from s/b to record that switches the Sammy HDMI input to the T2 when you are trying to watch the TV.
 
Last edited:

Black Hole

May contain traces of nut
#4
When I had an LG TV and an LG Blu-ray player connected through an active matrix HDMI switch, turning on the Blu-ray would always turn on the TV (even if I wasn't using the handset to do it), even if the switch was not set to connect the Blu-ray to the TV (I mostly output the Blu-ray to the projector). Very annoying, and I couldn't figure out where the link was.

The problem went away when I happened to replace the TV with a Samsung, so they won't talk to each other any more!
 

Luke

Well-Knwοn Мember
#5
It's the T2 waking from s/b to record that switches the Sammy HDMI input to the T2 when you are trying to watch the TV.
:confused:
If the T2 is already on, as Prpr's suggestion, then it can not turn on to record because it is already turned on.
 
#6
I recently upgraded my main TV from a Pioneer plasma to a Samsung KS7000 series. Unfortunately an unwelcome side effect of this upgrade is that the TV now switches to the HDR-Fox T2 input (HDMI 2) whenever it wakes up prior to making a recording. This can be very annoying if it interrupts the viewing of Live TV or another HDMI input. I tried fitting a CEC blocker (https://www.amazon.co.uk/LINDY-HDMI-Less-Adapter-Female/dp/B00DL48KVI) but this had no effect whatsoever.

Any thoughts/suggestions? The TV is running the latest firmware from Samsung.
Try different HDMI inputs. On some TV's auto port selection works on port activity (In addition to CEC) on some inputs, in the same way as auto hdmi switches select the last powered input. You might find a menu item on the TV to disable this action.
 

Trev

The Dumb One
#7
:confused:
If the T2 is already on, as Prpr's suggestion, then it can not turn on to record because it is already turned on.
Yes I realise that, but not everyone likes their T2s fully on 24/7.

All I know is that I have a similar Sammy 7000 to the OP, and if my T2 was in standby, when it 'woke up' to 'look for' the scheduled programme to record, Its CEC switched the TV to its HDMI input which was annoying if you were watching the TV at the time. This seems to be exactly the same 'problem' that the OP is complaining about. I switched off CEC on the TV to stop it doing this. This does of course mean that you have to manually switch the various HDMI inputs, but even that's better than having the T2 (or other device) to switch the TV to itself while it is going through its boot process.
Other than that, Sammy have been having problems getting CEC to work correctly on this TV. Successive software updates break then fix then break it. The current state with the latest S/W is that CEC works (as the OP has found)

.
 
OP
OP
sceptic
#8
Thanks all. I have not given up on this yet and am going to try inserting an HDMI switch between the Humax and the TV as a next step. It was wired that way previously, but with more HDMI's available I wired it directly this time. I'll also experiment with my two free HDMI inputs...
 

Trev

The Dumb One
#9
One for the experts. I haven't come across one, but is there a way of switching off CEC on the Hummy so that CEC still works for other devices?
 
#11
The T2 should not be fully waking when it is recording - recording is usually done in half awake state with the DLNA and HDMI outputs inactive. If you are using DetectAds in Chaserun mode that will switch the T2 to fully awake 3 minutes after the recording starts (because it needs to use DLNA)
 
#12
The T2 should not be fully waking when it is recording - recording is usually done in half awake state with the DLNA and HDMI outputs inactive. If you are using DetectAds in Chaserun mode that will switch the T2 to fully awake 3 minutes after the recording starts (because it needs to use DLNA)
The HDMI port is briefly activated when the box wakes from sby to recording sby. It's this brief activation that causes the issue.
 

Trev

The Dumb One
#15
@BH.
Who knows for sure? (rhet)
I have CEC switched off on my Sammy and it doesn't switch the input to the T2. I'll re enable CEC and set a schedule and see what happens just to make sure of my 'facts'.
 
#16
@BH.
Who knows for sure? (rhet)
I have CEC switched off on my Sammy and it doesn't switch the input to the T2. I'll re enable CEC and set a schedule and see what happens just to make sure of my 'facts'.
I don't think the HDR-FOX-T2 has any sort of CEC control, unlike the newer boxes. Some Panasonics auto select HDM1 on port activity. No idea about Samsung TV's.
 

Trev

The Dumb One
#18
Ah. Just tried switching on CEC on my Sammy and the results were not what I expected. Watching TV. T2 came out of S/B to 'look for' scheduled prog. It briefly came fully awake because it displayed the CF 3.1 on the front panel, then went back to half awake. The TV did not switch to HDMI1 as I was expecting. I then cancelled the scheduled recording, put the T2 to S/B then switched it on. It fully booted, but did not switch the TV to HDMI. It used to do this as it was damn annoying (as per the OP) if I was watching TV and switched on the T2, the HDMI switched and I was presented with the T2 boot up process. I'll reboot the TV and try again.
As I said above, Sammy have been screwing around with CEC control over the last few software updates, and I'm not certain where we are supposed to be at the moment. Over to AVF and the 7000 thread to find out.
 

Trev

The Dumb One
#20
Who mentioned anything about a blank screen? If the TV switches to the T2 for whatever reason, if the T2 is booting up, you have to wait until it has. You see the bootup screen that the T2 produces and have to 'suffer' this until it has fully booted and starts to produce the TV picture. My TV was switching to the T2 when I switched it on from what Humax call Off. It didn't do that when I tested this afternoon though.