1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Web Interface Fault

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by tobyjuggler, Feb 4, 2012.

  1. tobyjuggler

    tobyjuggler Member

    Hi there. I've been a bit of a lurker here for a while and have been using the custom firmware for about 5 months now. It's absolutely great, except now a problem has developed with the web interface and I'm hoping someone might be able to help. If I try and Browse Media Files or view the EPG or Settings I get the following error:

    "Runtime Error: /mod/var/mongoose/lib/system.class:72: in procedure 'header' called at file "browse.jim", line 211 at file "/mod/var/mongoose/lib/setup", line 13 at file "/mod/var/mongoose/html/lib/header.jim", line 19 at file "/mod/var/mongoose/html/lib/topbar.jim", line 9 in procedure 'system' called at file "/mod/var/mongoose/include/diskspace.jim", line 6 at file "/mod/var/mongoose/lib/system.class", line 72"

    I don't know what it means, but seeing something about disk space, I removed some of my media just in case and have over 300GB disk space (had plenty of disk space even before I did this though), reloaded the latest firmware and tried booting up with my external drive disconnected. I have pakages set up to autodownload updates. Any help would be appreciated. Thanks.
     
  2. Ezra Pound

    Ezra Pound Well-Known Member

    It would help to know if this is a 'happens every time' or 'happens occasionally and if I try again it is O.K.' type of error
     
  3. tobyjuggler

    tobyjuggler Member

    Ah right, sorry. The error is there permanently on all three pages. The others are okay and apart from the error, the only other visible object on the affected pages is the gray title bar. All other contents are missing. I've uploaded some screenshots.
     

    Attached Files:

  4. Ezra Pound

    Ezra Pound Well-Known Member

    Tobyjuggler:-
    That fine, I have seen messages like this sometimes but it usually works on a re-try, You obviously have a different problem. I don't think your problem is to do with diskspace, The error message is saying it hit problems when accessing the following JIM scripts:- browse.jim header.jim topbar.jim diskspace.jim. I'm afraid I'm not up to answering this but I know someone who probably can, The author of Web-If is af123, Hopefully he will be along soon and will be able to help you out
     
  5. af123

    af123 Administrator Staff Member

    I'm reading on the mobile so not up to posting anything long just now. The runtime error is being reported by the busy box du command though so I'll upload a diagnostic for you to run later to find out what is wrong. Interesting one!
     
  6. tobyjuggler

    tobyjuggler Member

    Excellent. Thanks both of you for your help. I can still access the Diagnostics pages, if running any of those diagnostics would help.
     
  7. af123

    af123 Administrator Staff Member

    Yes, please run the general and df diagnostics. I'm hoping that the second one will fail with an informative error message!
    Also, please look at the mongoose_error log in the same place, if there is one, and see if there are any error messages towards the end.
     
  8. tobyjuggler

    tobyjuggler Member

    Easier to screencapture than paste as code, so please see attached. I found something in the moodinit log that may or may not be of relevance, so have attached a partial screenshot of that too (the error carries on repeating itself for about 100 more lines after the cutoff of that screenshot).
     

    Attached Files:

  9. af123

    af123 Administrator Staff Member

    Could you re-run df ? I've made some changes to it. Something very odd going on here.
     
  10. tobyjuggler

    tobyjuggler Member

  11. tobyjuggler

    tobyjuggler Member

    Will do.
     
  12. tobyjuggler

    tobyjuggler Member

    New df diagnostic attached.
     

    Attached Files:

    • df.jpg
      df.jpg
      File size:
      34.9 KB
      Views:
      10
  13. af123

    af123 Administrator Staff Member

    and again please...
     
  14. tobyjuggler

    tobyjuggler Member

    Next one attached.
     

    Attached Files:

    • df.jpg
      df.jpg
      File size:
      99.8 KB
      Views:
      7
  15. af123

    af123 Administrator Staff Member

    Again? - curiouser and curiouser.
     
  16. tobyjuggler

    tobyjuggler Member

    Here you go. Would be interested to know what's going on if it's easy to explain to a layman :). If not, don't worry, of course.
     

    Attached Files:

    • df.jpg
      df.jpg
      File size:
      53.2 KB
      Views:
      5
  17. af123

    af123 Administrator Staff Member

    It looks like the file permissions on your busy box binary are wrong. I don't know how it can have got that way though.
    Otherwise your disk looks ok from what I've seen.

    Try df again and the see if the problem is fixed.
     
  18. tobyjuggler

    tobyjuggler Member

    Don't think it is!
     

    Attached Files:

    • df.jpg
      df.jpg
      File size:
      86.8 KB
      Views:
      8
  19. tobyjuggler

    tobyjuggler Member

    It is now. Not sure if it's anything you just did, but I might have done something to fix it. Having read what you just said about permissions, I browsed to the Humax disk from my PC and once I'd opened it the pages started working again. Does that make it even weirder?
     
  20. tobyjuggler

    tobyjuggler Member

    Ahh, you pushed a new busybox install?

    Edit: Ah, it's the same result as the previous one.
     

    Attached Files:

    • df.jpg
      df.jpg
      File size:
      82.2 KB
      Views:
      6