Webif problem after jim package upgrades

Brian

Administrator
Staff member
I have a problem with my HD-FOX T2 which came about whilst attempting to upgrade 3off jim packages this morning. I am now left with the following when I try to access the web interface.

webif.png

I have tried rebooting the box, stopping and starting mongoose, but seem to be stuck.
 

af123

Administrator
Staff member
That's strange. I did test the updated jim packages on my boxes without problems.

I'd suggest a force reinstall of the web interface and jim from the command line.

Code:
humax# opkg install --force-reinstall webif jim

IIRC.
 
OP
Brian

Brian

Administrator
Staff member
I have tried the force reinstall, and this has not fixed it. There are Segmentation faults mentioned, could these be the cause of my problem?

Code:
Humax HD-Fox T2 (humax0) 1.02.29/2.17
opkg install --force-reinstall webif jim
Removing package webif from root...
Removing package jim from root...
Installing webif (1.0.5-2) to root...
Downloading http://hummypkg.org.uk/hdrfoxt2/base/webif_1.0.5-2_mipsel.opk.
Installing jim (0.74) to root...
Downloading http://hummypkg.org.uk/hdrfoxt2/base/jim_0.74_mipsel.opk.
Package jim (0.74) installed in root is up to date.
Configuring jim.
Configuring webif.
Postinstall configure
Segmentation fault
humax0# Segmentation fault
Segmentation fault
 

af123

Administrator
Staff member
Yes.. if Jim is crashing with a segmentation fault then it would cause the problem.

Anyone else?
 

prpr

Well-Known Member
Anyone else?
Yes, it's well and truly fu^H^H broken.

How in the world do I downgrade? I tried:
Code:
humax # opkg --force-downgrade install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
but it just reinstalls 0.74
Attempts to download the above results in a file not found error. So how DO you find out what the old version is called?

Also, the http://hummypkg.org.uk/hdrfoxt2 site is bust, in that the "show files" and "Sources" links just give "Not found" errors. This used to work... :(

Also (2), this link works in a browser but not on the Humax:
Code:
humax# wget http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
Connecting to hummypkg.org.uk (89.248.55.76:80)
wget: server returned error: HTTP/1.1 403 Forbidden
What is going on here?
 
OP
Brian

Brian

Administrator
Staff member
prpr, are you saying that you have a similar problem since upgrading jim?
 
OP
Brian

Brian

Administrator
Staff member
The upgrades seem to have worked OK with my HDR-FOX T2's, so perhaps the issue is HD-FOX T2 specific.
 

Ezra Pound

Well-Known Member
Yes, it's well and truly fu^H^H broken.

How in the world do I downgrade? I tried:
Code:
humax # opkg --force-downgrade install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
but it just reinstalls 0.74

I would uninstall (remove) the curent jim and the install the one you want i.e.

Code:
opkg remove jim
 
opkg install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk

to get current status enter opkg info jim

Code:
humax# opkg info jim
Package: jim
Version: 0.73-1
Provides:
Status: install ok installed
Section: misc
Architecture: mipsel
Maintainer: af123@hummypkg.org.uk
MD5Sum: b18aabad050cfd63dd6ae3369021bef4
Size: 106614
Filename: jim_0.73-1_mipsel.opk
Description: Jim - lightweight TCL interpreter
Installed-Time: 1351099014
 
humax#

Having thought about it I'm wondering if your problem is that there is a 'set' of jim files e.g. jim, jim-binary, jim-sqlite3 etc. that have gone up to 0.74, they may 'depend' on each other so there maybe a specific order in which they need to be installed
 
OP
Brian

Brian

Administrator
Staff member
I tried to remove, and reinstall the previous jim.

Code:
humax0# opkg remove jim
No packages removed.
Collected errors:
* print_dependents_warning: Package jim is depended upon by packages:
* print_dependents_warning:    webif
* print_dependents_warning:    jim-binary
* print_dependents_warning:    jim-cgi
* print_dependents_warning:    jim-sqlite3
* print_dependents_warning:    jim-oo
* print_dependents_warning: These might cease to work if package jim is removed
.
 
* print_dependents_warning: Force removal of this package with --force-depends.
* print_dependents_warning: Force removal of this package and its dependents
* print_dependents_warning: with --force-removal-of-dependent-packages.
humax0# opkg install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
Downloading http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk.
Package jim (0.74) installed in root is up to date.
humax0#
 

prpr

Well-Known Member
I would uninstall (remove) the curent jim and the install the one you want i.e.

Code:
opkg remove jim
 
opkg install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
Well obviously I was trying that, but it wouldn't download due to those "403 Forbidden" errors.

I only (manually) upgraded Jim (in anticipation of problems) so the other dependent packages are still as they were.
 

prpr

Well-Known Member
I tried to remove, and reinstall the previous jim.

Code:
humax0# opkg remove jim
No packages removed.
Collected errors:
* print_dependents_warning: Package jim is depended upon by packages:
* print_dependents_warning:    webif
* print_dependents_warning:    jim-binary
* print_dependents_warning:    jim-cgi
* print_dependents_warning:    jim-sqlite3
* print_dependents_warning:    jim-oo
* print_dependents_warning: These might cease to work if package jim is removed
.
 
* print_dependents_warning: Force removal of this package with --force-depends.
* print_dependents_warning: Force removal of this package and its dependents
* print_dependents_warning: with --force-removal-of-dependent-packages.
humax0# opkg install http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk
Downloading http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk.
Package jim (0.74) installed in root is up to date.
humax0#
You need "--force-depends" on the "remove" line as it tells you.
Or "--force-downgrade" on the "install" line, but I don't think the latter will work anway.
Can you try downloading 0.73-1 with wget like I posted up-thread?
 
OP
Brian

Brian

Administrator
Staff member
I have downloaded 0.73-1 to my PC, but am not sure what to do with it. How do I use wget?
 
OP
Brian

Brian

Administrator
Staff member
Can I ftp the jim_0.73-1_mipsel.opk file to my box, and install it from there? If yes, where do I copy it to, and what command do I need to install it?
 

af123

Administrator
Staff member
As Ezra indicated, you can quite easily do

Code:
humax# opkg remove --force-depends jim
humax# opkg install --force-downgrade http://hummypkg.org.uk/hdrfoxt2/base/jim_0.73-1_mipsel.opk

without needing to use wget or transfer via a PC..

If anyone does still have a broken box, what happens if you just run jimsh from the command line?

Code:
humax# jimsh
Welcome to Jim version 0.74

(Control-D to exit)
 
Top